Num lock key off in start up
"Num lock" keyis off whenever I log offwindows. I'm using Windows 7 RC and I know that I have to edit the registry. Could anyone help me with this issue? Thanks in advancealfredpine
May 25th, 2009 8:05pm

I think most BIOS allow you to have number lock turned on or off at startup. Are you able to get into your BIOS settings okay?Regards from the Valley of the Sun.
Free Windows Admin Tool Kit Click here and download it now
May 25th, 2009 9:49pm

Hi, To do it, please take the following steps: Run Registry Editor. Move to HKEY_USERS\.Default\Control Panel\Keyboard. Change the value for InitialKeyboardIndicators to 2. Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows Hope it helps.
May 27th, 2009 6:49am

Thank you very much for your help. I have another problem. Maybe you can help me. My D-Link DWA-130 network adapter only allows me to connect at 150 Mbps, but specifications say 300 Mbps. I'm using the DIR-655 Extreme router.My computer is running Windows 7 RC. Could you help me with this? Thank you
Free Windows Admin Tool Kit Click here and download it now
August 13th, 2009 3:55pm

Thank you again Robinson. I got another one. My D-Link DWA-130 network adapter only allows me to connect at 150 Mbps, but specifications say 300 Mbps. I'm using the DIR-655 Extreme router.My computer is running Windows 7 RC. Could you please help me with this? Thank you
August 24th, 2009 12:03am

I have a similar problem. When I turn on my computer the number lock is always on. I would like it always off. I read your post and followed along OK until I got to changing the number. My initial Keybouard Indicator is not a single number, it is 2147483648. Any ideas? I am afraid to change it to just 0 in order to turn off the caps lock... I am not sure what BIOS is either. Thanks in advance to any help!
Free Windows Admin Tool Kit Click here and download it now
July 28th, 2010 2:19am

I was actually trying to reply to Robinson Zhang. I am trying to change my computer to have the number lock OFF when I turn it on. I read the post my Robinson on how to do it, but had trouble at the end. Where I should have a one didgit number I have the number 2147483648. I am sure a delightful person in Dallas owns this number, but I am not about to call it. Hahaha So any ideas on how to change my start up to have the number lock off?
July 28th, 2010 2:47am

I've found an interesting forum discussion on the numlock setting. http://www.technologyquestions.com/technology/windows-vista/133492-numlock-key-not-active-after-start-up.html "2147483648" is 0x80000000 in hex. It means something like 'leave states alone'. You can enable numlock at the login screen with "2147483650", which is 0x80000002 in hex, but you'll enter the decimal version as a string. Note that the HKU\.Default registry area is only for the System user or the login screen. You'll also have to change it in every user's ntuser.dat, or the Default ntuser.dat for new users.
Free Windows Admin Tool Kit Click here and download it now
September 15th, 2010 8:52am

i can't get numlock to be active by changing the number ind regedit, and there isn't the option in bios, anyone who has and solution to my problem it would help me alot, i use and acer laptop
October 14th, 2010 9:32am

i can't get numlock to be active by changing the number ind regedit, and there isn't the option in bios, anyone who has and solution to my problem it would help me alot, i use and acer laptop I have the same problem on an HP laptop. It is strange that HP seems to just ignore this problem.
Free Windows Admin Tool Kit Click here and download it now
November 14th, 2010 4:03am

i can't get numlock to be active by changing the number ind regedit, and there isn't the option in bios, anyone who has and solution to my problem it would help me alot, i use and acer laptop I have the same problem on an HP laptop. It is strange that HP seems to just ignore this problem.
November 14th, 2010 4:03am

My acer laptop has its number lock on at startup, despite it being off when it was shut down. I want it to always start with the lock off, but to be able to switch it on as required. As far as I can understand, JS2010's answer doesn't provide a solution to specifically this question. Or. at least, not one I understand. I can't solve this in the BIOS. I know how to edit the registry, but would be grateful for step-by-step advice on where to do this and in what way. Thank you for any help you can give.
Free Windows Admin Tool Kit Click here and download it now
April 14th, 2011 1:48pm

I would think num lock would be off by default: [HKEY_CURRENT_USER\Control Panel\Keyboard] "InitialKeyboardIndicators"="0"
April 14th, 2011 1:54pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics