vista desktop not loading properly (UAC problem?)
Hi I have just reinstalled Vista home premium after a hardware failure. It is completely up to date. At some point during the reload of all my applications something happened which now prevents the desktop loading properly, Search is not enabled, various links are not working, picture doesn't load, sidebar didn't load but does now. I can fix it by switching off UAC which I would rather not do. My sense is that there is a security issue with the desktop but I don't know very much in this are. (I found that I didn't have rights to the desktop folder which I thought strange but fixed that though it didn't fix the main problem.) Also another thread I found some people had found corruptions with the following registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinlogonShell = Explorer.exe " but mine is ok. Any suggestions really welcome thanks zzdpmjpr
March 3rd, 2008 4:28pm

Hi Do the icons appear on the desktop? How are you on functionality - can you click on the desktop icons? Go to Orb > All programs > Accesories > Run > Input eventvwr In the Event Viewer summary, can you see any critical errors? How about warnings?
Free Windows Admin Tool Kit Click here and download it now
March 5th, 2008 12:20am

Hi Many thanks for responding. I have done a lot of poking around since I posted. The major thing I have found seems to relate to permissions for my User name (John). Please note that John is an administrator account and has been from the start. An example is. If UAC is on when I get to the desktop many of the shortcuts in the Quick Launch toolbar have no icon and dont work. They all have administrator privilege but none specifically for John. When I try to view the security tab in properties I get To view these properties you need administrator permissions .(approx) . When I continue I get the UAC prompt and then get the security tab. I repeat my account is an administrator. The shortcuts in Quick launch that do work all have John as a named user with permissions. Similarly I have found folders I couldnt access (eg Desktop and some other folders in my standard user file structure) because I was not in the permissions as John. Similarly if I run a cmd prompt using Run as Administrator I get the UAC dialog even though it s an administrator account. There are several other places I get a UAC dialog unexpectedly. It seems to me, in my innocence , that my account, John, doesnt have the right set of privileges for an administrator. Many of the objects I should have access to as an administrator account I seem unable to access when UAC is on. I hope this makes sense. One small confession when reinstalling my long list of applications, some of the time UAC may have been switched off for my convenience. I got the desktop (and other) problems when I turned it back on towards the end of the reinstall sequence. I have looked at the event viewer and there is an occasional warning Event 1530 User Profile Service 1 user registry handles leaked from \Registry\User\S-1-5-21-1249328342-3511219507-2688458736-1000_Classes: Process 1032 (\Device\HarddiskVolume2\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-1249328342-3511219507-2688458736-1000_CLASSES But I am not sure that it occurs when I log in and have no idea what it means Any suggestions/observations hugely welcome. kind regards zzdpmjpr
March 5th, 2008 2:55am

Hi a further update By applying more permissions I am getting closer to my 'normal' environment. However when I run IE7 with UAC it won't let me access my home page, it slows down appreciably on other sites, and the processing of the favorites is very slow. I did a major reset to get a vanilla IE7but exacly the same. However ifI run explorer under 'run as administrator' it works perfectly smoothly and fast and I get my home page. !! My head continues to spin. regards
Free Windows Admin Tool Kit Click here and download it now
March 5th, 2008 10:00pm

Hi I think I am seeing the problem here. At some point your permissions got all tangled up.Is that the only username on your computer?We are going to have to take ownership over your User profile folder. Go to the orb > Accessories > Right-click on Command Prompt and run it as administrator. In the Command prompt window type in: takeown /F c:\users\john /RThat will make you owner of all the objects in your user profile folder. Do a reboot and tell me how things look.
March 5th, 2008 10:40pm

Hi & thanks for your response There is another standard user but with no problems. I ran the takeown command but some anomalies resulted. I didn't have permission to lots of folders (eg pictures !). A uac dialog came up to grant permission which went ok. I then found that the files in the folders were read only even though the read only box in the properties was not checked. My sense is that there has beenconfusion between the standard and administrator tokens in my account which is provoking confusion with some/many objects. Some base functions in Outlook I can't do unless I run outlook as administrator for example. I created a new account and copied the profile but though this removed some of the anomalies some others arose and I reverted. I might give this another go in a very controlled way but am not optimistic. My guess is that another fresh install will be the only way to resolve this. Please tell me I'm wrong! Kind regards
Free Windows Admin Tool Kit Click here and download it now
March 6th, 2008 1:51pm

Hi Reinstalling should be the last option. Tell me please, have you ever tried accessing from the other standard user account your "John" folder?
March 6th, 2008 6:20pm

Hi again The other account appears to have no abnormal access problems. It cannot access the John account which is what I would expect. the problem seemed to be getting worse and I was finding more and more objects for which I needed UAC control even though I owned them. My judgment was that I was spiralling downwards and wouldn't ever get out!! Having spent almost 10 hours trying to resolve ityesterday I bit the bullet and reinstalled. I now have a perfect, clean and wonderful system. One wonders, of course, just how long such an unusual state will last! Many, many thanks for your interest and help
Free Windows Admin Tool Kit Click here and download it now
March 7th, 2008 4:50pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics