XP file/printer connections to Vista cause events 2017, 2019, 2021
Hello, I havea small office network with a 64-bit Vista Ultimate file/print server that is accessed by various Vista and XP client workstations. Recently - and increasingly -the XP machines have been spontaneously losing their connections to the Vista file server. This started out as a minor annoyance about a month ago, but has escalated to the point where the XP clients cannot stay connected for more than 5-30 minutes. What I have found is: o When only using the Vista clients, the problem never occurs o Soon after booting one of the XP clients and logging in (which automatically maps a shared drive and connects one printer on the Vista file server), all XP clients lose their connections to shared folders and printers on the Vista file server o The XP clients can use all other network-based clients andprotocols (e.g. HTTP, FTP, RDP) to access the Vista file server, even after they have lost their connections to shared folders and printers o After the problem occurs, the XP clients can still use 'NET VIEW' to see shared resourceson other Vista clients. When using 'NET VIEW' to see the Vista file server, they receive a 1103 error "Not enough server storage is available to process this command" o Rebooting the XP clients never fixes the problem - they come back up with no folder/printer connections o Restarting the 'Server' and 'Computer Browser' services on the Vista file server(or just rebooting it) always fixes the problem; exsiting running XP clients can immediately start working again for a few minutes o The server is pretty stripped-down, from an application perspective. There is no anti-virus/anti-spyware/anti-spam/etc. software installed. I've stopped the 'Windows Defender' service, too, but the problem persists o Just before the XP clients become disconnected, the Vista file server gets several 2017, 2019, and/or 2021 events for the 'Srv' service in its event log. (I used the 'Attach task to this custom view' option in Event Viewer to pop up a message each time the 'Srv' service logs an event; I'm sitting right next to an XP client user, so it's easy to see the unfortunate chain of events that leads to the failure as it occurs.) I'm at the point where I have narrowed down the problem, but I have been unable to find any resources describing how to fix it. I would greatly appreciate your feedback recommending how to further diagnose - or, ideally, eliminate - this problem. Thank you, in advance. -Michael
March 4th, 2008 11:32pm

I'm having the same problem on an x86 system with shared folders in a Windows 2003 Server Active Directory Domain. All of a sudden started to happen (last couple of weeks). I've used Vista for months and never saw this issue. I recently applied Vista SP1. Are you running SP1? If not, I bet it is a recently releasedautomatic update that screwed up everything. One difference is that NET VIEW gives error ERROR_BAD_NET_RESP (58) "The specified server cannot perform the requested operation" for me when executed against the Vista client on a Windows 2003 Server. I agree that this annoying.
Free Windows Admin Tool Kit Click here and download it now
March 13th, 2008 12:35am

simdoc, > > Are you running SP1? > I'm running SP1 RC1; I don't have access to SP1 RTM yet. In my case, I don't believe that SP1 RC1 is the problem (at least not by itself). I've been using it for a few months and, on balance, it has helped more than it has hurt. My problems arose after having used SP1 RC1 (relatively) stably for a several weeks. Perhaps you're right that this is a result of some automatic update. I've been applying them eagerly as soon as new updates are available, as I'm holding out hope that they'll ultimately fix the myriad outstanding problems, large and small, that afflict my Vista machines each day. -Michael
March 17th, 2008 3:10am

I know what you mean, we cannot even use Windows SharePoint Services with Vista because of document history corruption. This is becoming somewhat annoying and I may end up opening a support case for it.
Free Windows Admin Tool Kit Click here and download it now
March 17th, 2008 3:58pm

Have you found a solution to this? I am experiencing a similar problem. I have two Vista boxes and three XP boxes on a peer to peer network. The first Vista box is sharing files. I can have all XP machines see and use the Vista share. As soon as I try to attach to the share from the second Vista box and transfer files, all of the XP machines loose their connection to the share. The Vista box that hosts the share gets error 2017. If I restart the server and computer browser service on the 1st Vista box, sharing works again until I try to use the share on the second Vista box. All PCs have the latest and greatest released versions and patches (XP sp2, Vista sp1). This is VERY annoying.
April 20th, 2008 1:07am

Olias88, Nope. I've recently installed Vista sp1 RTM (and, of course, all of the Automatic Updates since then) and the problem has become noticeably less frequent. I don't know whether this is due to sp1 itself, or to something else that I still don't understand. The problem still occurs, to be sure, but maybe only once per day. At this point, I'd classify the issue as an inconvenience, rather thana showstopper. Still, I'd love to both understand it and fix it for good. If you have any suggestions, I'm open to trying other solutions. Then again, I'm in the final stages of evalutating whether to roll back all of my Vista machines to XP or to switch over to Linux with an XP virtual machine (for my few windows-only apps), anyway, so it may become a non-issue in the next couple of weeks. After giving Vista a good 6 months and an honest effort to make it work, it just hasn't supported my business needs well. -Michael
Free Windows Admin Tool Kit Click here and download it now
April 20th, 2008 8:19pm

I've opened a support incident with Microsoft on this case. They think it has to do with too many client connections. I think they're barking up the wrong tree. For me, this is probably 10 or less. What about others that are experiencing this problem? How many connections do you think you have?
May 1st, 2008 7:25pm

simdoc, > > How many connections do you think you have? > I only have 2 XP machines, but 1 is powered down most of the time. So, effectively, I have1 client connecting, and experience the problem regularly. -Michael P.S. I'm still getting alert notices pretty regularly from the task I created in the event viewer. But, I haven't actually had a client lose its connection in a few days now. Again, other than automatic updates, I haven't done anything recently that would have made this better. -M
Free Windows Admin Tool Kit Click here and download it now
May 1st, 2008 7:48pm

That's what I suspected. They tried to install the hotfix in http://support.microsoft.com/kb/937082, but did not realize that it was already in SP1. Then they added the MaxMpxCt registry value and set it to 255. We'll see if that fixes it but I don't have much hope. I may be wrong. If you're not running SP1, the hotfix is required. Otherwise, MaxMpxCt is ignored.
May 1st, 2008 7:58pm

Hi, I'm also having this problem. My PC is running Vista Home Basic 64 bit with SP1. I've noticed that this problem is aggravated when I connect from a Macintosh computer to a shared folder in my Vista PC. I've tried the MaxMpxCt trick, and set it to 255, but it alleviates the problem only a little bit. My Event Viewer log is flooded with errors (2017 and 2021) Man, this sucks. And it sucks very badly. To me this means that I'll be forced to downgrade to Windows XP if the problem persists
Free Windows Admin Tool Kit Click here and download it now
May 9th, 2008 10:54pm

> > I've tried the MaxMpxCt trick, and set it to 255, but it alleviates the problem only a little bit. > My Event Viewer log is flooded with errors (2017 and 2021) > I haven't experienced any difference after having set this parameter, either.
May 10th, 2008 12:45am

Same here for the most part. It may be a little less but not eliminated.
Free Windows Admin Tool Kit Click here and download it now
May 10th, 2008 5:58am

For those that are experiencing this problem with me, what antivirus software are you running? I've also noticed that occasionally my McAfee 8.5.0i has stopped running. I noticed it occurred today at the same time this sharing problem was encountered. I don't know if I have seen this same synchronization of events in the past or not, but I do know that McAfee does stop running at times. I wonder if there is any relationship here or not.
May 16th, 2008 6:26pm

simdoc, o XP client: o Was ZoneAlarm (can't remember version; current as of last year, though) o Is now Kaspersky Internet Security (KIS) 7 o Vista server: o Was nothing o Is nowKIS7 I tend to think that the anti-virus software is unrelated to the problem on my systems. At its worst a few months ago, the server had no anti-virus software, and I disabled Windows Defender, just in case. Since then, things have improved, seemingly on their own. During this period of improvement, I've re-enabled Windows Defender and have installed KIS 7 on the server. These action neither made the problem better nor worse. Throughout, I have not had any problems with KIS 7, itself. (On a probably unrelated not, however, I cannot use Vista file backup when KIS is running without receiving a fatal volume shadow copy service error. But, KIS seemsfine, and the original XP problem persists at its usual frequency independently of this.) -Michael
Free Windows Admin Tool Kit Click here and download it now
May 16th, 2008 6:38pm

All, I've been holding off on saying anything because I didn't want to get the discussion off track. But, the pattern seems to consistent to ignore, so I'll throw this into the mix: I think the same problem is occurring with a Vista client and my Vista file server. o Is this happening for anyone else with Vista on both sides (client and server)? When I transfer large amounts of data for extended periods, I get the same popup warning for the Srv service that I set in my Event Viewer back at the beginning of the thread. At that point, my Vista client loses all connectivity to the Vista file server - and, in most cases, it freezes solid. I can move the mouse and, on some occasions, interact with the Task Manager. Every other app appears totally hung (i.e. they get that washed-out white look that Vista does when something is hosed) and cannot even be killed with the Task Manager (I'd like to open cmd.exe and get rid of them with killp, but I can't even lauch a new command prompt). To give you an adea of what I mean by 'large', I was just trying to make about 30 .zip files for a total of 13G in size. I was using a program called PowerArchiver, which lets you queue up a buch of files and churn through them without stopping for any human interaction. This consistent I/O load causes the disconnection pretty reliably (at least something about Vista is proving to be reliable for me). I'm curious as to whether this is the same problem or a different problem with the same symptoms. Just wondering if anyone else has seen the same. Thanks. -Michael P.S. I downloaded Fedora9 yesterday. I'm going to set it up on the same machine that I'm currently using for my Vista file server and see if it can provide any better reliability for my mixed XP / Vista office. It'll take me a few weeks to get this rolling, because I need to mentally port my Solaris skills to Linux, but I'll let you know how it goes. -M
May 24th, 2008 9:16pm

Iget the freezes you're talking about but I just don't know if I can pinpoint that another Vista system is causing them or something else entirely as our systems are moderately loaded with activity. In my case, we have Win2003 Servers and we use pier-to-pier networking within my group which consists of about 15 people in addition to domain networking. There is a mixture of operating systems (XP/Vista/x86/x64) in play here with some people using multilple systems. For me I have not found a Vista machine from being unable to access shared folders on another Vista machine, but I frequently see this with XP & Windows 2003 Server. Microsoft has obtained some logginginformation from my system and they want to do some more probing. I'll see if anything significant comes of it.
Free Windows Admin Tool Kit Click here and download it now
May 27th, 2008 4:32pm

Has anyone figured this out yet? I've been waiting for Microsoft to help me with my support incidentbut I'm finding more and more recently that their tech support is lowsy. It used to be good. All the outsourcing has led to individuals who know little about their products. I have several outstanding Vista related technical support incidents open and none are making progress. Maybe it's time to switch OS'es.
June 13th, 2008 11:24pm

simdoc, > > Has anyone figured this out yet? > No. Truthfully, I'm not actively pursuing this anymore, either. The preponderance of evidence from my own experience show that Vista is not the right OS for my office. I'm in the process of slowly migrating my servers to Linux, and my desktops back to XP. I'll probably keep a copy of Vista around as a virtual machine or on a dual-boot workstation just to keep tabs on it. It's too flaky and slow for production use, though, even with sp1 and the deluge of subsequent patches. On another note, I'd like to provide some additional information regarding one of my previous posts. I do not believe that I'm observing this behavior with Vista-Vista, only with XP-Vista. I've found that my Vista-Vista problem is due to the Vista client losing all network connectivity during heavy synchronizations with Sync Center (i.e. back-to-back syncs, one sync with lots of changes). When I first read up on the new Sync Center before upgrading to Vista, I was excited at the new features and performance it promised to offer. After having used it intensively since last October, however, I've found it to be so unstable and so slow that I'm currently syncing my most imortant files with a third-party tool. XP Offline Files might have been slow, but at least it worked. Good luck. I hope you find a solution that works for you. -Michael
Free Windows Admin Tool Kit Click here and download it now
June 16th, 2008 6:55pm

I'm not having Vista-to-Vista problems either. Only XP and Windows 2003 Server to Vista problems.
June 16th, 2008 7:07pm

I'm getting the same event ID's when trying to copy 1GB files (DVD vob's) from an Ubuntu 8.04 machine to Vista x64 SP1 Enterprise in a workgroup setting. I do NOT get the error when copying even larger files from Vista to Ubuntu.The only way I can get any Samba connections to work is if I restart the Server service on the Vista machine. I tried the MaxMpxCt registry key, set to 255, with no change. I use ClamWin AV, so there is no realtime AV scanner to interfere. If I can offer another perspective using Samba I would be happy to help to get this problem resolved. Until then I will use NFS for Ubuntu->Vista transfers, thanks to Microsoft for including built-in NFS support with Vista.
Free Windows Admin Tool Kit Click here and download it now
June 19th, 2008 4:59pm

The problem is related to SMB so it's not unexpected that Samba would also experience problems.
June 19th, 2008 5:05pm

I have had the same issue - system event log full of error 2017 - driving me NUTSCheck out this thread - I had had it in place now for a few hours and have not seen event ID 2017 Appears to be a bug with SMB2 (upgraded version of SMB that is new to Vista)http://www.hardforum.com/showthread.php?p=1032714322Fingers crossed!
Free Windows Admin Tool Kit Click here and download it now
July 20th, 2008 1:24pm

I have this issue. It started when I replaced my Vista x86 system with a new Vista x64 system. The error is seen when the XP client starts scanning for updated music files shared on the new machine. I have done many searches and tried many of the suggestions listed here and other places yet no relief. Any assist in trouble shooting and resolve the issue will be appreciated.
December 14th, 2008 10:46pm

OK did some testing. I am able to recreate the issue at willfrom either a Vista or XP client. All I need to do is run a program called "iTunes Folder Watch" and it will cause a ton of the srv 2021 warnings on the Vista x64 machine sharing the music files and ultimately the dreaded srv 2017 error. I can also generate the srv 2017 warningson Vista x86 sharing files too but the srv 2017 error never happens. Does anyone havean idea of what to do now?
Free Windows Admin Tool Kit Click here and download it now
December 14th, 2008 11:33pm

Help !I'm having the same problem here, and the reg key disabling smb2 doesn't fix it !Does anybody have a solution for this ?My file server is a Vista Business 32bit SP1 with 4GBSoftwares installed : Acronis True Image 2009, Cobian Backup, AVG free
March 12th, 2009 2:26pm

I am having this problem with either XP Pro x64 or Vista Business x86 as the server, and XP Pro x86 as the client. Has anyone noticed if SP2 fixed this? If it doesn't, I'll try disabling SMB2 as well. My method to recreate this problem is to attempt to copy lots of small files (millions) from the server. I get the srv 2017 events after 16-20 hrs. What's notable is that I got this problem with XP as the server.
Free Windows Admin Tool Kit Click here and download it now
June 16th, 2009 5:55pm

Service Pack 2 seems to have resolved the issue on my vista machine.
June 18th, 2009 11:39pm

Vista x64 SP2 did not fix this for me. I still have this exact problem.
Free Windows Admin Tool Kit Click here and download it now
July 12th, 2009 6:50am

Hi all, It's been a while since I've posted to this thread and, in this case, no news has been good news (you can imply, then, what today's news means). When Windows 7 RC1 was released, I upgraded one of my Vista machines in desperation - and it fixed all sorts of problems, including the ones described in this thread. I subsequently upgraded others to Windows 7 RTM, and have had relatively smooth sailing since then. Windows 7 turned out to be the Vista service pack I'd been waiting for. Unfortunately, the various Windows OS (including 7) that I've used for my business have been so problematic and so unstable for so many years, that I've committed to moving off of Windows as a host OS entirely. I'll run it as a VM for the Windows-only apps that I need (and there are a lot of them), but I need a better primary OS so my whole machine(s) doesn't come crashing down each week (or day, or few hours, ...). To that end, I've been configuring our first iMac for the last month or so to replace one of our Windows workstations. The office's primary file server is still a Windows 7 Ultimate computer, though, so I'm sharing drives in both directions and synchronizing updates using various third-party programs. (I also have a new motherboard sitting on my desk for the Ubuntu machine that is going to replace this Windows 7 file server, as soon as I'm done with the Mac :). For about 3 weeks, things have been going pretty painlessly on that front - until two days ago. Out of the blue, I started receiving another blizzard of 2017 errors - way more than I'd ever seen in the past. For the past few days, I haven't been able to keep any client - XP, Windows 7, Linux, Mac OS - connected to a shared drive on the Windows 7 file server for more than a few minutes at a time. I'll spare you the ensuing drama and fast forward to the root of the problem: heavy file I/O on the Windows 7 shared drive that was initiated by the Mac caused a deluge of 2017 errors that brought down the Server service. Fortunately, I came across a solution that seems to have fixed the problem: http://www.kombitz.com/2009/09/23/windows-7-file-sharing-crashes-srv-2017-error/ I added the 'MaxNonPagedMemoryUsage' key and chose an arbitrary value of 0x04000000 (the article recommended 0x02000000; I was hoping that twice as much memory would be twice as stable). After adding the new key, I restarted the Server service and immediately started synchronizing several gigabytes of files between the Mac and Windows 7, using a Mac-side sync program. I got one 2017 error right at the start, but no loss of connectivity. For the last hour, the Mac has been blazing away with activity on the shared Windows 7 drive and all clients in the office have remained connected. I have to confess that I don't totally understand what the MaxNonPagedMemoryUsage parameter does, but I'm not going to look the gift horse in the mouth until I'm done with this round of file transfers. Hopefully, if any of you good folks are still encountering these issues, you'll find that this fix works for you, too. FWIW, I also have the SMB2 key set to '0', as some other posts have mentioned; that's been set all along. Good luck; I'll let you know if there is any change in behavior on these systems. -Michael
January 10th, 2010 8:10am

Solved - I think I finally found a reference that looked like the answer. The shares on my win 7 box kept becoming unavailable from XP boxes, and I was generating zillions of error 2017s in the System log of the windows 7 machine. On my windows 7 machine I used regedit to increase the size of a parameter: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters the parameter was Size - and value was set at 1 . I changed the value to 3 . Since this change, I have had no incidences of error 2017, and have had no problems accessing shares on my win 7 box from xp clients.
Free Windows Admin Tool Kit Click here and download it now
January 27th, 2010 7:14am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics