Wireless networking not connecting to linux smb shares or http
Hi, For some strange reason if I connect wirelessly to my home network using my vista laptop I cannot connect to my linux box shares or to the http webserver. However if I connect via the LAN I have no problems whatsoever. Has anyone got an answer? I have disabled autotuning, iplayed around with NTLM authentication with no difference. The linux box is also using the the latest samba files 3.xxxx. Thanks for any help. David
March 18th, 2008 2:48pm

Hi David, I have the same problem. In my case I have an Linksys NLSU2 NAS and a local webserver (IIS5). I can't connect to the local SMB shares and to my local webserver. I hava no problem connecting to the internet and browsing around the world... Haven't you got any reactions at all? thanks, Joost
Free Windows Admin Tool Kit Click here and download it now
March 18th, 2008 5:02pm

No not yet. Can I just confirm is the problem with wireless access ONLY? You can access your nas via the LAN?
March 18th, 2008 8:02pm

Hi David, Before we go further, I would like to confirm the following points with you: 1. Are the shares and HTTP websites hosted by the same Linux computer? 2. When the Windows Vista laptop uses wireless connection, is the laptop connected to the Linux computer directly or through a wireless AP? If they are connected through a wireless AP, is the Linux computer used wireless or wired connection? 3. What is the exact wording of the error message when the Windows Vista laptop accessed the shares or websites? Thanks. I look forward to your reply.
Free Windows Admin Tool Kit Click here and download it now
March 20th, 2008 9:29am

Hi Joson,1. Yes the shares and http websites are both on the same linux box. The http website is SWAT the Samba Web Administration Tool.2. The linux box is connected to a wireless/modem/router via the lan. The router is a Thomson Speedtouch 7163. When connecting to the network shares, I can see the top level folders(Not sure if this was there because I was connected via the LAN), I then navigate to a subfolder and I will get a very long timeout, which then comes up with an error "L:\Apps is not accessible. The specified network name is no longer available"When I connect via http I am prompted to enter my username and password, then the browser sits there waiting for a reply and does not timeout.I have even tried connecting using the IP address with no joy.I have also just upgraded to Vista SP1 and the same problem still exists.Kind RegardsDavid
March 20th, 2008 4:46pm

David, In my case the only thing on my private network I can connect to is my routers ip-address. Which is a SpeedTouch 780. I think it's mostly a authentication issue. Aren't there any security policy settings that must be loosened up a little? (i'mjust thinking out loud to see if you are thinking the same things because i'm really out of possibilities here.....) Hope there is anyone elsethere who can help us. Greetz, Joost
Free Windows Admin Tool Kit Click here and download it now
March 22nd, 2008 12:00am

Joost, I am a little confused as to what your problems is? Sounds to me like this is a different issue altogether? I do know IE7 has a problem connecting to the Speedtouch Admin web page,using Firefox however is a workaround. As to my previous question i did not see a response?
March 22nd, 2008 3:52pm

dvkwong, Sorry i didn't answer your question. Yes, my problem only exists with a wireless connection. I just found out that I can "mark" my connection as "a private network connection" but still I can not browse through my shared folders on my NAS. I can see the shares, but as soon as there are files in the share I am opening, the explorer pops up a message which says that "the network location no longer exists" (the best translation from the Dutch message... ) And strangely, I still cannot access my local webserver which hosts my Novell Groupwise 7 WebAccess application. Really weird... I tried to make a connection on my private network with all the security settings which are suggested by Vista, and without those tight security settings (firewall off, no security updates installed) but still no connection. Changing the NTLMv2 setting in the registry doesn't help to (the [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa] key). Strangely I CAN connect to my Speedtouch Admin web page WITH IE7.... I'm getting completely lost by this behavior. The admin web page also is a private ip-address.... I did everything by the book as far as i'm concerned... but still no results. I hope this clears up a few things as to what my problem is. I think it comes close to what your problem is with private network connection. I hope someone can help us. Greetz, Joost
Free Windows Admin Tool Kit Click here and download it now
March 22nd, 2008 6:52pm

Hi dvkwong, I did some searching in microsoft forums and found this: http://windowshelp.microsoft.com/communities/newsgroups/en-us/default.mspx?query=password+sharing+on+nas&dg=&cat=&lang=en&cr=US&pt=&catlist=D1CBF0BD-E8EE-4D73-8ECC-15AF7EC6783B&dglist=&ptlist=&exp=&sloc=en-us look for this article: Accessing other XP machine and NAS from Vista in Network & Sharingfrom 1/31/2008 6:00 AM PST I think this is pretty much the same issue. And the guy that posted the message is also using a speedtouch router. Turns out there is a "Windows Scaling" problem. Also go to this article: http://support.microsoft.com/kb/934430 Me, i'm not sure. But it could be the problem. I'm not sure i'm getting the idea of the "Windows Scaling problem".... Greetz, Joost
March 22nd, 2008 11:22pm

Joost, It seems a little bit of a coincidence that we both have the same router make,I think just to eliminate all hardware I am going to try a different wireless router altogether ala Linksys WRT54GS andd see if that makes a difference. Unfortunately a friend is borrowing it at the moment so can't run the test for about 2 weeks or so. Had a look at the links, the one about the autotuning I have already done, and the other I am not sure as they can't access shares across the LAN. The MOST bizarre thing about this whole situation is that we can access the shares/http serverfine via the LAN BUT wireless is a no go......sigh David
Free Windows Admin Tool Kit Click here and download it now
March 23rd, 2008 4:08am

Same thing here: 1) Notebook: Windows Vista Home Premium WAN: Intel Pro Wireless 3945BG LAN: Realtek RTL 8168B/8111B 2) Modem/Router Speedtouch 780 (Thomson) Firmware: 3) MyBookWorld NAS 4) Dreambox (SatTuner) Connections by LAN - OK Connection to Internet by modem, http, pop3, imap - OK Connection to NAS, filesystem, http - OK Connection to Dreambox, http - OK Video stream (VLC) from Dreambox Connection by WAN - ERR Nowebpage from NAS, http(IE and FireFox) - ERRCan see filesystem on NAS, but cant access, or drops connection, or timesout on files - ERR No webpage from Dreambox, http(tested IE en FireFox), return nothing, or empty pages - ERR No videostream (VLC) from Dreambox - ERR Telnet connection on Dreambox, stops responding - OK Browsing the internet, http, pop3, imap Disabled autotuning, has no result, the problems still exists (netsh interface tcp set global autotuning=disabled) The whole setup works perfectly fine using another laptop: Toshiba Notebook Windows XP Intel Pro Wireless 3945BG To my opinion Vista uses some TCPIP features on the WAN which causes problems on the Router/Modem towards LAN connected devices. It could bea router/modem problem, but what are the parameters I can change on Vista to make it all work like Windows-XP? Wan is using 802.11b/g and WPA2 encryption ps. There should be an update firmware for the Speedtouch 780where this problem is tackled. I will install it, and put here my findings. ps. ps. Upgraded firmware of SpeedTouch 780 to version and all is working without problems. My case is closed, good luck for others on this subject.
March 23rd, 2008 10:31am

Alphons,Seems is comes down to the Thomson Speedtouch 780 modem/router, maybe in combination with a Intel Pro Wireless 3945BG... at least in our situations. Updating the firmware is a bit tricky in my case, because i have VIOP on that modem... but if it solves the issue, I guess i should give in a try... Thanks for your input here!Greetz,Joost
Free Windows Admin Tool Kit Click here and download it now
March 23rd, 2008 3:16pm

Hey Joost, Alphons,I just remembered that I have XP also installed on my laptop so I booted to this environment and what do you know the wireless everything works perfectly! Something definately wrong with Vista.........Still it would be good to test with another router and see what happens.David
March 23rd, 2008 7:55pm

Joost77 wrote: Updating the firmware is a bit tricky in my case, because i have VOIP on that modem... Joost Hello Joost and David, I also haveVOIP on my modem,and people can still phone me after this upgrade;-) I used a Windows XP machine to update the firmware, just to be sure everything goes well. 1) First I made a backup of the configuration file before updating and restoring the config file afterwards. Home > SpeedTouch > Configuration > Backup & Restore I used this link for the upgrade software. 2) http://www.speedtouch.nl/downloads/780_Upgrade_R62T2_sip.exe Make sure you connect directly to a lan port (not wireless) and give your lan adaptera static IP address like: IP: MASK: GTW: 3) Execute the upgrade file, and wait some minutes to let it do the job. 4) When ready, go directly to and restore the file you backed up under 1. 5) Ready. Vista should work using WAN. The firmware now should say: Hope this will help a bit. ps. I just restored some XP backup file of 40GB from my NASto Vista, using the "Windows NT Backup - Restore Utility", and can watch streaming video from my Dreambox. So it works.
Free Windows Admin Tool Kit Click here and download it now
March 23rd, 2008 8:10pm

Hi All,I tried 2 differing firmware versions for my 718 router. (Officially supported by my isp)(Current) and6.2.17.5 (This I got from the thomson uk website)(Voip stopped working)Both versions still had the same problem, maybe I need to try the exact but I can't see this having major differences?Will see if I can download the exact firmware version.David
March 24th, 2008 11:04pm

Hi, I did some more googling and came to this link... : http://www.sqweek.com/sqweek/index.php?p=0 I'm not at home richt now, so I don't know if it actually helps in our case... but maybe it will. Greetz, Joost
Free Windows Admin Tool Kit Click here and download it now
March 25th, 2008 5:46pm

Well, I think we are there!! The article of the above link is the solution... This is what does the trick for me: ============ First start an administrator console by entering cmd into the searchbox on the start menu and then do ctrl+shift+enter instead of just enter. In the console enter the following commands to change the MTU: netsh interface ipv4 show interfaces Take note of the id number of the wireless interface. netsh interface ipv4 set subinterface id mtu=1460 store=persistent ============Doesn't even need a restart.Good luck!Greetz,Joost
March 25th, 2008 9:33pm

However the MTU settings could do the trick, the error is in the firmware of the Speedtouch. The firmware does not work on Vista and WAN, you have to use!! greetings.
Free Windows Admin Tool Kit Click here and download it now
March 25th, 2008 9:39pm

I know!! But it works for me?! Gr, Joost
March 25th, 2008 9:57pm

When it works, don't touch it!, hahaha. However not related to Vista, I discovered a problem when VOIP (SIP)on SpeedTouch 780is not on the default port 5060. For example, when SIP is using port 38383, You have to telnet to the SpeedTouch 780 and issuing these commands. (Using userid Administrator and hitting enter (blank) for password) connection unbind application=SIP port=5060connection bind application=SIP port=38383service system modify name=VOIP_SIP port=38383saveallsystem reboot This prevents SpeedTouch 780 from denying incoming (UDP) sound packetsby its firewall. It shows up in the log file as: "Feb 28 19:10:19 IDS dos parser : udp flood (1 of 1) : xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 0200 UDP xxxx->xxxxx" or FIREWALL replay check (1 of 1): Protocol: ICMP Src ip: xxx.xxx.xxx.xxx Dst ip: xxx.xxx.xxx.xxx Type: Destination Unreachable Code: Port Unreachable I think most of the problems are covered now, but I wanted to share this information for future visits of other problem-solvers. -Alphons.
Free Windows Admin Tool Kit Click here and download it now
March 28th, 2008 3:24pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics