Wireless Adapter problems
My Acer Aspire 4820TG runs Win7x64, and has an Atheros wireless adapter (and I've checked for updated drivers). It will pick up other networks and connect, but since this morning it no longer will connect to my home (DLink) wireless router, not even when using a patch cable! It just does not recognise it - however, before thinking 'oh, it's the router', my wife's HP laptop that I am currently using is attached to said same troublesome router and working fine!! 2 System restores on my laptop have failed... Error code I get from troubleshooting wireless is;- Association status: Fail 0x00038002 Association reason code: 0x00000002 Can you help, please? regards, Andy
February 7th, 2011 8:25am

That wireless error usually means there's too much interference and/or it can't find a reliable channel. Resetting the router or re-orienting it's antenna might help. Try disabling your laptop's wireless (there's usually a switch or hotkey somewhere) before you connect with the wire and try the wire again. If it still won't connect, what error do you get? Is the machine even getting an IP address from the router?
Free Windows Admin Tool Kit Click here and download it now
February 7th, 2011 9:36am

I have recently had similar problems and the same error in terms of Association fail when looking at the detail off the back of the main error which stated couldn't connect because of hidden network. Did lots of googling and also used this forum, excellent advice here so thought I would also share my thoughts. I have sort of corrected my problem wireless network connectivity problem. Say sort of as the connection does occassionally drop off but comes back within a minute or so. By the way I have a Billion wireless n router and sony vaio using an Atheros wireless adaptor. You could try all or some of the following (apologies for any misuse of tech speak, but I've had to learn a lot over the past 2 weeks: - Update firmeware for wireless router (reset to factory settings then update). Consider putting MAC code from adapter into router settings. This seemed to be the main things which helped for me. Get code by using ipconfig/all in command prompt, the adpator physical address is the MAC code. If using WEP authentification change to WPA. Consider changing wireless access point channel on router to avoid interference from other devices. - Update / reset driver for adapter - if it says its using the latest remove/delet driver then re-install. - Try manually setting up wireless connection rather than using wizard. - Noticed that microsoft virtual wifi miniport adaptor had disappered when I started having problems, but when it suddenyl came back things started working again. When disabling adaptor and re-enabling you'll notice it disappears and comes back even though it is not used / connected. Not sure if this had any bearing on my problem. - Go into adapter settings and untick IPv6. - Disable Bonjour program in start up menu. People talk about problems when updating itunes and I must admit I started having problems when recently set it up on my new laptop. Above should give you a head start or may resolve your problem. If you need any more detail just google or use this forum to find exactly how to do. There's plenty of advice out there, and network connectivity seems to be a common problem, especially wireless. Must admit mine worked ok when using hardwire, so enabled me to easily do some of the things above. Took me a fair few hours to solve. Hope it helps.
February 7th, 2011 2:18pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics