Windows cannot connect to printer 0x0000000d (Windows 7)
I've connected a Canon MP640 via USB to PC running Vista. My PC (running Windows 7 Professional) is connected to this PC over a wireless network. Every time I try to add the printer I get error 0x0000000d Windows cannot connect to Printer. I had another Canon mp640 connected this morning which I have been connected to and printing fine from for 6 months. Something broke on that printer so I replaced it with a brand new mp640 and now I can't connect to it! I've tried everything listed in other related topics but I'm still getting the same error. Please can somebody help me!
August 4th, 2010 11:04am

This issue occurs because the following registry subkey on the print server contains invalid data: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3\ \Previous Names Please modify the value of the Previous Names registry entry on the print server so that it contains valid data. 1. Click Start 2. Click Run 3. Type regedit 4. Click OK. 5. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3\ 6. On the File menu 7. Click Export. 8. In the File name box 9. Type printerName 10. Click Save. 11. Right-click printerName.reg 12. Click Edit. 13. Locate the sentence which starts with the "Previous Names" string, and then replace the sentence with the following text: "Previous Names"=hex(7):00,00 14. On the File menu 15. Click Save. 16. Exit Notepad. 17. Right-click the file that you saved in step 10 18. Click Merge 19. Click OK. After that, restart the Print Spooler service by the steps below: a) Click Start b) Type services.msc in the Start Search box c) Click services.msc in the Programs list. d) If you are prompted for an administrator password or for confirmation, type your password, or click Continue. e) Right-click Print Spooler f) Click Stop. g) Right-click Print Spooler h) Click Start. If the issue persists, you can also try the suggestions in this thread: windows cannot connect to the printer.error 0x0000000d Hope this helps. Regards, Linda Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
Free Windows Admin Tool Kit Click here and download it now
August 6th, 2010 5:29am

Linda, I encountered the same problem and try to follow your steps to fix the problem. However, when I reach step number 10 where you instruct to click Save, the dialog box disappears. Am I to click on Export again so that I have access to the printerName.reg file? If so, I proceeded with the next few steps after I right clicked on that file and I did not locate a line that started with "Previous Names". Please advise on where I went wrong. Thank you, Roger
September 15th, 2010 3:14am

I got the same error message when I was using Vista computers, and the solution was to turn off "Render Print Jobs On Client Computers" under the host share. Then the error went away on the client computer and the printer added fine. I got the solution from Pentikllr on this site.
Free Windows Admin Tool Kit Click here and download it now
November 14th, 2010 1:58am

Linda, This really worked for me with my CANON MP490 Series Printer. Thanks, JimI can do it
September 11th, 2011 9:04pm

Hi, You might face a printer connection error if there are any connection issues in the hardware. If the hardware is not connected properly then it would come up with such issue. You need to make sure that the printer is connected with the correct cables provided by the vendor at the time of purchase. This would remove the possibility of printer connection issues in the network.
Free Windows Admin Tool Kit Click here and download it now
September 27th, 2011 9:47am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics