Windows 8 Updates fail
KB 2769165 and 2770917 fail to install on Windows 8 Pro
November 19th, 2012 8:43pm

Do a clean boot and try to install the updates:

If this doesn't work, we must look for error messages in the following log files:

Please run the Windows Explorer and go to the folder "C:\Windows\Logs\CBS\" and copy all files to your document folder, also copy the from the folder C:\Windows\Inf, the "C:\Windows\WindowsUpdate.log" and the file "C:\Windows\winsxs\poqexec.log" to your document folder (otherwise you can't upload it), zip all files into 1 ZIP and upload the zip to your SkyDrive [1] and post a link here.



Free Windows Admin Tool Kit Click here and download it now
November 20th, 2012 12:15am

And then what?  I have three of the 5 instances of Windows 8 I have upgraded to failing at this time.  I have run the troubleshooter and it appears to be cleaning out the windows update database as part of the process, but that has no effect or impact.  Can an update be applied that fixes this update process which appears to be botched worse that it was for 7?  I really don't wish to spend hours debugging something on these machines that have just been upgraded and frankly should not be having issues with updating at all...


December 28th, 2012 7:26pm

upload the required logs if you have issues installing updates.
Free Windows Admin Tool Kit Click here and download it now
December 29th, 2012 11:49am

There are many issues with MS failing to update.  I have an open case # with MS tech support and have spend hours on hold with MS "tech support" and they are still unable to help me with an issue that happened after a failed windows update.  The computer now tells me in one place that my copy of windows is valid and in 3 others that it is not.  It will not allow the licence to be altered and will not allow system restore to go back to a previous state (system restore).

I am so disappointed that the only solution given is to wipe out all of my data and 3rd party programs and re-install the system from scratch.  After 8 hours with tech support controlling my machine, this is their only solution to a MS created problem...very makes it hard when my apple fanboy friends ask me how it is going with my Windows 8 experience....I'm beginning to think that they are right!

January 8th, 2013 9:24am

also share the log files so that I can take a look.
Free Windows Admin Tool Kit Click here and download it now
January 8th, 2013 5:37pm

If Windows Update is failing, especially if the Win8 install was an Upgrade from a prior Windows OS, do the following:

Command Prompt, Run as Admin

DISM.exe /Online /Cleanup-Image /ScanHealth


After that finishes...

DISM.exe /Online /Cleanup-Image /RestoreHealth


Reboot & retry Windows Update

January 13th, 2013 2:19am

Hi Andr,

I recently purchased a new Lenovo Ideapad pre-installed with Windows 8. I soon started having problems in the update process like others have mentioned. Here is the link to my log files, can you help me figure out how I can fix it?

http ://


Manu Goel

Free Windows Admin Tool Kit Click here and download it now
January 23rd, 2013 2:43am

Have any of you tried using the (possible) solution, FIX, I offered w/ the command line that starts DISM?  See back in this thread a wee bit.  should have been marked as an answer, already... especially, since it was supplied to me by MS Tech Support & does work.

January 23rd, 2013 6:41am

You get a 0x80071a90 - ERROR_TRANSACTIONAL_CONFLICT error for the files explorer.exe and helppane.exe:
2013-01-22 18:05:54, Error                 CSI    00000021 (F) Error: ResolvePendingTransactions called after poqexec failure (call 1)
  Status = STATUS_TRANSACTIONAL_CONFLICT, Operation = SetFileInformation, DiagString = [l:74{37}]"\??\C:\windows\HelpPane.exe, N/A, N/A"

2013-01-22 18:05:55, Info                  CBS    Startup: Changing logon timeout to a static timeout: 10800000
2013-01-22 18:06:12, Error                 CBS    Startup: Primitive operations failed, startupPhase: 0.  The transaction will be cancelled. [HRESULT = 0x800f0921 - CBS_E_PRIMITIVES_FAILED]

1cdd7f43a23dbc8: 84c, c0190001, 2aa, 0, SetFileInformation ;\??\C:\windows\explorer.exe, N/A, N/A
1cdf45b7f2527a1: 84c, c0190001, 9e, 0, SetFileInformation ;\??\C:\windows\HelpPane.exe, N/A, N/A

To fix it, delete all files (*.*) from C:\Windows\System32\config\TxR, next run

fsutil resource setautoreset true C:\

Don't forget to set the folder options to show all system and hidden files otherwise the TxR directory will look empty.
Free Windows Admin Tool Kit Click here and download it now
January 23rd, 2013 8:45am

This issue can be fixed temporarily by turning off the checkbox for 'Check for Microsoft Updates'.  Those would be for things other than windows.  Strangely, when you select this to not check (by default on install it is checked) it disappears from the screen for later reversal.  This has fixed all the pc's I have assessed that were having trouble updating windows.  This is a clue to the real issue, which Microsoft should be addressing, as it disables all other updates from Microsoft which I would imagine have to do with Office, Hardware and others...  This is definitely a HUGE issue since no Windows Defender updates can be performed while the windows update feature is broken, exposing the user to malware that they would not necessarily have been exposed to.  In addition, it forces the end users to look for solutions since Microsoft, in each and every blog entry, forum entry or email shoots recommendations at the users who may or may not be technically savvy to perform.  Many of the recommendations could have harmful results to the end users pc if they were not to apply them correctly, and in many cases, the recommendations are written in such a manner that the sequence and application of the recommendation are unclear and left to the end user to assume.  Not good.  You better get this fixed and soon.  I will not be recommending anyone migrate to Windows 8 new or upgraded until this issue is addressed, fully and without question.  This is a reproduce-able issue that can and has been reproduced by many, many end users to date and for the life of me I cannot understand why Microsoft has not reproduced the issue and created a surefire solution that works all the time, in every case.
January 31st, 2013 8:52pm

Hi Andr I also bought a Lenovo Ideapad (Z580). Turns out the OS setup seems to work like an upgrade which is buggy. What I did was, directly after the refresh/install, ran the windows update troubleshooter. This fixed the windows update database. All updates worked after that including the po pack install (it's dependent on the windows updates). Here is how to run the troubleshooter Hope it helps Joe
  • Proposed as answer by joppenheim Thursday, February 07, 2013 8:46 PM
Free Windows Admin Tool Kit Click here and download it now
February 7th, 2013 11:46pm

I'm trying it right now...its taking forever however. Its stuck at 20%. Its sitting there at 20% for 30 minutes. That seems like a very long time on a 4 core machine. I'll keep you posted.

January 12th, 2014 5:18pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics