Windows 7 not registering IPv4 address in DNS
We have been testing Windows 7 and noticed that the Windows 7 systems are not registering the IPv4 information in the DNS though IPv6 information is registered in the DNS. These test systems are in-place-upgrades from Windows Vista to Windows 7. The Windows 7 systems access the Internet and our internal networks just fine. We noticed the problem when we tried to RDC to the Windows 7 systemsthrough a VPN connection and through our Citrix services. We are able to connect using RDC by entering the IP address of any of the Windows 7 systems. Once we issue the ipconfig /registerdns command we are then able to connect using the IPv4 DNS resolution.W7 = Windows 7WV = Windows Vista C:\>nslookup w7-sbarnett.ciwmb.calepa.localServer: wmbdns.ciwmb.calepa.localAddress: 156.41.165.20 Name: w7-sbarnett.ciwmb.calepa.localAddress: 2002:9c29:a620::9c29:a620 C:\>nslookup wv-jrodarte.ciwmb.calepa.localServer: wmbdns.ciwmb.calepa.localAddress: 156.41.165.20 Name: wv-jrodarte.ciwmb.calepa.localAddresses: 2002:9c29:a614::9c29:a614 156.41.166.20 C:\>ping -4 w7-sbarnett.ciwmb.calepa.localPing request could not find host w7-sbarnett.ciwmb.calepa.local. Please check the name and try again. C:\Windows\system32>ping -4 wv-jrodarte.ciwmb.calepa.local Pinging WV-JRODARTE.ciwmb.calepa.local [156.41.166.20] with 32 bytes of data:Reply from 156.41.166.20: bytes=32 time<1ms TTL=128Reply from 156.41.166.20: bytes=32 time<1ms TTL=128Reply from 156.41.166.20: bytes=32 time<1ms TTL=128Reply from 156.41.166.20: bytes=32 time<1ms TTL=128 Ping statistics for 156.41.166.20: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),Approximate round trip times in milli-seconds: Minimum = 0ms, Maximum = 0ms, Average = 0ms C:\>ping w7-sbarnett.ciwmb.calepa.local Pinging w7-sbarnett.ciwmb.calepa.local [2002:9c29:a620::9c29:a620] from 2002:9c29:a614::9c29:a614 with 32 bytes of data:Reply from 2002:9c29:a620::9c29:a620: time<1msReply from 2002:9c29:a620::9c29:a620: time<1msReply from 2002:9c29:a620::9c29:a620: time<1msReply from 2002:9c29:a620::9c29:a620: time<1ms Ping statistics for 2002:9c29:a620::9c29:a620: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),Approximate round trip times in milli-seconds: Minimum = 0ms, Maximum = 0ms, Average = 0ms C:\>ping wv-jrodarte.ciwmb.calepa.local Pinging WV-JRODARTE.ciwmb.calepa.local [2002:9c29:a614::9c29:a614] from 2002:9c29:a614::9c29:a614 with 32 bytes of data:Reply from 2002:9c29:a614::9c29:a614: time<1msReply from 2002:9c29:a614::9c29:a614: time<1msReply from 2002:9c29:a614::9c29:a614: time<1msReply from 2002:9c29:a614::9c29:a614: time<1ms Ping statistics for 2002:9c29:a614::9c29:a614: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),Approximate round trip times in milli-seconds: Minimum = 0ms, Maximum = 0ms, Average = 0ms When we execute ipconfig /registerdns, we get the following:C:\>nslookup w7-sbarnett.ciwmb.calepa.localServer: wmbdns.ciwmb.calepa.localAddress: 156.41.165.20 Name: w7-sbarnett.ciwmb.calepa.localAddresses: 2002:9c29:a620::9c29:a620 156.41.166.32 C:\>ping -4 w7-sbarnett.ciwmb.calepa.local Pinging w7-sbarnett.ciwmb.calepa.local [156.41.166.32] with 32 bytes of data:Reply from 156.41.166.32: bytes=32 time<1ms TTL=128Reply from 156.41.166.32: bytes=32 time<1ms TTL=128Reply from 156.41.166.32: bytes=32 time<1ms TTL=128Reply from 156.41.166.32: bytes=32 time<1ms TTL=128 Ping statistics for 156.41.166.32: Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),Approximate round trip times in milli-seconds: Minimum = 0ms, Maximum = 0ms, Average = 0ms Here is the NIC configuration for the Windows 7 system:Microsoft Windows [Version 6.1.7600]Copyright (c) 2009 Microsoft Corporation. All rights reserved. C:\Users\sbarnett>ipconfig /all Windows IP Configuration Host Name . . . . . . . . . . . . : W7-SBARNETT Primary Dns Suffix . . . . . . . : ciwmb.calepa.local Node Type . . . . . . . . . . . . : Hybrid IP Routing Enabled. . . . . . . . : No WINS Proxy Enabled. . . . . . . . : No DNS Suffix Search List. . . . . . : ciwmb.calepa.local calepa.local Ethernet adapter Local Area Connection: Connection-specific DNS Suffix . : ciwmb.calepa.local Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet Physical Address. . . . . . . . . : 00-1B-B9-B9-A3-02 DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : Yes IPv4 Address. . . . . . . . . . . : 156.41.166.32(Preferred) Subnet Mask . . . . . . . . . . . : 255.255.255.0 Lease Obtained. . . . . . . . . . : Thursday, October 29, 2009 8:36:37 AM Lease Expires . . . . . . . . . . : Thursday, November 05, 2009 8:36:31 AM Default Gateway . . . . . . . . . : 156.41.166.1 DHCP Server . . . . . . . . . . . : 156.41.165.12 DNS Servers . . . . . . . . . . . : 156.41.165.20 156.41.165.11 Primary WINS Server . . . . . . . : 156.41.165.12 NetBIOS over Tcpip. . . . . . . . : Enabled Tunnel adapter isatap.ciwmb.calepa.local: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : ciwmb.calepa.local Description . . . . . . . . . . . : Microsoft ISATAP Adapter Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes Tunnel adapter 6TO4 Adapter: Connection-specific DNS Suffix . : ciwmb.calepa.local Description . . . . . . . . . . . : Microsoft 6to4 Adapter Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes IPv6 Address. . . . . . . . . . . : 2002:9c29:a620::9c29:a620(Preferred) Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301 DNS Servers . . . . . . . . . . . : 156.41.165.20 156.41.165.11 NetBIOS over Tcpip. . . . . . . . : Disabled C:\Users\sbarnett>Has anyonecome across this?TIA Jose
October 29th, 2009 9:25pm

Here is some additional information from our DNS logs.The DHCP server is registering the appropriate IPv4 IP address then the workstations sends its own DNS update and deletes the IPv4 address and only registers the IPv6 address. $SOURCE PACKET 156.41.165.12 <<<<< DHCP server Registering w7-SBARNETT$VERSION 825910$ADDw7-sbarnett 900 A 156.41.166.32 $SOURCE PACKET 156.41.166.32 <<<<< w7-SBARNETT workstation sending DNS update.$VERSION 825913$DELETEw7-sbarnett 900 A 156.41.166.32$ADD 1200 AAAA 2002:9c29:a620::9c29:a620
Free Windows Admin Tool Kit Click here and download it now
October 30th, 2009 5:49pm

We're having the same issue. No help from MS yet, we've put in a ticket and found some issues with our DHCP/DNS not updating properly, but after fixing them this is still happening. DHCP renew re-adds the hostname, but it vanishes shortly after.
December 18th, 2009 8:32pm

Have got the same issue! W7 and Windows 2003 server (with DNS\DHCP installed), Intel(R) 82567V-2 lan.card Have you found any solutions!?!
Free Windows Admin Tool Kit Click here and download it now
February 5th, 2010 10:10am

up up
February 12th, 2010 1:15pm

I got round this today by specifying the DNS server in TCPv4 properties. Why I should have to do that when the machine was telling me it was already there if I did IPCONFIG /ALL I can't say but it made the problem go away which will do me.
Free Windows Admin Tool Kit Click here and download it now
February 16th, 2010 12:03pm

Specify on client or DHCP server?
March 4th, 2010 2:42pm

Now i just add static ip in DNS and use DHCP reservation for the same ip remaning...And proplem still exist!
Free Windows Admin Tool Kit Click here and download it now
March 13th, 2010 2:09pm

Have got the same issue with some 2008 servers - seems them can't register its own "A" record in DNS located on windows server 2003 (for expl), only on w2k8(r2).
June 14th, 2010 10:18am

Have got the same issue with some 2008 servers - seems them can't register its own "A" record in DNS located on windows server 2003 (for expl), only on w2k8(r2). I'm having the same problem with a new win7 machine with server 2k8r2 DNS. This will be a MAJOR roadblock for deployment of win7 for me since most of our people use windows to connect to linux machines that check forward and reverse DNS entries for the connecting machine and reject the connection if they don't match. edit: Also, it is registering an IPv6 address even though I have it dis-abled
Free Windows Admin Tool Kit Click here and download it now
August 11th, 2010 1:48pm

We're also having the same problem across the board with Windows 7 Enterprise. We've statically configured the DNS server IP addresses, and still have the problem running IPv4. This problem is stopping a major workstation rollout for one of our departments.
November 1st, 2010 7:18am

This is the only solution that I've found to work. http://support.microsoft.com/?id=929852 The problem seems to be that just unchecking IPV6 under the Adapter Properties isn't enough. I've implemented this registry change on several systems that were displaying this issue and it has fixed them all. No changes to DHCP/DNS, just the client.
Free Windows Admin Tool Kit Click here and download it now
November 1st, 2010 7:50am

My organization is also experiencing this problem, exactly the way the original poster described it. I'd love to see an answer; this is going to cause big problems soon. The link that lgoodman provided, disabling specific components of IPv6, is useful and we've implemented it on our clients, but the IPv4 entries in DNS are still being deleted periodically. Please oh please oh please let somebody find an answer!
November 17th, 2010 11:55am

Any of you using networking caching devices at locations having this problem?
Free Windows Admin Tool Kit Click here and download it now
December 14th, 2010 2:50pm

Exact same issue. It is not the same across all Windows 7 clients though... some clients have both the IPv4 and IPv6 records registered correctly. Only resolution so far was to perform the IPv6 disable registry hack and uncheck it under network settings to fully disable IPv6. This is not a fix... just a troubleshooting attempt. This is a serious problem as users are complaining that they can't connect to their workstations. How is there not a fix yet?
January 19th, 2011 3:09pm

I am also experiencing this problem, but the registry hack still did not result in the problem PC updating it's DNS entry on my servers after a reboot and an "ipconfig /registerdns". The only way I was able to workaround the problem for another PC not being able to resolve the name correctly was to manually change the DNS entries for that problem PC on both DNS servers. (Yes, I did an "ipconfig /flushdns" on the client PC each time, and was using nslookup directly against the DNS servers when checking also). Unfortunately I didn't have time to test further since this was a production machine and they needed to get back to work. Does anyone know why the reg change (setting [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters] "DisabledComponents"=dword:000000ff) followed by a reboot and "ipconfig /registerdns" might not resolve this? I didn't find any errors in event log afterward either. It's probably worth mentioning that all my DNS servers have IPv6 unchecked in the NIC properties and one of them already has the registry key setting I mentioned above also.
Free Windows Admin Tool Kit Click here and download it now
January 20th, 2011 10:13am

Jodarte's first reponse regarding the clients deleting the records after the server had registered them, has led me to a fix. Under the properties of one of our DHCP scopes where the issue has been occurring, I changed the following setting under the DNS tab: Old setting: Always dynamically update DNS A and PTR records. New setting: Dynamically update DNS A and PTR records only if requested by the DHCP clients. Now all of the clients we were having issues with are registering both IPv4 and IPV6 addresses correctly. I assume for some reason the client was removing what the server had already registered for them upon DHCP lease. I'm considering changing all of our DHCP scopes to this new setting now. Please let me know if this works for anyone else.
January 21st, 2011 12:54pm

The correct value for the DisabledComponents key to disable IPv6 is DWORD:ffffff (six f's). This was the only thing I got to work, sacrificing IPv6.
Free Windows Admin Tool Kit Click here and download it now
January 24th, 2011 6:11am

I think i solved this problem, i have deaktivated IP6 in the networks, then i have set the following flag in the registry. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\DNSRegisteredAdapters\{ID of adapter}] "Flags"=DWORD:0000000e At last i exceuted ipconfig /registerdns you can check it by nslookup server <dns-server> <ip-adress of the machine> please let me now if it works thanks Andy
February 16th, 2011 1:12am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics