Windows 7 Spooler Hangs on boot
I've seen several people start threads on this subject but none of them have a solution. I have several Windows 7 32-bit Professional machines that are printing to a Ricoh Aficio MP C2050 across the network. I had them printing through a server, but now have them printing directly to the printer itself. Here is what happens: On boot, the user brings up Outlook 2k7 and then Word 2k7. Word never makes it past it's splash screen. Going into Devices and Printers the window hangs. I can't stop the Printer Spooler service. I have to do 'taskkill /im spoolsv.exe /f' then start the service. Everything is fine after that until the machine is rebooted. I have disable bidirectional communication on the TCP port. I have tried setting the port to RAW. This seems to work, except print jobs take hours to print. Putting it on LPR the print jobs come out at normal speed but this problem persists. I have reloaded the drivers. Cleared out the spool folder. No luck. Please, please, please if someone knows how to fix this, let me know. I can't believe MS would see all these posts for this exact problem on their forums and remain so silent about it.
May 13th, 2011 2:31pm

We are experiencing the exact same error on most of our win7 64bit sp1 workstations, all using office 2010. it is not consistent though, sometimes they do boot with out error, makes trouble shooting even more of a mission. We have tried the same steps as you describe, as well as updating the printer drivers, removing pdf writers that we thought were causing the issue and removing unwated drivers in print server properties. no errors in event viewer. The spooler service claims to be running, but if we try to restart it, it fails to restart and actually just stops. Then we start it and all is well... until the next reboot All our W/S use the same print server with the same share and driver. it has not always been a problem, but has definitely increased in the last month. We now have a spooler rush every morning to get all staff up and running... very frustrating.
Free Windows Admin Tool Kit Click here and download it now
May 25th, 2011 12:38pm

If you would like to find which printer driver cause the crash issue, I suggest you isolate each driver and run printing job. Please: 1. Open mmc in Start Search box. 2. Click File->Add/Remove snap-in 3. Add "Printer Management". Click Add "The Local Server". 4. Click Finish. 5. Expand Print Servers->[server name]. Click on Drivers. 6. Right-click on the first driver, choose "Set driver isolation"->"Isolated". 7. Start a printing job. 8. If the issue still occurs, change the isolation to System Default for this driver, then isolate the next driver and start printing job. You can find which driver is the root cause. You need to involve a Windows 7 compatible driver for Windows 7 clients. If the driver is packed, you can extract the driver pack and add the driver from printer server console. However, if the driver is included in an installation file, you may try the following method. 1. Install the driver on one of the Windows 7 clients. 2. Launch mmc from Start Search box. 3. Click File->Add/Remove Snap-in. 4. Add "Printer Management". Point to the server in "Specify the printer server". 5. Expand "Printer Management"->"Printer Servers"->"Drivers". 6. Right-click, then click "Add a driver". Please follow the instructions to add the Windows 7 printer driver. After doing so the driver should be added into the server. If the printer driver is not found, the driver should be not designed for enterprise environment. In this case you may need to add the printer from the client side manually.
May 25th, 2011 12:56pm

After looking at another W/S, there is an error in event viewer system log: A timeout (30000 milliseconds) was reached while waiting for a transaction response from the Spooler service. Event ID: 7011
Free Windows Admin Tool Kit Click here and download it now
May 25th, 2011 12:58pm

We will try the driver isolation test. The spooler does not "hang" when printing, only at login. After login, we kill the spooler service, start it and all is fine until the next reboot. We are using the latest driver for all our printers and the 64bit drivers have been installed in the manner described above.
May 27th, 2011 6:41am

I do not think it is printer driver related... We have tried to isolate drivers and have also gone as far as removing all printers and deleting drivers, and the problem persists.
Free Windows Admin Tool Kit Click here and download it now
June 21st, 2011 4:35pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics