Why does lync not save conversation history in outlook
I have outlook 2007 and lync 2010. at work we use a microsoft exchange server. since i got a new computer it says that my conversation history is beings saved, but when i look in outlook in the conversation history folder it is not there.  i verified that lync is set under options>personal> to save my conversations to outlook, but it is not. Does anyone know why?
October 9th, 2011 4:21pm


Do you see the conversation history folder in Outlook? But you do not see any conversations are getting saved?

have you installed the latest Service pack and Updates to the office 2007 and try? it should work once it's enabled from the LYNC Client.


Free Windows Admin Tool Kit Click here and download it now
October 9th, 2011 4:36pm

Dear friend,

Check your

in General Catogory and check whats the status of this ( "Mark or Unmark") , or you can do it in Global Client Policy.

October 10th, 2011 10:45am

Hi Wallace,

The Conversation History is saved using the MAPI Connection between Lync Client and Outlook Client.

Please check the Lync Configuration Information. The MAPI Status and EWS Status should be OK.

In addition, please note, Lync 2010 supports Exchange Server 2007 with Service Pack 1 (SP1) (required) or the latest service pack (recommended).

And there is another post for reference. Hope useful.

Free Windows Admin Tool Kit Click here and download it now
October 12th, 2011 11:26am

I am not surprised this question, hard as it was to finally find, is still not only NOT answered but not resolved half a year later and leads to yet another dead end. I was under the impression Lync was only a week old given there is barely any help information on such a simple topic. Has anyone figured out what apparently Microsoft is making rocket science? Everyone just says "oh you just need to check 'save IM message conco in my email conversation history folder'". What if the conversation history folder is not in Outlook? I have Outlook 2010 using Exchange 2003. Is Exchange 2003 the problem and if so, hopefully if someone says "yes" then this forum will be the first to actually say that. This issue shouldn't be so hard to figure out nor should one have to read/comb through an entire [excruciating] Microsoft's Microsoft Unified Communications Solution using Microsoft Lync bull$hit verbiage manuals where they overuse the word Microsoft (ya smell what I'm steppin' in?). Sorry for the negative rant but I'm sure some of you can relate. 
May 9th, 2012 4:05pm

Thats a perfect shoot @goldeneye.....lots and lots of threads about same issue.....But no solution with microsoft...
Free Windows Admin Tool Kit Click here and download it now
June 14th, 2012 9:08am

Did you verify your users have their SMTP address set correctly?
October 23rd, 2012 6:13pm

I am fed up with this issue, I was reading lot of threads but the solution is not mentioned anywhere. What I use is a combination of Outlook 2007(X86), Win 7 X64, Lync 2010 X64
Free Windows Admin Tool Kit Click here and download it now
November 28th, 2012 8:31pm

I agree with you. Been working on this exclusively for some time now, there are no solutions or any patches given by Microsoft. I work in an enterprise with replicated PC environments so if it works on one device, then it should work on another which has the exact same settings. Somehow on my device I get a notification "We saved this conversation in the conversations tab in Lync and in the conversation history in Outlook." But neither is saved.

My work environment requires that I use my history.

Here are the things I've tried:

I've tried uninstalling Lync, Outlook, Office keys, and deleted all related folders in cache and  C:\users\Ryan\AppData\Local\Microsoft\Office\15.0\Lync\sip_Ryan***

Tried using a different account on same PC.. It's a local issue.

Tried deleting a few folders since the most common issue was 1000 folders thing.

Tried deleting the history spooler from  D:\users\ryan\AppData\Local\Microsoft\Office\15.0\Lync\sip_ryan**\History Spooler

Checked the Lync Client policy(Get-csclientpolicy) .. (DisableIMSaving Option)

This is a good thread for some, but didn't work for me http://exchangeserverinfo.net/2013/02/lync-unable-to-save-conversation-history-in-outlook/

I've tried adding all the suggested registry keys from diff sites.

Exit Lync....

Open Registry -> type regedit in run.

Expand - HKEY_LOCAL_MACHINE > Software > Policies > Microsoft > select Communicator or Lync folder.

Now look for files CallLogAutoArchivingPolicy AND ImAutoArchivingPolicy

Open these files and change the Hexadecimal value to 1

Now Open Lync and all new conversation will be saved in conversation history folder in outlook and Lync........ 

June 19th, 2015 7:56pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics