WLAN:  Dynamic key exchange did not succeed
Hi to everybody, I have a weird problem with wifi connectivity: I just cannot connect to a wireless network that works seamlessly on many other machines (3 Win XP Computers, my Iphone). I can try to connect, but then Windows 7 (x64) tells me it couldn't. After several reboots, I just worked once for a few hours, then it stopped again. The error in the event log is the following: Wireless security failed. Network Adapter: Intel(R) WiFi Link 5100 AGN Interface GUID: {a25847a0-945b-4d46-b5c4-83e07f71db71} Local MAC Address: <my Wifi MAC> Network SSID: <my SSID> BSS Type: Infrastructure Peer MAC Address: <my AP MAC> Reason: Dynamic key exchange did not succeed within configured time Error: 0x0 is there anything I can do about this? It's a shame that I need to use my mobile data plan because my laptop is just too dumb to connect to the Wifi AP... Has anybody had this problem before? By the way, I'm running Ubuntu on the same machine and there it's working perfectly... Thanks for suggestions Rainer
February 14th, 2010 1:30pm

Hi Does it work OK without using the Encryption? If it does then try another level of encryption instead the one that you use.Jack, MVP - Networking.
Free Windows Admin Tool Kit Click here and download it now
February 14th, 2010 4:34pm

Hi Jack, it's actually an access point a a friends house, so I cannot change the encryption etc. It's a WPA (1) network by the way. Any other ideas? Rainer
February 16th, 2010 8:37am

Hi, In addition, please also try the following: 1. Upgrade your router’s firmware. 2. Check the signal strength; you can also move the laptop closer to the wireless router. 3. Update the driver of Intel(R) WiFi Link 5100 AGN: You can get the latest driver here: Intel – Download Center Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information. 4. If there is another wireless network available, please check if you can access it. Hope this helps. Thanks.Nicholas Li - MSFT
Free Windows Admin Tool Kit Click here and download it now
February 16th, 2010 10:06am

This is going to sound crazy, but if you haven't yet resolved this (if you have, I'd love to know), try booting up with the laptop power plugged in and fully charged and then connecting. That's the exact issue that I am having. Other posts that I've researched have shown that this issue is related to Windows 7 (and apparently an issue with Vista, too - http://support.microsoft.com/kb/935222) with WPA or WPA-2. In the Vista issue, they cite AES encryption as a factor; in my case, it's AES or TKIP. If, however, my laptop is plugged in and charged, I can connect, with no issues! If, after connecting, I unplug it, it will stay connected until the charge drops below 95%, and then it disconnects. This isn't a device issue (mine's not an Intel adapter) or a driver issue, or a WPA issue. From the posts that I've seen, these are laptops that are compatible with Windows 7 (mine's an Acer that came with Windows 7 and has this problem out of the box). So, while writing this, I decided to poke a bit deeper into the power settings and I may have actually resolved this (Microsoft take note - maybe turn this into a KB article): Windows 7 Go into your power options (Control Panel - Power Options) There are 3 options: Balanced, Power Saver and (may be hidden) High Performance. Either choose High Performance (there's no Save or Ok; it changes immediately) and try connecting again or choose either of the other plans and click "Change plan settings" and the "Change advance power settings". Scroll down, if necessary, to "Wireless Adapter Settings" and click on the + to view the "Power Saving Mode". Click the + again to reveal the options for "On battery" and "Plugged in". For both, choose 'Maximum Performance'. Any of the other three options ('Low', 'Medium' and 'Maximum Power Savings') will cause this issue. Let me know if that helps. Microsoft may want to investigate this further; I had set my adapter such that "allow the computer to turn off this device to save power", which I would think would override any other power settings. The adapter wasn't getting powered down, but clearly even 'low power saver' mode was somehow affecting the adapter's ability to perform a proper key exchange. It would be interesting to know if the issue found in Vista that I mention above was similarly related. Thanks, Tim
April 25th, 2010 3:45am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics