Vista gets my IP and DNS server from the modem, but ping doesn't respond and pages don't load...
I've just donea fresh install of Vista Ultimate, having used Beta 2 and RC1 in the past (where everything network-related worked fine), and I can't get the internet to work through my D-Link DSL-300T ethernet modem. The modem gives my PC an IP address that appears to be for the internet (It always starts with 88.107) and the DNS server I'm used to seeing, but other than that, nothing internet-related seems to work at all. I can't get aping reply from192.168.1.1 (The router) and when I try and remote IPs, it says "Destination host unreachable", or something to that effect. I've managed to connect using a USB modem, but it's somewhat awkward to use when you're used to the internet just working straight away! Could anyone shed some light on my situation? I can access the internet perfectly fine through Ubuntu Linux on another partition.
February 18th, 2007 7:36pm

Make sure you have your router compaitable with Windows Vista (note of the new TCP/IP stack which is so rich new with new specifications top of them IPv6 support. Good luck
Free Windows Admin Tool Kit Click here and download it now
February 18th, 2007 8:52pm

There don't seem to be any other reports of this modem not working with Vista on the internet...and it worked fine in Beta 2 and RC1. If it isn't compatible, is there anything I can do? I've read about this SPI thing causing lots of problems, but this modem doesn't have a hardware firewall soI doubt it. Other than that,I guess I might just have to wait for a firmware update. P.S. It's worth mentioning that I doubt the network adapter is the problem, as I have two and neither work with it. Sometime later I'll dig out my old laptop and see if that'll connect.
February 19th, 2007 12:17pm

I got exactly the same problem: D-Link DSL-300T works with an old laptop with Windows XP, but for my new laptop with Vista Premium, it "gets my IP and DNS server from the modem, but ping doesn't respond and pages don't load..." I spent last few hours fighting with the internet connection, and was so relieved to find this website, so I am not the only one having this problem.
Free Windows Admin Tool Kit Click here and download it now
March 10th, 2007 1:08am

Hooray, someone that has the same problem as me! This proves pretty conclusively that it's Vista's problem, and not my hardware. I'm guessing that it's the new TCP/IP stack still, and I really hope there'll be a hotfix sometime. Exploring other possible solutions, I've heard it's possible to "upgrade" the 300T to its successor, the 320T, by employing some devious firmware tricks. The question is, is this legal, and will it fix anything? I don't want to go to all the trouble and have it still not work.
March 10th, 2007 10:30am

just add the ip address of the modem ( on the default gateway. click tcp/ipv4 properties and advance. add the default gateway and check automatic metric. leave everything in automatic, and you can browse the internet...
Free Windows Admin Tool Kit Click here and download it now
March 15th, 2007 12:41am

Thanks for that. I had a similar problem which had been driving me mad for days. I telephoned D-Link tech support but I could neverget past being put on hold. I could configure the 300T and couldbrowse the net OK and collect my mails with Windows mail.However onceI rebooted the PC I could not browse the net or even log into the modem. I would have to reset the modem and go through the whole configuration again, then all would be fine until I turned the PC off again. addingthe modem IP as the default gatewayhas now fixed this problemCheers. Russ
June 22nd, 2007 10:50pm

I have the same problem. I tried getting rid of IPv6 in Services and on the NIC settings. This seemed to help sometimes. I tried putting in the IP of my router as a gateway and DNS. Again this seemed to help sometimes. Then according to one of the answers in this thread, I tried using the IP of my modem and not my router. The modem IP settings are assigned by my ISP and show up in the router web page with a gateway IP and primary and secondary DNSes. So I put these all in my NIC IPv4 settings. Now everything seems OK so far. (Maybe?!? I hate Vista) My other old XP box work fine on the same network.
Free Windows Admin Tool Kit Click here and download it now
March 11th, 2008 12:44am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics