Vista - Cannot Connect to the Internet via browser
I purchased a nice Gateway M-Series laptop for my daughter this x-mas. Problem is I cannot connect to the Internet. I have 3 other computers that can connect just fine both wireless and LAN. I installed Firefox to see if it was IE, it is not, they both exhibit the same issue. Strangely and rarely enough I do sometimes connect to the home page which is Google, but cannot proceed anywhere else, nor search successfully. This is usually after I repair the connection and/or restart the computer, which I have done many times. My daughtercan play World of Warcraft which requires an Internet connection so it seems only browser related. Also I can see all the other computers on the network. When I ping my reply is just over 100 MS. Any suggestions would be appreciated, it seems like something simple. Dazed and confused.
January 3rd, 2008 2:17am

Hi, Thank you for the post. Based on the description, I understand that the Windows Vista machine cannot browse any website by using IE or Firefox. However, you find that the Windows Vista machine is connected to the Internet successfully. If there is anything I have misunderstood, please let me know. Before we go further, I would like to collect the following information with you for further research: 1. What error message was received in the IE window when attempting to access webpage? 2. Please collect the information related to Windows Network Diagnostics by using the following steps:==============2.1 In the IE window, click Diagnose Connection Problems.2.2 Capture a screenshot of the Windows Network Diagnostics information. Meanwhile, please refer to the following steps for troubleshooting: =============== Please refer to the steps in the KB article 926431 ( Also, perform a full scan by using antivirus software to make sure that we have not installed malware unconsciously. If the steps cannot resolve the issue, please try the following suggestions to reset IE:2.1 Disable all add-ons:-------------------------------Right-click the Internet Explorer icon on the Desktop, and then click Start Without Add-ons.If you do not have an IE icon on the Desktop, please click start, click All Programs, click Accessories, click System Tools, and then click Internet Explorer (No Add-ons).2.2 If disabling all add-ons resolves the issue, please use Add-ons Manager to narrow the issue down on the problematic add-on.2.3 If disabling add-ons doesnt resolve the issue, please try to reset IE back to its default settings:--------------------------------------------------------a. Close all IE or Windows Explorer windows.b. Open a new IE window.c. Click Tools, and then click Internet Options.d. Click Advanced tab, and then click Reset.e. Close IE and reopen it to apply the changes If the issue persists, please reboot the machine and logon to Safe Mode with Networking to check the result. If the issue occurs in Safe Mode with Networking, certain Windows Resource Protection (WRP) file may be missing or corrupted. Thus, please refer to the steps in the KB article 936212 ( to repair the system. Hope it helps. Sincerely, Joson Zhou Microsoft Online Community Support
Free Windows Admin Tool Kit Click here and download it now
January 6th, 2008 11:13pm

I had the same set of problems as the OP. The messages I received in the browser were along the lines of "This website cannot be displayed" and when I did the network diagnostic it said everything was fine, no problems detected. After trying everything suggested to fix the problem, I came up with the following interesting results:1) safe mode with networking worked2) after repairing the system, something could not be repaired and internet browsing still didn't work3) I performed a system restore for several weeks prior to the issue happening, and that fixed the problem4) After testing, I decided the next thing to do would be to run all updates in Windows Update for the computer, I did so5) After installing the updates, internet browsing no longer functioned.So, after all of that, I find that one of the updates has to be the culprit in killing the machine's ability to browse the internet. below are listed the updates that were available when I tried updating the computer:1) Cumulative Security Update for Internet Explorer 7 in Windows Vista (KB944533)2) Security update for Windows Vista (KB943055)3) Security update for Windows Vista (KB946026)4) Security update for Windows Vista (KB946456)5) Update for Windows Vista (KB938371)6) Windows Malicious Software Removal Tool - February 2008 (KB890830)7) Cumulative Update for Media Center for Windows Vista (KB947172)8) Update for WIndows Mail Junk E-mail Filter [February 2008] (KB905866)9) Update for Windows Vista (KB943302)10) Update for Windows Vista (KB943899)11) Atheros Communications Inc. - Networking - Atheros AR5007EG Wireless Network Adapter12) nVidia - Networking - NVIDIA nForce Networking ControllerI think it's one of the Windows ones rather than the two third party ones since the first time this problem popped up I tried running updates to fix it and both of them were not yet installed.I really hate that it is likely one of Microsoft's own updates that killed this computer's ability to browse the internet.Specs:AMD Athlon 64 x2 (1.7 Ghz)1 GB Ram160 GB hard drive (hardly even close to half-full)made by Acer
March 5th, 2008 12:50pm

i am experiencing same issue here and after restoring to previous date before all the updates, I can browse internet again. I hope there is a fix for this or at least remove the update that is causing this problem. I don't have time to do update them one by one and restart the computer just to see which one.
Free Windows Admin Tool Kit Click here and download it now
March 11th, 2008 9:48pm

Same issue with HPDV2000 laptop...working fine prior to updates; however cannot restore due to point of restore was after updates. I would rather not do a recovery from back disks. Microsoft lets fix this problem immediately...from a home user stand point and possibly a professional stand point definitely not good business...job security...hmmmm.
March 18th, 2008 9:50am

Same issue here on a vaio pc been happening for a while.
Free Windows Admin Tool Kit Click here and download it now
March 24th, 2008 4:23am

I had the same problem yesterday. There was a network shown between my computer and the internet icon, and there was a red X, between the network and the Internet. Anyway i got ip from my router, and other coumputers also could use the internet throug the same router. Try to set your IP manually from the same subnet, what router uses, but not from the DHCP range. Maybe it will help. Peter
April 3rd, 2008 7:10am

Same problem on my Vista Home Premium portable. It happened gradually, one browser after the other. I could still connect through Opera when IE and Firefox would give a "connexion refused" message. Now all of them give the same message. Windows Update works fine, I got the SP the other day with no problem. So does Skype. The notebook maker's support linesuggested (would you have guessed it?) to make a clean install of the whole system. NOT something that I want to do. If I can't get it to work, I will install XP instead and get rid of that Vista monster. rgds, LFR
Free Windows Admin Tool Kit Click here and download it now
April 3rd, 2008 9:38am

I have the exact same problem - I run a business where I go to people's homes and fix machines that have developed issues - apparently the lady had had another tech come to her house and fix something and he had entirely messed up her ability to browse the Internet. But oddly enough, the laptop (a Sony Vaio) is able to download windows updates, ping places on the internet, and run other applications that require an internet connection just fine.It was very confusing. She didn't have system restore turned on so rolling back was not an option, I said I'd do some research on the issue before doing a complete format and reinstall of her system.Do we have an progress on this?
April 5th, 2008 3:49pm

Still no progress for me. Rolling back/blowing the machine seem to be the only solutions at the moment. I wish Microsoft would answer this issue. I've been on the lookout for other solutions ever since I posted my solution.
Free Windows Admin Tool Kit Click here and download it now
April 5th, 2008 6:19pm

I've pretty much had the same thing happen to me with a new laptop, right out of the box. No updates can be done because even windows update can't access the internet, yet I get an assigned IP with DHCP from the router and can ping I've also had it that I can get to google but no one else. Other software requiring internet access or HTTP protocal can access the net.I've got an HP Pavilion dv2845se and I use WPA-PSK with TPIK connection.
April 7th, 2008 12:53pm

I recently had this happen to me out of nowhere, meaning no new app installs or anything to narrow down as the culprit. I will be using the computersuch as watching advd and downloading headers from newsgroups butIE or Firefox can't connect. I am clearly connected to the internet andNetwork Diag. finds no errors but connection diag. in IE finds problem its unable to fix. It happens only occasionally and usually is rectified by a restart. I have found that it is more than likely a corrupt winsock protocol, although have not figured out what is causing the corruption. Anyways, try this link or google winsock protocol reset and hope that helps.
Free Windows Admin Tool Kit Click here and download it now
April 8th, 2008 11:55am

I'm also having Internet connectivity problems with Windows Mail and Internet Explorer, which mysteriously started last week. The Internet connection icon shows that I am connected to my wireless router. I have a Win XP computer also connected with WiFi to that same router, using the same WPA-PSK encryption, and it has no problems. The problem seems to have started following a Windows Update last week, which made my IE unable to connect. Windows Mail could still connect. A day later I got the Windows Update message that Vista SP1 was available, so I assumed that it had been quicky issued to resolve the connectivity problem. I backed up everything, and finally today decided to install SP1. It didn't resolve my connectivity issue, and now Windows Mail also has connectivity issues. My last Windows Updates (back to April 9th) are: Definition Update for Windows Defender - KB915597 (Definition 1.31.8726.0) - 4/13/2008 Windows Vista Service Pack 1 (KB936330) - 4/13/2008 Definition Update for Windows Defender - KB915597 (Definition 1.31.8683.0) - 4/9/2008 Update for Windows Mail Junk E-mail Filter [April 2008] (KB905866) - 4/9/2008Security Update for Microsoft Visio 2002 (KB947896)- 4/9/2008 Security Update for ActiveX Killbits for Windows Vista (KB948881) - 4/9/2008 Update for Windows Vista (KB938371) - 4/9/2008 Security Update for Windows Vista (KB941693) - 4/9/2008 Security Update for Windows Vista (KB948590) - 4/9/2008 Windows Malicious Software Removal Tool - April 2008 (KB890830) - 4/9/2008 Security Update for Windows Vista (KB945553) - 4/9/2008 Cumulative Security Update for Internet Explorer 7 in Windows Vista (KB947864) - 4/9/2008 Note: I turned off User Account Control a few weeks ago. Any connection? Specs: HP Pavillion dv9000 Intel Core2 Duo 2Ghz 3 Gb RAM, 160 Gb disk (less than half full)
April 13th, 2008 7:41pm

Sadly this is a Windows Update caused error. Its update KB947864. Microsoft Help and support has the following pages: 1) uninstalled update KB947864 and the Internet Explorer and Firefox worked like a champ. Its a shame that they cause their own programs to stop working. The second link is a "resolution" they have, however they want the user to contact a third party vendor to solve the issue. I found it much easier to uninstall the update.
Free Windows Admin Tool Kit Click here and download it now
April 17th, 2008 7:20pm

Solved same problem with my Gateway M-Series. (32-bit with 3 gig ram). Full connectivity restored by "exiting" five programs from taskbar. Did leave Mcaffee running,,also left on the Synaptics Pointing Device.At this time I'm not sure which program was the trouble maker..I will find out by shutting off one at a time!Good Luck!
May 1st, 2008 8:28pm

I just followed what Noneed posted (reseting winsock) and all is well. BTW, it wasn't a windows update in my case. Prior to running Windows Update, I ran a engine update on my PC Tools Antvirus (, which required a reboot. After reboot, I ran an update to Windows IE 8 (KB971930) and .NET Framework 3.5 (KB963707) and it failed. Pinging everything in my network worked, but I could not connect to any web service, nor could I connect to any websites outside of my network (DNS queries and pings via domain name failed). I also ran the same AV engine update AND Windows Update on 2 other Vista Home (Premium) laptops without the any issues whatsoever. In my case, cause is still unknown on the one laptop, but the issue is resolved via
Free Windows Admin Tool Kit Click here and download it now
June 25th, 2009 3:24pm

This fixed my problem!!!!! THANK YOU VERY MUCH FOR SHARING THIS!!!!! I have been up for over 24 hours until i came across this and it fixed the problem very QUICKLY!!! THANKS AGAIN!!!
September 22nd, 2011 10:27pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics