VPN Juniper Networks Connect 7.3.1 dont work on Windows 8.1

Hi

In our corporate, we are using Juniper Network Connect 7.3.1 for our VPN connections. It is not working under Windows 8.1 Preview. The error is nc.app.windows 23712 (see Picture 1). I have tried to install reboot and install again same error. In device manager I see that the virtual adapter have a warning. I have tried to uninstall the adapter without any success.

This is a really showstopper for me any ideas?

Picture 1

Best Regards

Th

June 27th, 2013 7:52pm

Same problem for me, any solution?
Free Windows Admin Tool Kit Click here and download it now
June 28th, 2013 12:41am

Same problem also.

Hopefully 3 votes and people having the same issue will get this problem on the radar.

No VPN is a bit of a productivity problem for Win 8.1.

June 28th, 2013 3:17am

I am experiencing the same issue.

Windows device manager reports the following for the Juniper Network Connect Virtual Adapter:

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

An object ID was not found in the file.
Free Windows Admin Tool Kit Click here and download it now
June 28th, 2013 11:37pm

I experienced the same issue after I upgraded my 8.0 to the 8.1 Pro Preview.  I'm using Juniper 6.5.0.

I resolved it by:

1)  Delete the "phantom" Juniper Network Connect Virtual Adapter

2)  Uninstall Juniper

3)  Reinstall Juniper

I had considerable difficulty removing the driver.  I could not uninstall it directly from Device Manager, such that I would run the uninstall but the driver remained.   I went in to the registry but was unable to delete the folder due to lack of permissions, even though I was the owner of said folder.  So, I removed all the values, which was enough to make it appear uninstalled.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ROOT\DSNCADPT\0001

More Detail

After the first attempt at reinstallation post-registry change above, it created a "Juniper Network Connect Virtual Adapter #4" driver entry in device manager.

I then was able to delete that directly from Device Manager then did the Juniper reinstall and it worked right away.

I should also mention that the virtual driver is no longer present in Device Manager, so my theory is that the 8.1 upgrade misinterpreted Juniper to need a device driver so created a device driver that was causing the issue.  My Win 8.0 laptop also does not have the driver so it really wasn't ever needed.

Let me know if I can provide more detail.

Clark Bohs

June 29th, 2013 1:43am

Awesome! I had this issue yesterday! thanks for figuring this out!

Brian

Free Windows Admin Tool Kit Click here and download it now
June 29th, 2013 4:15am

I fixed another one of my upgraded machines and was able to reduce the list of steps.  This is for Network Connect 6.5.0, but may be relevant to later versions:

  1. Uninstall the Juniper app from Progs and Features, in my case just the Juniper Networks Network Connect 6.5.0 app.
  2. Delete c:\windows\system32\drivers\dsNcAdpt.sys file
  3. Reboot
  4. Launch IE (which is IE11)
  5. Add your login URL to compatibility view in IE (alt, tools, compatibility view settings)
  6. Launch your URL
  7. Accept all install prompts assuming it auto-installs if not present.
  8. Should now work!

June 30th, 2013 1:24am

I uninstalled all Juniper Apps from Prog and Features.

Then I didn't find the "c:\windows\system32\drivers\dsNcAdpt.sys file"

I rebooted, lauched ie 11.

Added my login URL to compatibility view.

Reinstalled Juniper networks.... AND

Now I get an error that says "Fatal Application Exit": dsTermServ.exe has exited unexpectedl. Debug Information has been created in "... insert juniper roaming service location here\dsTermServ.dmp"

Debug information pretty much says: "The thread tried to read from or write to a virtual address for which it does not have the appropriate access."

I tried looking for that "Juniper Network Connect Virtual Adapter" and found nothing...

Anyone else have a similar issue?

Free Windows Admin Tool Kit Click here and download it now
July 1st, 2013 5:28am

Thanks Clark your solution worked for me.

/Thomas Z

July 1st, 2013 8:15am

Same issue here
Free Windows Admin Tool Kit Click here and download it now
July 2nd, 2013 1:55pm

Same issue as jtmcduffie
July 2nd, 2013 8:53pm

Like Clark I could not delete the entire folder '0001', but when I tried to delete it, some of the sub-folders were removed.

I could not remove any of the values either. After the first re-install attempt, I was able to uninstall "phantom" Juniper Network Connect Virtual Adapter.

After this I uninstalled Juniper (and all related applications) & re-installed.

This resolved my issue.

Free Windows Admin Tool Kit Click here and download it now
July 2nd, 2013 9:15pm

I had issues getting the re-install to work, no matter what happened it would not re-install Network Connect. JuniperSetupClient.exe just sat in task manager doing nothing.

I ripped out the network adapter and driver file as per this thread, but nothing.

In the end I followed the advice from here: http://superuser.com/questions/433321/where-to-download-juniper-network-connect-7

To get a copy of the x64 Network Connect installer and installed that. I then put in my Companies VPN Login URL, pressed "GO" and signed in. Now connected again.


July 3rd, 2013 4:02pm

Hi Clark,

Thanks for your first and second solution. I can confirm it worked with Juniper Network Connect 7.0.0.1.  Your second solution, installing using compatibility view was the way to do it. Great! :)

Free Windows Admin Tool Kit Click here and download it now
July 11th, 2013 4:02am

Clark: 

After I did all the steps from 1 to 7, and it shows "The Network Connect session terminated.  Do you want to reconnect? (nc.windows.ap.23712)"

Do you know what I did wrong. 

Thanks.

July 15th, 2013 10:40pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics