The program can't start because DINPUT8.dll is missing from your computer
The program can't start because DINPUT8.dll is missing from your computer I am currently getting this error whenever I try to start a game. I have tried reinstalling all drivers, installing new version of direct X, and even manually updating the dll in the system 32 folder. The file exists where it should and I have been running the games (WoW, Startrek Online, champions online etc) for some time now with no issues. I have also ofc tried reinstalling the games and because someone mentioned that it may be connected to mouse and keyboard tried changing my usual USB ones for ps2 versions - still no help. Any assistance would be appreciated.
January 26th, 2010 12:35am

Tell us what the machine make, model and model # is (be specific)What operating system specifically do you have installed?You said you tried reinstalling - did you uninstall it first? (just checking) What game is this (cause you haven't identified it yet) - our crystal balls have not been working for a while ;)Ok a little research and I found some info for you, here are some comments from othersI finally have found a forum about someone else having this issue, and it was related to HID devices being connected that would crash direct input in the game.So i have unplugged both of my IR recievers for windows media center and .. the game runs perfect. Glad to know its not any wierd software or hardware problems other than unplugging my recievers when i wanna play a game..My issue was with what my system thought was a HID (Human Input Device) USD device but really wasn't. Once I unplugged the device from the USB hub, dxdiag starting working again. Just for information sake, the device was a PICkit 2 microcontroller programming unit. <!-- google_ad_section_end --> found out that my .dll files needed to be updated. I went to and in the search field I typed in .dll files update, it took me to a place where I could do a windows update for XP. Low and behold my games are working just fine now. Hope this helps someone with the same problemAnother idea I have is to look for your game executable Try running the game in Windows XP sp2 compatibility.<!-- / message -->MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
Free Windows Admin Tool Kit Click here and download it now
January 26th, 2010 3:49am

Hello,Does the problem occur in any games? Have you also tried reinstalling display card driver? Try to perform a system restore and see if the issue persists:1. Click the Start Button, type "system restore" (without quotation marks) in the Start Search box and press Enter. Click Continue if necessary.2. Check Show more restore points, and choose a time before the issue occurs and click Next.3. Click Finish and click Yes to confirm the operation.If the problem still happens, try to re-register DINPUT8.dll file:1. Click the Start button, then in the "Start Search" box, type CMD but DO NOT press Enter yet.2. In the list above, under "Programs" right-click on CMD that appears above and choose "Run as Administrator" and click "Continue". 3. In the open window, type the following command and press Enter:regsvr32 dinput8.dll -uregsvr32 dinput8.dllIf the system failed to register DINPUT8.dll , try to run in-place upgrade to repair the whole system:In-place Upgrade============= 1. Insert the Windows 7 DVD in the computer's DVD drive. 2. Click Start and choose Computer.3. Please find the "setup.exe" file in the DVD-ROM and double click it.4. Click Install now. 5. When we are prompted to input the product key, please click Next without inputting any key. The setup wizard will prompt and ask if you agree to install Windows 7 without the key. Please choose to confirm.6. When you reach the "Which type of installation do you want" screen, click Upgrade to upgrade the system files of Windows 7.Thomas77
January 26th, 2010 12:51pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics