Strange Vista problem
This one is a little strange.I have a Windows 2000 Domain with a mix of 2000/XP/Vista PC's connected to it all successfully until today.Today None of the Vista PC's will work properly, the network connection icon in the toolbar has a cross through it and when you hover the mouse it says "The dependency group or service failed to start!" THe diagnosis wizard will not work as the service isn't started and starting it returns an "access is denied" error! There are other servies not working like the DHCP client, the network location awareness and the firewall.Restarting the Network Location Awareness puts this in the event log"The Network Location Awareness service terminated with service-specific error 3221226008 (0xC0000218)"ANy help please.Thanks
January 3rd, 2008 6:02am

OK, a slight update, if I give the offending client PC's a static IP address, it connects to the network, but still doesn't start the services...
Free Windows Admin Tool Kit Click here and download it now
January 3rd, 2008 11:43am

Anyone have any suggestions to this problem?My last resort is to do an Authorative Restore of the Active Directory, but if that goes wrong I have more problems than I have now...
January 4th, 2008 6:50am

Hi, Thank you for the post. Before we go further, I would like to confirm if there is Group Policy having been applied before the issue occurs. I performed research and found that the issue can occur if the privileges of the Local Service and Network Service account are modified. Especially the following two privileges: "Adjust Memory quotas for a process" (could be referred to as 'SeIncreaseQuotaPrivilege' ). "Replace a process Level token" (could be referred to as 'AssignPrimaryTokenPrivilege'). As a result, I suggest performing the following steps to narrow the issue down: ============= 1. Create new OU in the AD and move Windows Vista machine account to this new OU. 2. Select the checkbox "Block Policy inheritance" in the properties of the new OU. Also, please make sure that the Local Group Policy is not modified on the Windows Vista machine. 3. Restart the Windows Vista machine and run GPUpdate /force to check the result. If the issue disappears, I suggest submitting the issue to our Windows 2000 Server Newsgroup to check which GPO causes the issue since the engineers there are specialized in issues related to Group Policy. Discussions in Windows 2000 Active Directory If the issue persists, please contact our CSS to perform further troubleshooting. Please understand dump analysis, which is out of our forums support boundary, is required to locate the root cause of this issue. To obtain the phone numbers for specific technology request, please check the website listed below:;EN-US;PHONENUMBERS Thank you for your understanding and cooperation. Sincerely, Joson Zhou Microsoft Online Community Support
Free Windows Admin Tool Kit Click here and download it now
January 7th, 2008 5:12am

Hi Joson,i have exactly the same problem. I am on a w2k3 domain which contains mostly XP pro clients and maybe a few w2k pro.I need to think about deploying vista on my network but i have found out that the moment i make a vista machine a member of the domain, the networking services are killed and only a restore from a restore point helps (or a rebuild)Now i know that it is my default domain GP that is causing this, because I did exactly what you mentioned about the blocking GP on my own vista laptop and as long as the GP is not applied I am fineproblem is i have a hard time finding out which setting exactly is causing this. I have a backup of the registry when the networking is working and I have one when it is not. I am trying to use windiff to compare but it is a daunting you have any suggestions on how to approach this problem? Any advice would be highly appreciated.Thank you so much
April 10th, 2008 12:55pm

well, after 100000000000000000000 system restores i have finally fixed this issue. not sure if it is the best way to do it, but honestly i am way to tired of dealing with this to care.basically it came down to an error in the system log that referenced Stop 0xc0000218 errorso i tried to look that up and found this: talks about a corrupt registry but i know that wasn't the case for me since i was getting ACCESS DENIED errors when i was trying to start the services in in my GP I added LOCAL SERVICE and NETWORK SERVICE to the HKLM\SYSTEM with full rights and VOILA!!!!!!!network is alive and STAYS alive even when i do gpupdate /force.again,i am pretty sure that i could narrow this down to the exact part of the system hive, but i will leave that for some other time. hopefully this won't make my PCs way too open for malicious apps.hope this helps somebody, because it drove me nuts for weeks
Free Windows Admin Tool Kit Click here and download it now
April 15th, 2008 3:50pm

Hello, I am having a similar problem, I also find that the network services do not start, and I get a cross over the network icon in the system tray. But my computer is not part of a Domain and Group policy is not uses, but I still get the access denied error. What can I do about it? Any help would be really appreciated! Will Griffiths
April 23rd, 2008 5:57pm

Good news, a system restore under safe mode fixed the problem.
Free Windows Admin Tool Kit Click here and download it now
April 23rd, 2008 6:00pm

I recently ran into the same problem except that I am not on a Domain, just home laptop running Vista Ultimate connected to standard dsl line. Nothing wrong with the dsl, my other laoptop running XP connects fine. I have been troubleshoting for over a week and nothing I do will make this and other dependant services start. It appears that the common culprit is the TCP/IP Protpcol Driver. My IT consulltant ran me thru an uninstall of the network adapters to attempt to wipeout and automatically reinstal the TCP/IP Protocol Driver but evenafter automatic reinstall of hardwar and drivers the problem persists. I already installed SP1, still no fix. I note from the forum that I am not alone with this problem. Is there any way to fix this? I don;t want to go to a restore, in my case I would lose to much in the process. The system viewer gave me this error report: Log Name: System Source: Service Control Manager Date: 7/2/2008 10:02:04 AM Event ID: 7024 Task Category: None Level: Error Keywords: Classic User: N/A Computer: RDT-ToshibaX205 Description: The Network Location Awareness service terminated with service-specific error 3221226008 (0xC0000218). Event Xml: <Event xmlns=""> <System> <Provider Name="Service Control Manager" Guid="{555908D1-A6D7-4695-8E1E-26931D2012F4}" EventSourceName="Service Control Manager" /> <EventID Qualifiers="49152">7024</EventID> <Version>0</Version> <Level>2</Level> <Task>0</Task> <Opcode>0</Opcode> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2008-07-02T14:02:04.000Z" /> <EventRecordID>105559</EventRecordID> <Correlation /> <Execution ProcessID="0" ThreadID="0" /> <Channel>System</Channel> <Computer>RDT-ToshibaX205</Computer> <Security /> </System> <EventData> <Data Name="param1">Network Location Awareness</Data> <Data Name="param2">3221226008 (0xC0000218)</Data> </EventData> </Event>
July 2nd, 2008 11:18am

Has anyone been able to solve DTSLAW's problems? I am experiencing the exact same problem, am unable to do system restore before SP1 (when the problem started to have occurred). I have read on other forums and threads that this might be an issue with Trend Micro, but having performed the nlasvcc.dll change and swap for old file, the issue is still not resolved. I have no Trend Micro/Norton installed on the laptop but am experiencing the same issue.Any updates or further help would be appreciated!
Free Windows Admin Tool Kit Click here and download it now
March 31st, 2009 12:03am

having the same problem here only with a Win2k8. i get an access denied whenever I'm starting the NLA service. will try the solution of morpheous and hope it works.
May 28th, 2009 9:39pm

Thank you very much Cheadles it worked after the commands gave the computer a restart and in a few minutes found wireless network NLA service and all dependency services were running
Free Windows Admin Tool Kit Click here and download it now
January 21st, 2010 4:28am

Took a while to track this down. At least for me, the solution was: Administrative Tools -> Domain Security Policy -> Registry Remove any permissions being enforced on SYSTEM\CurrentControlSet\Services\Tcpip or related keys
January 29th, 2010 5:58pm

The Cheadles solution worked for me. The rest may work, I dont know.
Free Windows Admin Tool Kit Click here and download it now
March 11th, 2010 6:44pm

I want you to know I TRIED EVERYTHING short of a complete reinstall to fix this problem that everyone was having.. I repaired winsock countless time, reinstalled every protocol imaginable, safe mode, command prompt, everything that any other post ever had on why so many services were not starting.. YOU fixed it... i entered your commands and VOILA! IT WORKED! I will link this thread to EVERY board I was on... This is the ONLY one where the problem was actually fixed!! THANK YOU THANK YOU THANK YOU!!!!!!!!!!!
June 30th, 2010 10:50pm

It shall henceforth be known as the Cheadles solution :-D
Free Windows Admin Tool Kit Click here and download it now
June 30th, 2010 11:24pm

sir, you are forever in my debt. +1 internets.
July 1st, 2010 7:26pm

Many thanks Cheadles, my computer is running properly too because of this, and the issues have all gone away. (The issue was "The Network Location Awareness service terminated with service-specific error %%-1073741288." for anyone else googling around.) Edit: I should add that I used your fix in Windows 7 rather than Vista and it worked just as well.
Free Windows Admin Tool Kit Click here and download it now
October 29th, 2010 5:27am

Thanks I managed to connect to n/w after using the above proposed commands but I can no longer connect to Remote client VPN( which I was able to connect before this problem appeared). The error I get is "The VPN client was unable to setup Ip filtering. A VPN connection will not establish" I appears to me that VPn client can no longer get sufficient rights to setup IP filtering on the machine. Any help would be really appreciated! AK
November 18th, 2010 8:02pm

Cheadles you solved my problem too!!! Thanks!!!
Free Windows Admin Tool Kit Click here and download it now
January 5th, 2011 2:54am

you rock dude!! Been trying to fix my friends laptop for two weeks. This finally did it.
April 30th, 2011 10:19pm

Worked for me too! I had already tried editing the registry keys to add full permissions for the network service on tcpip and dhcp hives. That got rid of a dhcp error, but didn't fully solve my problem. Your solution was the final fix. Thanks!
Free Windows Admin Tool Kit Click here and download it now
July 17th, 2011 7:13pm

I had the same problem with several services on a laptop running Vista. Running "Startup Repair" from the recovery options of the Vista boot cd solved the problem! Chris.
January 10th, 2012 7:43am

This fix (Cheadles) also fixed me. THANK YOU!!
Free Windows Admin Tool Kit Click here and download it now
April 11th, 2012 12:31pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics