SFC Windows Resource Protection could not perform the requested operation FIX!
Over the past few weeks I have experienced several interesting problems between my two computers. Of particular note was an issue I discovered when the Event Viewer on my Windows 7 Ultimate 32-bit machine failed. After some troubleshooting I decided to attempt SFC /scannow. I got the error message "Windows Resource Protection could not perform the requested operation." This worried me. So I attempted to boot into WinRE from my Win 7 installation disk. The result in WinRE was the same. No good. I scrounged forum after forum looking for an answer, but nothing worked. It seemed like everyone just gave up and reinstalled their OS, but I would not do that. So I kept exploring. CBS.log showed nothing of interest as sfc never made it past "Beginning verification phase of system scan." Finally I found this article: http://www.updatexp.com/scannow-sfc.html which, while interesting and comprehensive, did not directly solve my issue. It did, however, point me to the registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\SourcePath This registry entry does not appear to exist in Win 7, but another entry in it's vicinity caught my attention: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir I had recently moved my program files dir to a different hard drive and placed a junction point in it's place. In the process I had altered HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir to point to "D:\Program Files\", then back to "C:\Program Files\" when the junction point was in place. "C:\Program Files\" is incorrect! the trailing backslash is incorrect, and must be removed! with the ProgramFilesDir value set to "C:\Program Files" I ran sfc /scannow and it scanned properly, finding several corrupt files (some of which required checking cbs.log to repair). I can imagine that some virus maker somewhere will use this to break SFC in the future, but here's your solution! So to review: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir cannot have a trailing backslash! Tell your friends! :) Cheers, Crosmanrond
January 8th, 2012 10:57am

Hi, Thanks for sharing. We really appreciate your time and efforts. Hope your experience will help other community members facing similar problems.Leo Huang TechNet Community Support
Free Windows Admin Tool Kit Click here and download it now
January 9th, 2012 6:20pm

Iv been having a similar problem first noticed a problem with error msgs when trying to run certain installers, tried to do sfc scan got same msg as you after researching it I felt in the same spot as you then I saw your post, unfortunately that did not work for me either there was no \ in ProgramFilesDir value.
January 11th, 2012 4:00pm

I had the same error and was able to get it to run using this command: sfc /scannow /offbootdir=c:\ /offwindir=c:\windows
Free Windows Admin Tool Kit Click here and download it now
June 12th, 2012 12:29pm

This article looked promising, but my registry already had the correct entry. =/
July 6th, 2012 8:34am

I had the same error and was able to get it to run using this command: sfc /scannow /offbootdir=c:\ /offwindir=c:\windows This worked for me - thank you for sharing :0)
Free Windows Admin Tool Kit Click here and download it now
July 18th, 2012 1:33am

this command does not work for me: ----------------------------------------------------------------------------------------------------- C:\Windows\system32>sfc /scannow /offbootdir=c:\ /offwindir=c:\windows The arguments passed to sfc are invalid. The offline windows directory specified points to the online system.
August 5th, 2012 10:54am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics