Running regedit as admin
Hi all, Ran into a problem trying to launch regedit using the "Run as Administrator" option available from a right click of the mouse while logged in as a regular user. When you click on run as administrator it tells you that you do not have permissions. We do have group policy set to not allow users to edit the registry, but the run as administrator function should bypass that and it does not. Any advice or ideas would be greatly appreciated. Thanks, Tracy
October 25th, 2012 7:38pm

You have set group policy in wrong way. Run resulting set of policy. Better forum for your problem is Windows Server Group Policy Regards Milos
Free Windows Admin Tool Kit Click here and download it now
October 25th, 2012 11:59pm

Milos, Thanks for your help. I would agree but, it doesn't happen like this on every Windows 7 machine. Odd I know. GP was the first thing that came to mind for me.
October 26th, 2012 12:17am

Jeremy, I will take a look at UAC and run icacls to see what happens. This happens on local or domain admin accounts. I will let you know. Thanks, Tracy
Free Windows Admin Tool Kit Click here and download it now
October 31st, 2012 4:38pm

Jeremy, Here is what I get when icacls c:\windows\regedit.exe is ran NT Service\TrustedInstaller:(F) Builtin\Administrators:(RX) NT Authority\System:(RX) Builtin\Users:(RX) Thanks, Tracy
October 31st, 2012 5:34pm

Hi, Which group policy setting do you use to lock down the registry? Does it also block the access to administrator? You can try to disable the UAC feature on Win7 client. Regards, DennyPlease remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
Free Windows Admin Tool Kit Click here and download it now
November 5th, 2012 12:44pm

Denny, We are using the "Prevent access to registry editing tools" policy. It is set under User Configuration --> Admin Templates --> System We do have a non group policy users org that does not have the limitations. All administrative accounts are in this group. UAC has been completely turned off on the machines in question, and still not able to do a right click and "run as" on the regedit.exe Very odd.....I have been working on this problem as I can, still not sure why it is doing this....What I did do was move the user that needed registry access to the non group policy users org. It was a temporary solution to the problem at least.
November 6th, 2012 11:52pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics