Strict Standards: Non-static method Settings::setHostName() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 20

Strict Standards: Non-static method Settings::addHostAlias() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 22

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 28

Strict Standards: Non-static method Settings::setDsn() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 16

Strict Standards: Non-static method Settings::setTitle() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 19

Strict Standards: Non-static method Settings::setDescription() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 20

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 24

Strict Standards: Non-static method Settings::setShowDeleted() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 31

Strict Standards: Non-static method Settings::setRecentTopicsDuration() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 36

Strict Standards: Non-static method Settings::test() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 28

Strict Standards: Non-static method Skin::test() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 29

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 102

Strict Standards: Non-static method Settings::getSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 32

Strict Standards: Non-static method Settings::getDsn() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 35

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 39

Strict Standards: Non-static method Form::fieldExists() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\User.php on line 92

Strict Standards: Non-static method Form::fieldExists() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 15

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 17

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\Topic.php on line 138

Strict Standards: Non-static method Entity_Post::queryPosts() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 21

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Entity\Post.php on line 111

Strict Standards: Non-static method Skin::showHeader() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 23

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 46

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 91
Network Security Key Mismatch (Network Steve Forum)
Network Security Key Mismatch
Hi all, Using windows 7, I have a persistent problem connecting to the Internet. When I try to connect to my router (wifi), I get "Network Security Key Mismatch" after entering the password for my connection. I am 100% positive that I am typing the password correctly. I have tried manually creating the network connection, so I can specify the security type, etc. I get the same result. I can connect to my neighbours unprotected wifi, so I know the hardware and drivers are functional. The problem is only when I connect to my router (linksys). It works fine when using Vista. This is the only thing stopping me from using Windows 7 full time (and indeed purchasing it for my three family computers). Can anybody help me? I've trawled the Internet many times looking for an answer. Thanks in advance, Nik
June 18th, 2009 7:44am

Hi Zzubnik, Did you check out this thread? http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/2825618b-2fc1-451b-a6d2-89691040e032RegardsFilip Wilms
Free Windows Admin Tool Kit Click here and download it now
June 18th, 2009 8:47am

Hi Filip, and thanks for your reply. I did read that thread, but I didn't think it applied to me, as my MAC address hasn't changed. If I put my HDD with Windows Vista back into the machine, it connects without difficulty. Does this imply that the thread you linked to doesn't apply to me? Forgive my ignorance! To clarify, I have a laptop, with the original HDD in, I can connect fine. When I swap the HDD to a new one which has my Windows 7 installation on it, I get asked for the security key over and over. I have seen a couple of forum threads on other forums which seem to have the same problem as me, but there hasn't been a response to these threads. Thanks again for your assistance. Nik
June 18th, 2009 10:09am

Nik,Have you tried to manually configure the wireless connection?1. Open the Network and Sharing Center2. In the left pane click Manage Wireless Networks3. In the list of networks right click your wireless network and click Properties4. Click the Security tab and check its settingsI have seen a number of times that WPA was chosen instead of WPA2 or that TKIP was chosen instead of AES encryption.Ensure the settings here resemble the security settings on your access point.I hope this fixes your connection issues.Ray
Free Windows Admin Tool Kit Click here and download it now
June 18th, 2009 12:31pm

Nik,Have you tried to manually configure the wireless connection?1. Open the Network and Sharing Center2. In the left pane click Manage Wireless Networks3. In the list of networks right click your wireless network and click Properties4. Click the Security tab and check its settingsI have seen a number of times that WPA was chosen instead of WPA2 or that TKIP was chosen instead of AES encryption.Ensure the settings here resemble the security settings on your access point.I hope this fixes your connection issues.Ray
June 18th, 2009 12:31pm

When you manually configure it, try unchecking the hide characters as I type check box just in case there is a mistype somewhere.
Free Windows Admin Tool Kit Click here and download it now
June 18th, 2009 1:58pm

Had same problem Try entering password with CAP locks on - This worked for me
October 25th, 2009 8:14pm

Let me know if you find the answer to your question about "Network Security Key Mismatch" for Windows 7 using Linksys. I'm having the same issue.
Free Windows Admin Tool Kit Click here and download it now
December 26th, 2009 11:30pm

Having the same problems... have tired everything mentioned thus far with no luck. Hope someone can help.
December 27th, 2009 7:04pm

i was having this same problem with my new laptop and Linksys wireless router. here's how i solved it... -went into my router's wireless security settings and changed from WEP to WPA2 Personal -changed from TKIP to TKIP+AES -set to 64bit 10 hex -set password -saved settings after that i was able to connect without a problem. seems my windows 7 doesnt like WEP at all and prefers AES over TKIP
Free Windows Admin Tool Kit Click here and download it now
January 2nd, 2010 3:39pm

I had this problem in Win 7 and what I had done was not correctly match up the Key # in the WEP security in my modem/router setting with the number set in the wireless network setting. Win 7 defaults to Key 1 but my used passphrase was on Key 2 on the modem settings. Not sure this is your issue, but FYI
January 23rd, 2010 6:47pm

What kind of linksys was it? I have a WTR54 (802.11) and it doesn't offer me a WPA2 personal option. I get a lot of WPA2 Shared Key or WPA2 radius options. Is my router just old?
Free Windows Admin Tool Kit Click here and download it now
February 10th, 2010 4:31am

Thanks Ray, this fixed my problem, I'm amazed that Windows doesn't determine I am using AES encryption on it's own. I had to manually add the wireless network and specify the settings. I never had to before Win 7 though...
February 22nd, 2010 11:23am

Hello, I'm having the same issues and none of the suggested solutions have worked. In my case, what happened is my D-link router suddenly couldn't find a network connection, so I phoned them and they had me change from WEP to WPA2, and delete and recreate the name for my network. This worked fine on my Windows XP PC, but my laptop (Windows 7) will not connect to this same (new) wireless connection, and I get the same msg of Key Mismatch. When I try to add/create a new wireless connection to match the new settings, it just puts an "X" in the box showing all available connections, and says it does not match the settings of the one I just created! Very frustrating, and sorry if I'm not explaining this too well... I am not very technical. If I try a different setting (say, WEP or WPA2 with TKIP, even though I know this is not correct) it accepts it, but then I get the Key Mismatch every time I try to connect. Any assistance/suggestions would be greatly appreciated.
Free Windows Admin Tool Kit Click here and download it now
March 25th, 2010 4:37pm

I had the same problem with my Linksys router until a few minutes ago, I tried resetting my password since the it wouldn't work..."Network Security Key Mismatch." I uninstalled Linksys on my 'old' laptop, which has XP, reinstalled the router, and got a new encryption key. I got on my new laptop (Windows 7), selected my router name, entered the new encryption key and it worked!!!! Here I am typing this wirelessly....after working on this all afternoon. I didn't have to change any settings on my new laptop. This stuff really frustrates me when it doesn't work. Hope this works for you.
March 28th, 2010 3:27am

Hello, Thanks for your response. I managed to the problem fixed by calling D-link and working it through with them (they are still supporting the product for free, even though I bought it several months ago, so kudos to them). For anyone else who has this problem, the main issue appears to be that my new laptop (< 1 month) does not accept the WPA2-PK setting as it is incompatile with the built-in wireless network driver. So, I changed the setting to WEP, and also re-named the security key, passwords, etc. while doing this, and all now works well. Cheers.
Free Windows Admin Tool Kit Click here and download it now
March 28th, 2010 9:24pm

This was frustrating to me because i called linksys and they didnt help. told me i had to pay. so this is wat i did to fix mine using windows 7. 1.Unplug router then plug it back in. 2. right click the conection 3. left click the connection 4. it will tell u to hold the wireless button on the router do that instead of typing your phrase. The internet will conect by itself and there u go. 5.If it doesnt work repeat step 1-5 Hope this solves your problems.
April 8th, 2010 12:39am

I had the same problem and just found out that Windows 7 is case sensitive. The security key is case sensitive.
Free Windows Admin Tool Kit Click here and download it now
April 23rd, 2010 11:32pm

Has anyone found a solution to this yet ? Tried 100 different suggestions from all different people and still can't connect wirelessly.Windows 7 is a bad joke! How dare they put this on the market like this.
May 10th, 2010 12:36pm

ya, I have the solution. The security key is the one that was generated automatically after configuring the router for the first time and using it on the first wifi connecting device (e.g. laptop). If you have it then good otherwise restore the router to factory default setting. This time save the automated password generated after putting the router pin while connecting with wifi network on the first device. Use the same pin for all the device in future.
Free Windows Admin Tool Kit Click here and download it now
July 2nd, 2010 5:36am

With Me The problem was my security WEP key, in the ROUTER was in lower case. Once I made the key UPPERCASE in BOTH the router AND the laptop everything was fine.
July 7th, 2010 2:10am

Had the same problem with a Toshiba notebook. It wouldn't connect to the wireless netwerk no matter what. Desperate I changed the SSID and accesskey. I made it a WEP code with 10 x 0 as password, couldn't type that wrong, right? Tried a couple devices on this network, worked just great. However, the Toshiba just would not work. What I did was putting the wireless settings of another notebook, on which the network worked fine, on a flashdrive. I then installed these on the Tosiba and it would connect just fine.
Free Windows Admin Tool Kit Click here and download it now
July 23rd, 2010 8:13am

try WPA2-AES instead of WEP. you will need to reconfigure the router. On Fri, 23 Jul 2010 08:13:06 +0000, Mmore wrote: > > >Had the same problem with a Toshiba notebook. It wouldn't connect to the wireless netwerk no matter what. Desperate I changed the SSID and accesskey. I made it a WEP code with 10 x 0 as password, couldn't type that wrong, right? Tried a couple devices on this network, worked just great. However, the Toshiba just would not work. > >What I did was putting the wireless settings of another notebook, on which the network worked fine, on a flashdrive. I then installed these on the Tosiba and it would connect just fine. Barb Bowman http://www.digitalmediaphile.com
July 23rd, 2010 8:53am

So many suggestions here! Yet none of them worked for me! lol I managed to fix my problem though. I am on Windows 7 and it works fine on ALL networks I have ever connected to except an old wireless access point I have just started using at home. It only has WEP for encryption and I used 128bit. Under this, I could use manual hex key, the routers stringed passphrase, ASCII or a normal passphrase. I tried normal passphrase first but my computer would reject the passphrase I had configured in the router! For some reason it would only accept "admin" but the result was limited connectivity. I would reset the access point after each reconfiguration (through the configuration page, not physically). I solved my problem by using ASCII and having to use a 13 character key (that's annoying!) but hey, my computer didnt reject the passphrase and it has full connectivity now =)
Free Windows Admin Tool Kit Click here and download it now
July 29th, 2010 1:06am

I was having the same problem with my father-in-law's laptop. I use logmein free to work his pc's up in Montana from here in Texas. We wrestled with it for a couple of hours trying some of the above suggestions with no success. Finally I rebooted his router and everything worked fine. Someday I will learn to try the simple stuff first.
August 15th, 2010 10:07pm

great answer for your wireless security mismatch problem is not a modem or window 7 perse rather than the following to solve yhour issue: 1 enter the security code provided by the router company. another thing you could do is reinstal the router software so that you can get a new security code 2 restart your computer. if ask to enter the security code again when attempting to use the wireless, enter it with the caplock on and you done good luck
Free Windows Admin Tool Kit Click here and download it now
December 13th, 2010 9:33am

I had the same issue. I fixed the problem by taking one of the response's advice above. I went into the Network & Sharing Center. I saw that W7 had saved the initial WEP setting with my initial passcode. I had changed my mind regarding WEP, because it disabled my Wireless N, and only gave me "good" reception instead of "excellent". But I restored factory settings on the router (one of several times as I started to figure out what I was doing), and then attempted to change to WPA2-PSK so that I could have a much quicker internet - as instructions said that it would. However, it kept the older WEP setting in memory on the "Managed Wireless Networks", and the older WEP happened to be first in line for connection. So, when I entered the WPA2-PSK passcode and saved it, when I tried to get back online, it first attempted to connect with the WEP - and that was the old passcode, not the new one that I had changed it to for the WPA2-PSK. Therefore, I "removed" the WEP connection from the list of "Managed Wireless Networks", then I went back in and entered my password (by resetting again factory settings on the router) and voilà... it worked. It worked because there was no longer a mismatch between "networks" having differing securities and passcodes. I am sure that if I had both passcodes the same, it would have connected, albeit WEP. I hope my experience has helped any others out there with the same issues. It did take me a bit of time to figure it all out - but I learned a lot in the proces and will be available to help out friends who have the same issues. I feel like I am now ahead of the curve regarding routers, and I can see that I am a minority of people in my wireless range that have WPA2-PSK on N. Many still have G, and a few even have WEP. Cheers, palermodude
April 15th, 2011 12:25pm

Hi, PLEASE BE SURE THAT WPS PIN AND PASSPHRASE ARE NOT THE SAME THING For instance, I was able to connect my vista laptop to my router with the wps pin (all numbers) while I connected my windows 7 netbook with the passphrase which was composed of letters. Good luck!
Free Windows Admin Tool Kit Click here and download it now
April 26th, 2011 2:05pm

I was entering the security key as printed on the side of my router and it didn't work. I pressed the reset button and held it for 10 seconds and it connected fine when I entered the key again... Turns out that by doing that I reset the security key to it's default (the one printed on the router). If I had remembered that my dad had changed the security key months ago I could have entered that and it would have worked fine. So Before you press and hold reset, make sure the security key/password hasn't been changed at any time since getting it because hitting reset will restore the default security key to the one printed on the router.
May 11th, 2011 5:35pm

I have the same problem but trying to connect to a range extender. I enter the correct WEP key but it still says there's a mismatch. I went to Manage Wireless Networks. It turned out it didn't show any security for that device. I entered a WEP Key, which is the same for the original wireless router, but it still says there's a possible mismatch. Should I configure the range extender with a different key password than the router? Should I change the range ext. from WEP to WAP or whatever other options there are? It has taken me many hours just to make the range ext. work. Now that I was able to configure it correctly with my XP machine, my Windows 7 is still making things difficult. Any suggestions? Jorge
Free Windows Admin Tool Kit Click here and download it now
May 27th, 2011 3:31pm

For those who are still struggling with this issue...this is how i got around it. I am using Lynksys Wireless-G, my security settings are WEP... I struggled with this for over 2 weeks, i read all manuals and googled everywhere but nothing was of help untill this morning... It looks strange but i understand now thta it is not.... step 5,6,7 and 12 are the most important connect your laptop to your wireless router with ethernet cord(ensure proxy server IP add is not set) go into the router settings normally http://192.168.1.1/ you may be required to enter your credentials go in to the wirelss security settings enter your passphrase important: click on "generate" button and about 4 security keys will be generated copy one of these generated keys. save and apply and exit this window. Goto network and sharing center select "Manage wireless networks" delete any network reference listed that may conflict with the network you are connecting to. exit the window now with that that try reconnecting and when prompted for passphrase or security key paste the generated key that you copied from step 6 above then shout bingo...you should be home and try
June 22nd, 2011 2:00am

For those who are still struggling with this issue...this is how i got around it. I am using Lynksys Wireless-G, my security settings are WEP... I struggled with this for over 2 weeks, i read all manuals and googled everywhere but nothing was of help untill this morning... It looks strange but i understand now thta it is not.... step 5,6,7 and 12 are the most important connect your laptop to your wireless router with ethernet cord(ensure proxy server IP add is not set) go into the router settings normally http://192.168.1.1/ you may be required to enter your credentials go in to the wirelss security settings enter your passphrase important: click on "generate" button and about 4 security keys will be generated copy one of these generated keys. save and apply and exit this window. Goto network and sharing center select "Manage wireless networks" delete any network reference listed that may conflict with the network you are connecting to. exit the window now with that that try reconnecting and when prompted for passphrase or security key paste the generated key that you copied from step 6 above then shout bingo...you should be home and try
Free Windows Admin Tool Kit Click here and download it now
June 22nd, 2011 2:00am

For those who are still struggling with this issue...this is how i got around it. I am using Lynksys Wireless-G, my security settings are WEP... I struggled with this for over 2 weeks, i read all manuals and googled everywhere but nothing was of help untill this morning... It looks strange but i understand now thta it is not.... step 5,6,7 and 12 are the most important connect your laptop to your wireless router with ethernet cord(ensure proxy server IP add is not set) go into the router settings normally http://192.168.1.1/ you may be required to enter your credentials go in to the wirelss security settings enter your passphrase important: click on "generate" button and about 4 security keys will be generated copy one of these generated keys. save and apply and exit this window. Goto network and sharing center select "Manage wireless networks" delete any network reference listed that may conflict with the network you are connecting to. exit the window now with that that try reconnecting and when prompted for passphrase or security key paste the generated key that you copied from step 6 above then shout bingo...you should be home and try
June 22nd, 2011 2:00am

WEP isn't safe. This isn't a solution that anyone should consider. Most likely you need to update the firmware in your old Linksys router to properly support at least WPA (WPA2 would be best). What exact model router and what firmware? On Tue, 21 Jun 2011 10:08:27 +0000, de Goldman wrote: > > >For those who are still struggling with this issue...this is how i got around it. I am using Lynksys Wireless-G, my security settings are WEP... I struggled with this for over 2 weeks, i read all manuals and googled everywhere but nothing was of help untill this morning... It looks strange but i understand now thta it is not.... step 5,6,7 and 12 are the most important 1. connect your laptop to your wireless router with ethernet cord(ensure proxy server IP add is not set) 2. go into the router settings normally http://192.168.1.1/ you may be required to enter your credentials 3. go in to the wirelss security settings 4. enter your passphrase 5. important: click on "generate" button and about 4 security keys will be generated 6. copy one of these generated keys. 7. save and apply and exit this window. 8. Goto network and sharing center 9. select "Manage wireless networks" 10. delete any network reference listed that may conflict with the network you are connecting to. 11. exit the >window 12. now with that that try reconnecting and when prompted for passphrase or security key paste the generated key that you copied from step 6 above 13. then shout bingo...you should be home and try Barb Bowman http://www.digitalmediaphile.com
Free Windows Admin Tool Kit Click here and download it now
June 22nd, 2011 7:26am


Strict Standards: Non-static method Settings::getRecentTopicsLimit() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\Topic.php on line 120

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics

Strict Standards: Non-static method Skin::showFooter() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 119

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 56

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 91