Strict Standards: Non-static method Settings::setHostName() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 20

Strict Standards: Non-static method Settings::addHostAlias() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 22

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 28

Strict Standards: Non-static method Settings::setDsn() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 16

Strict Standards: Non-static method Settings::setTitle() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 19

Strict Standards: Non-static method Settings::setDescription() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 20

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 24

Strict Standards: Non-static method Settings::setShowDeleted() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 31

Strict Standards: Non-static method Settings::setRecentTopicsDuration() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 36

Strict Standards: Non-static method Settings::test() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 28

Strict Standards: Non-static method Skin::test() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 29

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 102

Strict Standards: Non-static method Settings::getSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 32

Strict Standards: Non-static method Settings::getDsn() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 35

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 39

Strict Standards: Non-static method Form::fieldExists() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\User.php on line 92

Strict Standards: Non-static method Form::fieldExists() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 15

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 17

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\Topic.php on line 138

Strict Standards: Non-static method Entity_Post::queryPosts() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 21

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Entity\Post.php on line 111

Strict Standards: Non-static method Skin::showHeader() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 23

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 46

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 91
NWLink IPX/SPX/NetBIOS Compatible Transport Protocol (Network Steve Forum)
NWLink IPX/SPX/NetBIOS Compatible Transport Protocol
I tryed to load command and conquer Tiberian sun, on my vista beta 2 version and network with my son. But the game dose not pick up the network card, and go in to net work connection and go to load the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol and it is not there. or an i missing somthing hase it been removed or named changed? thank for your time. redknight
June 12th, 2006 5:17am

That'd be a Novell Netware protocol that's not currently available in Vista Beta 2. At least, if there IS such a critter - it's not immediately evident in the usual places where you'd normally find it. That USED to be the protocol of choice many moons ago - but hasn't been that popular since the Internet and TCP/IP became the standard of choice. Two options - wait for Microsoft to deliver one OR maybecheck with Novell - they might have an IPX/SPX protocol package available for the Vista beta.
Free Windows Admin Tool Kit Click here and download it now
June 13th, 2006 1:28am

Still seems to be nothing... I've been searching for the past two days both Novell's & Microsoft's tid's... and have come up short. I'm dead in the water without my netware client on my laptop running Vista RC1 build 5600, I missed out on the opportunity to download RC2, and I have a feeling the Client Service for Netware including the IPX / SPX protocol is in there... Looks like we're waiting till January 30th!!! I'll probably just blow away Vista RC1 and go back to XP till then. Joe
November 10th, 2006 7:34pm

Hi there i have the released version and it dosnt have the NWLink IPX/SPX/NetBIOS Protocol so i havent being able to connect over the lan Did you ever get any help ?????
Free Windows Admin Tool Kit Click here and download it now
February 5th, 2007 6:02am

Novell has a beta client for VISTA. http://download.novell.com/Download?buildid=yIEJzwGwlu0~ Requires username and password to download. You can register. When connecting toa Novell server, you may apt to leave context and tree blank, only add ip address of server to assure connection.
February 13th, 2007 10:52pm

IPX in Vista!: http://www.starbase01.com/site/index.php?id=22,0,0,1,0,0
Free Windows Admin Tool Kit Click here and download it now
February 17th, 2007 4:27pm

I tried out with 32bit-version of vista basic and had no problems with the installation and after getting master of my router it worked great with c&c RA2 xD
April 5th, 2007 7:23am

I also tried it (the patch from the starbase01.com guy)out with the 32 bit version of Vista Home Basic; there were no problems (that I could see) with the installation, but when I clicked the "Network" button on my C&C RA2 main screen it did the same thing it had before, no network screen, just the main one again. I did notice that my second computer (running XP) has an additional protocol, "NWLink NetBIOS" that came with "NWLink IPX/SPX/NetBIOS Compatible Transport Protocol",and the Network screen comes up for RA2 on that one. Any tips? I am fairly certain I did the installation right. I may need to get patches off of westwood.
Free Windows Admin Tool Kit Click here and download it now
April 7th, 2007 11:12pm

well,I 've only intalled the "NWLink IPX/SPX/NetBIOS Compatible Transport Protocol" without any additional protocols beside the standard-IP & MS-protocols and it worked without any Problems. (once before updatet C&C with the auto-updater)the only thing missing in C&C is the id shown in the network-menue on C&C but I've no need for it.
April 17th, 2007 6:08pm

the vista ipx http://www.starbase01.com/site/index.php?id=22,87,0,0,1,0 did not seem to work i have vista 32bit and when i selected the file to add C:\IPX-SPX\Windows\INF it brings up a pop up after i click ok saying "could not add the requested feature. the error is: The specified module could not be found." do you have a clue what i am to do? i have a net work set up from a vista to a xp computer the xp has ipx all set up. i am trying to get this to work for command and conqueralso please reply to me i am in need of some help and i am 100% sure that i didfollow the information on the page correctly
Free Windows Admin Tool Kit Click here and download it now
April 20th, 2007 4:56pm

hi i just finnished installing the patch from the starbaseo1.com site and it all worked well, however i realised that unlike the xp ixpprotocol i could not access the properties of this new protocol and therefore could not specify the frame type and network number which is required to play warcraft 2. if anyone has any ideas please let me no as id love to network this classic game with my flatmates
April 23rd, 2007 9:51am

Be shure to extract the content of the downloaded files tothe root directory on the harddrive where vista is installed (maybe c:\). This puts the different files into the correct folder under the windowsdirectory. then it should work - it worked for me...
Free Windows Admin Tool Kit Click here and download it now
May 16th, 2007 10:20pm

I've downloaded the patch and tried to extract it to (c:\) and it says to replace the windows file. Now this isnt my computer im doing it on and was wondering if im supposed to go forward with replacing the windows file or im i doing something wrong. Its on Windows Vista Home Professional.
June 27th, 2007 6:11pm

I've done this for windows vistathere is no properties button for it.i went to red alert2 and to options and network it said IPX not available.same problem as beforehow can i play red alert 2 LAN with another compuiter?one is on XP has IPX other is on VISTA has this IPX, but it shows not avaiable in the gameplz help
Free Windows Admin Tool Kit Click here and download it now
July 2nd, 2007 12:11am

this is the same problem i faced i had vista home basic and the downloadable file did not work for me the only way i got it to work was by taking vista off and putting xp on so that i had xp linking to xp with ipx for c&c
July 6th, 2007 11:23am

Any ideas how I gain access to the root directory. Despite being Administrator/Owner/Athenticated User I am denied access to c:\ and don't seem to be able to edit permissions to necessary effect.
Free Windows Admin Tool Kit Click here and download it now
November 18th, 2007 10:38pm

i have had the same problem. however i didn't have the option of switching back to xp because there was no display driver that supported my display card, which was compatible with vista only. but i have found a solution for playing Red alert 2 on vista. first you need a ipx protocol. you will find this at this site which worked for me. please use at your own risk. www.starbase01.com/site/index.php?aid=87 i used the automatic installation. after the install, go to manage network connections. then right click the network that you receive your internet on and go to properties. there you want to click on protocal and click add. you are going to see tthe protocol "nwlink ipx/netbios..." click on that and add it. this will allow you to use ipx on game sites. furthermore, i like playing online and so to get the game going on vista i found that installing the game a certain way helps from getting error messages. here are the steps i took: 1. install game. 2. go to properties on the red alert 2 icon which is on your desktop (if you chose this option) and go to compatibility. check the box next to "Run this program in compatibility mode for:" and choose "Windows XP (Service Pack 2). hit apply at the bottom and close the window. 3. now run the game without running the auto update first.if you auto update the game it will display a message saying something about a stringerror. 4. once you watch the movie that seems like ittakes hours to finish, go to options. then go to networks and you should see several ipx options. this shows that the ipx is working and you will be able toplay online. if it says thatthere is no ixp thentry restarting your computer. 5.then go back to the mainscreen and choose internet. once you choose custom game, it should tell you that there is a patch available. download the patch andlet the game reset. 6.this should do the trick. after doing this if the game is still not woking properly, which i had a problem with once, install the yuri's revenge game and auto update that aswell. this should definately fix your Red Alert 2 addiction. hope this works for all of you guys.
December 14th, 2007 12:31pm

You can see the IPX but it doesn't work on RAD ALARM 2.
Free Windows Admin Tool Kit Click here and download it now
March 1st, 2008 8:53am

I would also like an answer. I have the IPX protocol set up, but I can't acess it's properties, nor is it showing up in Red Alert 2.
April 4th, 2008 9:30pm

a lot of people have this problem, but why microsoft doesn't fix it ?
Free Windows Admin Tool Kit Click here and download it now
August 6th, 2008 7:31am

so has anyone found any answers yet? I am also trying to play c&c tiberian sun through a network with my friends but my vista won't let me click on the multiplayer network and the network card is undetectable in game.. there is a socket number and destination network that is blank though...would filling those out work? -my older windows computer is apprx 3 years old and its network card is showing. I can even join the network under multiplayer to get in the lobby..but not with my vista. --i changed the default gateway on my window pc to match my vista ip but still nothing..searched for answers everywhere. if anyone has any solution yet please reply!! thanks, sabian
September 22nd, 2008 3:43pm

Hey i found the solution;Download Red Alert 2 Patch from http://www.understorm.net/cnc/lan/ts_ra2.php and copy "wsock32.dll" from the downloaded archive to the root folder of your Red Alert 2 installation. - This replaces the deprecated IPX Protocol with the state of the art UDP protocol. (http://www.wikihow.com/Play-Red-Alert-2-over-the-Internet)Make sure all players are using UDP.Regards,Katz29
Free Windows Admin Tool Kit Click here and download it now
September 23rd, 2008 10:29am

if your having trouble using IPX/SPX use this:http://www.computercare.ca/forum/showthread.php?t=2562check that page, you can add .dll .sys . inf files from win xp, read the page follow it and it works for vista and windows 7.
March 16th, 2009 10:49pm

Do you know if they have one for windows 7 yet?
Free Windows Admin Tool Kit Click here and download it now
December 2nd, 2009 8:03pm

I tryed to load command and conquer Tiberian sun, on my vista beta 2 version and network with my son. But the game dose not pick up the network card, and go in to net work connection and go to load the NWLink IPX/SPX/NetBIOS Compatible Transport Protocol and it is not there. or an i missing somthing hase it been removed or named changed? thank for your time. redknight
January 17th, 2010 12:06pm

Windows 7 comes without the IPX/SPX protocol. Neither Microsoft nor Novell have created one at this time. You can download and install "XP Mode" from Microsoft at http://www.microsoft.com/windows/virtual-pc/download.aspx. This allows you to run Windows XP in a virtual window under Windows 7, and it does include (but not by default) the IPX/SPX protocol You will have to add it in the Control Panel at Network Connections. You can install your application under "XP mode" and it will then become available as a menu selection without running "XP Mode" from Windows 7. However neat this may sound, it does not necessarily mean your game will run in this manner. I tried to run Warcraft 2 for lan play over IPX/SPX using this method and it would not run because of a video problem. I wouldn't expect "XP Mode" to solve all instances of application incompatibility. It is really too bad that Microsoft never took the time to think this thing through and produce an IPX/SPX protocol for Windows 7 (outside of "XP Mode").
Free Windows Admin Tool Kit Click here and download it now
July 10th, 2010 9:15pm


Strict Standards: Non-static method Settings::getRecentTopicsLimit() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\Topic.php on line 120

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics

Strict Standards: Non-static method Skin::showFooter() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 119

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 56

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 91