Msg command - "Error 1825 getting session names"
I'm trying to send a message to another computer over network by using msg command. Both computers are using Win 7 Ultimate and are in same workgroup. I can send messages to myself just fine, but I get "Error 1825 getting session names" when I try to send a message to that (or any other) computer. So far I've tried: -known solution to Error 5 (setting AllowRemoteRPC to 1 in registry) -turning off firewall -starting any service that has something to do with remote connection -fixing WMI ports and port-forwarding them. Don't know if I succeeded and if it's even relevant, but I came across this when searching for solution to error 1825 I have a feeling it has something to do with router. I replaced original firmware with Tomato (v1.27) because of "quality of service". Router model is Linksys WRT54G/GS/GL. Any settings I should look for? What else can I try to do? Error 1825 translates to "A security package specific error occurred. " - what exactly does this mean? Also, what are requirement for msg command to work, apart from 2 or more computers, router and same workgroup? Thanks in advance! UPDATE: I created a homegroup, and while both computers are joined, msg command gives me error 5 instead of 1825. As I said, I already applied known fix for error 5, so it must be something else. Also, homegroup doesn't work as it should, computers don't detect each other and I do share libraries. Another thing, when I joined the homegroup, cmd font became smaller on both computers. It should be 8x12 size by default, but 8x12 option disappeared. I fixed that now, but it's still weird that joining a homegroup removed default font size in command prompt. It makes me wondering what else did homegroup mess up.
May 29th, 2010 12:52am

Hi All after much trying and re trying i got it right to send windows 7 to windows 7 using the following command msg /server:pcname username message server stays as is. pcname is the name of the pc you are sending to. user name is the name the user is logged in under on that PC. message is obviously the msg u want to send. you will also need to change a setting on the receiving computer by using regedit. the following registry key must be activated (as described by Consoles above): HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server Name : AllowRemoteRPC Type : REG_DWORD Value : 1 (the dafault is '0')
Free Windows Admin Tool Kit Click here and download it now
July 22nd, 2010 3:31pm

Hello, great to see this answer, thank you, I had the same problem. I'm trying to send messages with msg.exe between two computers running Windows 7 (one with Home premium, the other Ultimate) , connected by Homegroup, NOT network. I fixed AllowRemoteRPC, turning it to 1, I turned off firewall (which I don't think matters) but still, it doesn't work. Now I get the message: "[user] does not exist or is disconnected" Where [user] is the username of the administrator of the other pc. I tried with * too (which means all users) but I get "* does not exist or is disconnected" Note that on my pc I am logged as administrator without password and the user at the pc I'm sending to is also the same. You said that you made it work on Win 7. Any particular settings you have? Thanx! SG
December 21st, 2010 6:01pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics