Metro Apps (expect Maps) Stuck At Splash Screen

Lots of people are having this problem, many of them lucky enough to find solutions through various means.  This thread is for those of us who are still not being able to open Windows 8 default applications (Mail, Music, Photos, etc). 

I have looked at every solution around the web and none of them are working for me.  I'll list everything tried to get that out of the way:

  • Screen resolution too low - NO (1920x1080)
  • Running avast or other 3rd party anti-virus - NO
  • Using built in admin with Windows Live ID - NO
  • Registry errors - NO (tried the "Ole" delete)
  • Updated graphics drivers - No (Windows update and directly from NVDIA's site)
  • Refresh your PC - NO (I tried this, but got an error saying my install drive is locked) - Please take a look at my other thread about this issue

There are other small things I have tried with no luck, hence my asking the question.

My computer is a brand new Dell Inspiron 17R Special Edition, it is completely loaded 2TB drive, 8GB ram, Core i7 processor, HD screen - all meaning I don't see this being a compatibility/ hardware issue. 

Strangely enough:

  • The apps worked just fine for 3 days after my install, then suddenly yesterday morning all default apps stopped opening
  • Windows Store does not load, so I cannot update or uninstall then reinstall
  • Any apps I had downloaded before this problem, like solitaire and Netflix work just fine.
  • The Maps app works though
  • The apps on the start screen WILL live update - I can see the weather, and email messages on the tiles, but then get stuck at aforementioned splash screen.
  • Notifications still work - running in the desktop I will receive messaging and outlook notifications, but when I click them, splash screen is all I get.

Any ideas?  I upgraded from Windows 7 Ultimate with the Windows 8 Upgrade Assistant using a promo code from

  • Edited by WakaFlakaFlame Monday, October 29, 2012 12:39 PM Apps DID work fine after install, then stopped.
October 29th, 2012 12:38pm


Have you tried creating a new user profile?

Free Windows Admin Tool Kit Click here and download it now
October 29th, 2012 12:42pm

Yes, I meant to put an explanation next to "Using built in admin with Windows Live ID".

I have made new accounts as local and Windows Live IDs, with admin controls and standard permissions. 

UAC is not the issue, I have tested every account with every level of setting, from OFF to FULL and DEFAULT.

Hasn't gotten apps to open yet...thanks for answering though!

October 29th, 2012 12:51pm

I may have found the issue, but need a bit of help figuring it out.

I looked under installed Windows Updates and found that Windows installed an optional update (or I may have been carefree and said to install it) Yesterday @ 12:31pm.  I remember this is exactly when the apps stopped working!

However when I go to "Remove and update, see Installed Updates" It is not listed under there! Only the recommended updates are listed to be uninstalled! 

Does anyone know how to uninstall this update?!

Free Windows Admin Tool Kit Click here and download it now
October 29th, 2012 2:21pm


It is your graphic adapter driver. I suggest you uninstall the driver from Device Manager, then go to manufacture's website to load the driver manually.

Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

If the issue persists, you can contact GeForce which driver is compatible with Windows 8.

October 31st, 2012 6:20am

Hello WakaFlakaFlame,

I just experienced the same problem, however only "Windows Store" app stucks at splash screen. Other metro apps work fine.

These are what I've done to make it work. Hopefully after Windows Store works, you can reinstall other apps as well.

1. Close windows store (Alt+F4 or close gesture or Win+Tab>Right click>Close)
2. Wait 11 seconds (metro apps are only suspended for 10 seconds after being closed, not fully terminated)
3. Run the Windows 8 App Diagnostic Tool. Download here (in my case, it found an error and repaired it).
4. Open windows store. It will stuck at splash screen as usual.
5. Open task manager.
6. Kill the "Microsoft WWA host" process.
7. Press Win+Tab and right click "Store" and then close.
8. Wait another 11 seconds and run Windows store app again.
9. Windows store should work fine.

Free Windows Admin Tool Kit Click here and download it now
November 10th, 2012 11:02am

Oh thansk, after kill Microsoft WWA Host, Windows Store work fine
March 7th, 2015 10:55pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics