Limit Disk Space Used by Offline Files Group Policy is not working properly
Since this could be a very useful setting in a corporate environment, I would very much like it to work or have an alternative way of setting it (except manually). The problem is, if you enable and configure this setting, the client computer will have the option grayed out but the previous setting seems to stick. I thought perhaps it was a UI bug, which "forgot" to actually move the sliders all the way to 100 %. I tested this by filling network share with more data then the previous limit (25%), and every file after that wasnt cached. So, if the disk with the offline files were 100 GB, it used 25%/25GB of the disk even tho the GPO was configured to 100 GB, or even 1000 GB. Its been posted in this forum before: However, its marked as solved without something which even resembles a solution. Anyone know how to solve this, or can someone else confirm the bug? Ive tested in our corporate environment, and a test lab with the same results.
January 14th, 2010 6:27am

What is the system of the DC? How do you apply this policy? In Windows Vista and Windows 7 this policy is located in Computer Configuration\Administrative Templates\Network\Offline Files. By default it will use 25% disk space. I suggest you manually enable this policy on a Windows 7 computer that is not in the domain and check the result. Also you can run the following command in a command prompt window that is run with administrator privilege. gpresult /z > %userprofile%\Desktop\gpresult.txt Then open the file gpresult.txt on Desktop, please check if the policy is successfully applied.Arthur Xie - MSFT
Free Windows Admin Tool Kit Click here and download it now
January 18th, 2010 2:28am

The DC is running on a Windows 2003 R2 server with the Windows 7 admin templates added. I have also tested this on a lab environment with Windows 2008 R2 server, with the same results. Its is configured via "Computer Configuration\Administrative Template\Network\Offline Files\Limit Disk Space Used by Offline Files" and different values have been tested, without any other result that the option (the sliders) becomes grayed out on the client computer (for manual configuration). If the client computer did not have the setting configured manually prior to the enabling the GPO, it was locked on 25%. If however the client computer had set it higher manually prior to enabling the GPO, it was locked/grayed out on that value. Hence the only effect this GPO seems to have is to disable manual configuration of disk space used by offline files, but it does not actually configure the disk usage. I did a test where the GPO was configured with a 100 GB limit on both settings, but the client computer showed it configured to locked to 25% of a 174 GB partition. I ran a 2nd test with the GPO configured with a 5 GB limit on both settings, with the client computer showing the same result. gpresult says the policy is applied. If I manually set the offline files disk usage limit (when the GPO is not configured or disabled) via an admin account, the sliders move, the vales are changed... it works. But its not exactly an option to set this config manually for each portable computer. About your suggestion: "I suggest you manually enable this policy on a Windows 7 computer that is not in the domain and check the result." How exactly do I do that?
January 18th, 2010 6:23am

We have tested on our side. This behavior is by design. When the policy is enabled the slides are grayed out. The disk space usages are actually changed. They are controlled by the policy and we cannot change it by moving the slide in UI. The settings that you can see in the UI are not applied.Arthur Xie - MSFT
Free Windows Admin Tool Kit Click here and download it now
January 19th, 2010 9:39pm

Which version of Windows Server did you use on your DC, and which version of Windows did you run as test-client? Maybe this was a setting that worked in Windows Vista? The clients I have tested it on was running Windows 7 Enterprise. Did you make any extra configurations in your setup which you think could be related to this issue? Is it possible to configure it "manually" via the registry so it can be scripted instead?
January 20th, 2010 9:40am

In our environment we have Windows Server 2003 and Windows Server 2008 domains. Clients are Windows 7 Ultimate. No other settings can control the disk space usage for offline files. If you would like to manually change it in Registry, you may change the values for the following keys. HKLM\Software\Policies\Microsoft\Windows\NetCache\CacheQuotaLimit HKLM\Software\Policies\Microsoft\Windows\NetCache\CacheQuotaLimitUnpinnedArthur Xie - MSFT
Free Windows Admin Tool Kit Click here and download it now
January 21st, 2010 3:29am

Is that the 32-bit or 64-bit version of Windows 7 Ultimate? I tested by manually configuring the limits with an admin account - in which case the settings worked as confirmed earlier - but of course those registry settings did not exist. Again, a test with the policy enabled - in which the settings did not work, but the registry values (CacheQuotaLimit and CacheQuotaLimitUnpinned) existed. I am using the 64-bit version here, so I will make a new test in the lab environment to see if it works on a 32-bit version of Windows 7. I will post updates on the results.
January 21st, 2010 9:57am

Same results with Windows 7 Enterprise 32-bit. I configured the offline cache limit to be 100 GB, but sync center shows an error telling me the offline cache is full. The sliders are set at 12 GB, 19,9% of a 60 GB disk and grayed out.This is so strange, what else could cause this to not work?Anyone else have the oppertunity to test if this setting works for them?Any other tips on how to try and solve this?
Free Windows Admin Tool Kit Click here and download it now
January 21st, 2010 1:15pm

Just a update to this issue. I have now tested Windows 7 Enterprise (x86 and x64) and Windows 7 Ultimate, with and without Windows Updates, and they do not apply this configuration correctly. Even tho the values are punched in the registry, and the "Disk Usage" sliders are locked (grayed out), the values are still incorrect, stuck at whatever the default value is (somewhat close to 25% for the most time). And here comes the strange part... I have also tested with Windows Vista Enterprise (x64), and it works! The machine has a identical configuration to what the Windows 7 machines have, exist in the same OU with the same GPOs applied... To me this seems like a Windows 7 bug, but I still find it strange that Arthur Xie says it works as intended with his setup using Windows 7 Ultimate. I've made a clean test setup in AD/GPO to eliminate the chance that there might have been a strange GPO conflict or something like that in our production environment, but the result was still the same. I have no idea why this works for Arthur Xie and not in our environment with Windows 7. Think I might call in Microsoft support for this one, even tho I kind of doubt it will help.
March 3rd, 2010 4:14am

does not work for me. My 2008 Server does not run the patch :-/
Free Windows Admin Tool Kit Click here and download it now
April 2nd, 2012 5:54am

but i am unable to find the keys which u specified HKLM\Software\Policies\Microsoft\Windows\NetCache\CacheQuotaLimit HKLM\Software\Policies\Microsoft\Windows\NetCache\CacheQuotaLimitUnpinned in my system.i made the gpo as not configured.will u please specify is there any registry keys affected for this disk space option even though when i am not select enable or disable option in gpo for xp,vista,win 7and win 8.and is there any restriction that my computer want to be in work group and domain option? plzzzzzzzzzzzzzz plzzzzzzzzzzzzzzzzzzz clarify my doubt regarding me anyone on this issue.
November 11th, 2012 11:27pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics