Increasing IRPStackSize in Vista?
When I try to print or map a network drive it gives me this error the mapped netowrk drive coule not be created because the error has occured - not enough server storage is available to process this command. Upon googling the error, the solution is to increase the IRPStackSize. There is nothing in Vistas registry pertaining to stack size, so how do I fix this problem? __ Customer was able to map all her drives and print succesfully for a day or two, then this error arose and she cannot print nor map new drives
April 16th, 2007 8:52pm

I figured it out. Thanks
Free Windows Admin Tool Kit Click here and download it now
April 16th, 2007 10:14pm

Problem still persists. Customer is still unable to print over her network or map network drives. Help would be greatly appreciated.
April 17th, 2007 8:00pm

It's still messed up! Help would be greatly apprecaited.
Free Windows Admin Tool Kit Click here and download it now
April 17th, 2007 8:01pm

This may or may not be pertinent... Make sure you backup your registry before you make any changes... Good luck...
April 18th, 2007 1:45pm

I am trying to Map my Vista Ultimate Lapop & also a different XP Pro Laptop to a Shared Drive on my XP Pro Desktop. We are all in the same Work Group & can Share other Drives & Printers. I recently purshaed an External 500 GB USD HDD. I attached it to my Desktop then formatted it NTFS & created a Network Share. Now when I attempt to Map the drive from Explorer or Net Use from the Command Prompt I receive the error "Not enough server storage is available to process this command." I found your suggested fix and had to create the IRPStackSize DWord & I put the Decimal Valul at 30.I wonder if there is something else. It seemed to have no effect. I am now upping the number to 40. Keep your fingers crossed.
Free Windows Admin Tool Kit Click here and download it now
April 19th, 2007 6:13am

Has there been an update for this? I am having the same problem. I have a 750GB External Seagate FreeAgent Pro attatched to a Windows XP machine. When I try and map it or access it in Windows Vista Ultimate, I get the error "Not enough server storage is available to process this command." I have tried the IRPStackSize increases and it did not help. Any other ideas or a fix would be greatly appreciated.
May 31st, 2007 5:33am

I found in XP that I could not map to a USB external hard drive and found the usual info about changing the value. If the IRPStackSize Key was deleted and then re-created after a re-boot, then it functioned correctly with a value of 15. apparently some AV's cause this to happen. Some times the key does not exist to start with and needs to be manually created in HKLM\System\CurrentControlSet\Services\lanmanserver\parameters, dont know where it should be in Vista though. Usual precautions about registry, back up first though. Hope this helps, if not you, then some one else.
Free Windows Admin Tool Kit Click here and download it now
June 4th, 2007 5:45pm

Having the same problem here; We have 2 vista business machines and 2 Windows XP laptops all with a mapped network drive hosted on another windows XP machine. The 2 Vista business machines are the only ones having any problem connecting the drive. Both with the same error: "not enough server storage is available to process this command" This usually starts working after a few retries but does tend to happen at least a few times a day. At first I thought the problem was with the XP machine hosting the network drive, so I increased the IRPStackSize, this has not worked. The connection error is only occuring on the Vista machines.
June 14th, 2007 1:43am

I'm probably a little late in responding to this, I was looking for a different solution, but saw this question. I have had the same problem, and I just now reproduced it to verify. I run Roboform on each of my workstations. I keep the database in a protected location on an NAS drive. This works very well, and keeps the local copies of the DB sync'd with the master. I switch networks depending on what I'm doing: for example, I'm now connected to my webserver's wireless network, as I was doing some maintenance on the server. When I am using a browser (IE or Firefox) Roboform tries to access it's primary database location, on the NAS drive. Obviously, it's not there. After a few long moments, this message pops up. (NOTE: this occurs while using Vista or XP)."There is not enough free space on volume 'S:' At least 524288 bytes is required"S is the mapped network drive for this resource. Once that message is cleared, I can browse normally, until another browse event causes Roboform to look for matching passcards. I have not been able to prevent this from happening except by disabling Roboform for this session. It's more of an annoyance than anything else. Because the networks are completely disparate, there is likely no easy solution, except to shut down the "mapped" resource for the session. If you are mapping a resource that you "should" be able to see on your current connection, you may have to either establish a static route, or possibly use LMHOSTS to pre-fill the DNS data for the resource. Or...if the resource is only available intermittently (like a hard drive or printer that can't be reached unless the host machine is on), you'll need to figure out a way to call on the resource only when you need it...and, can get to it.Dunno if you need this, but in case I don't head back this way, background:Workstation platforms: XP Pro SP2, XP Home SP2, Vista Ultimate.Network is 10/100 wired and wireless (802.11g and 11n), gateway/router is in place, local dns is managed with shared LMHOSTS, WAN dns managed by ISP.Shared Network resources include: mapped data drives, printer services, streaming media, automated backup functions, VPN, SSH, FTP,
Free Windows Admin Tool Kit Click here and download it now
June 16th, 2007 8:16am

I think I got this to work. The solution was to set IRPStackSize on the PC that is connected to the Ext. USB drive, not necessarily the remote PC/laptop that is trying to access the drive. My setup was a Vista laptop and an XP PC which shared a wireless network. The Vista laptop could see all of the PC's regular drives, but gave me the now infamous "not enough server storage is available to process this command" error when I tried to view the Ext. USB Drive.Since the Vista laptop was the one giving me the error, naturally, I added IRPStackSize to its registry. The problem is that I needed to actually add it to the XP PC which was the one that was physically connected to the Ext. USB drive.To be safe, I actually added it to both the Vista laptop and the XP PC. I set the value to 50 on both, rebooted both machines and I could then see the drive.
November 21st, 2007 5:12am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics