Hyper-v cannot add any network switches
I just upgraded from from Win 7 to Win 8 enterprise and have installed hyper-v. I am now unable to add any network switches (external, internal or private). I have uninstalled hyper-v and my nics multiple times. I have also tried to adding a switch using the powershell command New-VMSwitch.

All the errors come down to a file not found error but here is the one from powershell:

New-VMSwitch : Failed while creating virtual Ethernet switch.
Switch create failed, name = '21B8292F-A4FD-4FFF-93A9-76602E2DE9EE', friendly name = '': The system cannot find the file specified. (0x80070002).
The operation failed because the file was not found.
At line:1 char:1
+ New-VMSwitch "Wireless NIC" NetAdapterName "Wi-Fi" MinimumBandwidthMode Weight
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (Microsoft.HyperV.PowerShell.VMTask:VMTask) [New-VMSwitch], Virtualizati
+ FullyQualifiedErrorId : ObjectNotFound,Microsoft.HyperV.PowerShell.Commands.NewVMSwitchCommand

Any thoughts would be appreciated.
October 21st, 2012 12:15am

Hi James!

This sounds like an issue with the drivers for wireless NIC. I had the same problem at first, but then I found some new drivers and after a reinstall it worked like a charm. So try to update the drivers for your NIC, and run Windows update as well to install the latest patches for the OS.

I hope this will help you!

Best regards
Andreas Molin

Free Windows Admin Tool Kit Click here and download it now
October 23rd, 2012 1:02pm


I have tried reinstalling both NICs and downloading new drivers from Dell, but I can look harder if you think it could effect everything.  Do you think the wireless NIC would prevent all switch types from being added (internal & private too)?

Thank for the reply

October 23rd, 2012 1:17pm


I'm running my switches on the wireless card of my HP-computer, so that shouldn't be a problem.
Does it work if you try to add a switch to the wired NIC?


Free Windows Admin Tool Kit Click here and download it now
October 23rd, 2012 1:33pm

I cannot add anything (External, Internal or Private).  They all come back with something pointing to file not found.
October 23rd, 2012 1:35pm


Please uninstall the NIC/WiFi device from Device manager, then scanned for device and reinstall the device for a test.

Free Windows Admin Tool Kit Click here and download it now
October 24th, 2012 5:50am


I have done that multiple times already (see above response to Andreas for details).  Would this effect my ability to add even a "private' switch?

October 24th, 2012 12:14pm

Hardware drivers will not affect an internal or private switch. Something else is wrong.
Free Windows Admin Tool Kit Click here and download it now
October 24th, 2012 3:23pm


thanks, that was my gut instinct but I am a dev, and not an infrastructure guy so I was not sure.  

Given that the error seems to always point to "file not found", would there be any folder permissions or files that anyone knows of to check that specifically get modified when a switch is created?

October 24th, 2012 3:32pm

I am having the same issue. This computer is an upgrade from 2008R2 to 2012. The existing switchs worked but they are not gone during trying to figure out why I could not add a new one and now I have none.  I found a few articles related to 2008R2 hyper-v but none of those fixes worked. I have been unable to pinpoint the issue with process monitor as well.
Free Windows Admin Tool Kit Click here and download it now
November 7th, 2012 4:17pm

I have the same issue :(

also upgraded from win7 to win8.

perhaps is related but my connectify and related software does not work anymore because for some reason i can not create hostednetwork.

  • Edited by btomas Sunday, November 18, 2012 1:41 PM
November 18th, 2012 1:41pm

Having the exact same problem here.
Free Windows Admin Tool Kit Click here and download it now
November 25th, 2012 7:10pm

I, too am having this issue.  The system in question was an upgrade from win7 x64 ultimate to win8 x64 pro, has all win8 updates installed, and latest drivers from realtek.  Another machine works perfectly with same NIC and older drivers.  The failing one has a Gigabyte motherboard (latest firmware) and has had to have USB3.0 disabled in the BIOS to even allow hyper-v to boot.  Maybe there's another tweak required.

However, the fact remains that hyper-v cannot create even an internal switch, which surely can't need a driver.  And the error message complains about a missing file.  Pretty shoddy programming to not specify in the event what file is actually missing, no?

If anyone with access to the code wants tests run, I'll happily oblige.

November 26th, 2012 4:19am

Hello All

I am having this same issue - 'file not found error' when trying to add a virtual switch to Hyper-V.

Upgraded from Win 7 to Win 8 (Pro) and have installed Hyper-V. Cannot install any type of network switch, even after uninstalling Hyper-V and my nic multiple times.

A solution would be greatly appreciated - a fresh install of Win 8 will take me _way_ too long :(.

Free Windows Admin Tool Kit Click here and download it now
December 17th, 2012 5:17pm

My Problem was solved by adding my user to Hyper V Authorization issue see this blog 



April 15th, 2015 4:43pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics