FIM Portal Security Groups missing
When I go to the portal as an administrator, I see the section Security Groups When I go to the portal as an user - Security Groups missing Why?
July 8th, 2010 9:11am


On the FIM Technet Page you will find a lot of documentation on FIM 2010. Check it out! The reason of this behavior is the usage of Keywords. FIM Portal is highly customizable and this is done through these keywords. For Example the keyword BasicUI makes a Navigation Bar Resource available for all users.

Usage Keywords - This is a multivalued string attribute, with each entry delimited by a new line. Portal administrators can use this attribute to customize which set of users can see which set of Navigation Bar resources. You can create a set of Navigation Bar resources based on a particular Usage Keyword value. You can then create a Management Policy Rule using this set to grant certain privileged users permissions to read these Navigation Bar resources. To allow the same set of users to see a new Navigation Bar resource, you simply add that particular Usage Keyword in the new Navigation Bar resource. The new resource will automatically transition into the Navigation Bar set. For detailed steps to grant permission to users to view Navigation Bar resources, see Introduction to Configuring and Customizing the FIM Portal in the FIM documentation.



  • Marked as answer by FighterZP Thursday, July 08, 2010 1:26 PM
Free Windows Admin Tool Kit Click here and download it now
July 8th, 2010 11:55am

July 8th, 2010 1:26pm

Traveling down this same path...I managed to add the keyword "BasicUI" to the Navigation Bar options to get the Security Groups section.  However, when I go to those pages as a user, I don't have a "Search" field up at the top-right of the screen.  What am I missing?
Free Windows Admin Tool Kit Click here and download it now
December 23rd, 2010 7:10pm


if you do the same for the necessary Search Scope item in the Administration section you will get your issue fixed.

However what i also found is that after adding the keyword to all items a user still couldn't do search (list is empty)!

quick search in list of MPRs didn't show me an appropriate standard policy to enable so i created my one "Users can read Security Groups" with Read source permission to All Security Groups as target (choose whatever you need in settings) and after that.. finally works correct!

Hope this helps.


March 11th, 2011 9:31am

I was able to add BasicUI under Search Scope to My Security Groups and My SG Memberships and it allowed my to search for my security groups but only after I did an iisreset.
Free Windows Admin Tool Kit Click here and download it now
December 29th, 2011 9:19pm

Yes, anytime you change anything related to the UI, an IISRESET is required for the changes to show up. Actually there are settings in the Portal Configuration that control refresh intervals for UI items, but those can take up to 24 hours for some items, so an IISREST will get everything refreshed for you right away.
December 29th, 2011 10:11pm


I miss the search function also. But I can't get it fixed with an MPR, can you please explain me what configuration you made exactly?

I also can not see the security groups on the my SG window. I've filled the Usage Keywords with BasisUI. Can someone tell me what im doing wrong?

Thank you,


Free Windows Admin Tool Kit Click here and download it now
November 15th, 2012 9:08am

To allow regular users to see and search Security Groups, you need to enable the default security group related MPRs, and point them to a different set / modify the "security group users" set so that it includes your users.

To see the search option you have to add "BasicUI" to the usage keyword list for the "All security groups" search scope. Administration->search scopes->"All security groups"->"usage keywords". (You can off course use a MPR to grant users access to one of the different usage keywords already present instead, which might make more sense if you want to give access to certain user groups and not all.)

May 12th, 2015 6:09am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics