Error raised in the event log when browsing the portal


I have the FIM Portal (FIM 2012 R2) running on Sharepoint 2013 on Windows Server 2012

I recently upgraded FIM to the latest build (4.1.3496) and now whenever I browse the portal an event is raised in the event log (although the portal still works). This is the error:

Requestor: urn:uuid:7fb2b853-24f0-4498-9534-4e10589723c4
Correlation Identifier: 84d217f1-2ce7-46f3-afe6-d17005e64321
Microsoft.ResourceManagement.WebServices.Exceptions.UnwillingToPerformException: Other ---> System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
   at System.ThrowHelper.ThrowKeyNotFoundException()
   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
   at Microsoft.ResourceManagement.Query.QueryParametersGenerator.WriteRequestedAttributes()
   at Microsoft.ResourceManagement.Query.QueryParametersGenerator.BuildParameterString()
   at Microsoft.ResourceManagement.Query.QueryProcessor.BuildSqlCommand(Query objectRepresentation, Boolean countResultsOnly)
   at Microsoft.ResourceManagement.Query.QueryProcessor.ExecuteQuery(Query query, Nullable`1 maximumTime, Boolean& endOfSequence, Boolean countResultsOnly, Int64& resultCount, Int64& executionTime)
   at Microsoft.ResourceManagement.WebServices.RequestDispatcher.ExecutePullActionImpl(PullRequestParameter pullParameter)
   at Microsoft.ResourceManagement.WebServices.RequestDispatcher.ExecuteEnumerateAction(RequestType request)
   at Microsoft.ResourceManagement.WebServices.RequestDispatcher.ExecuteAction(RequestType request)
   at Microsoft.ResourceManagement.WebServices.RequestDispatcher.ExecuteAction[ResponseBodyType](RequestType request)
   at Microsoft.ResourceManagement.WebServices.RequestDispatcher.DispatchRequest[ResponseBodyType](RequestType request, Guid requestIdentifier, Object redispatchSingleInstanceKey, Boolean isRedispatch)
   at Microsoft.ResourceManagement.WebServices.RequestDispatcher.DispatchRequest[ResponseBodyType](RequestType request)
   at Microsoft.ResourceManagement.WebServices.ResourceManagementService.Enumerate(Message request)

In addition, I am unable to change any RCDCs now since every time I update it I get an error in the portal despite me making extra sure the RCDC is correct. I have a feeling this is some error related to SharePoint, but I don't know how to investigate this further.

Any ideas?

January 20th, 2014 3:42am

Sounds like some data corruption. I suggest calling support
Free Windows Admin Tool Kit Click here and download it now
January 20th, 2014 1:43pm


I also had these errors after installing hotfix 4.1.3496.0.

The solution for me was to follow the steps outlined in the KB article associated with the hotfix.  The new feature in the hotfix is the ability to hide the advanced search option in the portal, but it requires manual schema changes.  After I updated the schema, the errors disappeared.

Copied from the KB:

To enable the configuration and remove the Advanced Search link, follow these steps:
  1. In Administration, click Schema Management, and then click All Attributes.
  2. Create a new Boolean attribute that is named "HideAdvancedSearchLink."
  3. In All Bindings, create a new binding for the HideAdvancedSearchLink attribute to the Portal Configuration resource, and then click Finish to save the binding.
  4. Create a new Management Policy Rule (MPR) to allow for changes to the new binding in the portal configuration. To do this, use the following configuration for the new MPR: Display Name: Administrators can modify the HideAdvancedSearchLink attribute in the Portal Configuration resource
    Type: Request
    Disabled: False
    Specific Set of Requestors: All Administrators
    Operation: Modify a single-valued attribute
    Permissions: Grants permission
    Target Resource Definition Before Request: All Basic Configuration Objects
    Target Resource Definition After Request: All Basic Configuration Objects
    Resource Attributes: Select specific attributes: HideAdvancedSearchLink
  5. Reset Internet Information Services (IIS), and then restart the FIM service.
  6. In Administration, click Portal Configuration, and then click Extended Attributes. You should see theHideAdvancedSearchLink attribute together with the other extended attributes.
  7. Click to select the HideAdvancedSearchLink check box, and then click Submit to enable the hiding of the Advanced Search link.
  8. Verify that the Advanced Search link is not available in the list views. For example, check the following list views:
    • My DGs
    • My DG Memberships
    • Management Policy Rules

January 21st, 2014 6:25pm

Hi Andrew,

Thanks for your help, can't believe I missed that from the release notes!

Creating the attribute fixed the issue, I also noticed that its not necessary to hide the advanced search - simply creating the attribute and binding it to Portal configuration is enough to stop the event from being raised.

Once again, thanks a lot, much appreciated

Free Windows Admin Tool Kit Click here and download it now
January 22nd, 2014 3:27am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics