Error 800F0922 when installing Windows Updates and .Net Framework 3.5

I recently refreshed my Windows 8 installation as I had experienced a problem with graphics drivers which left my PC barely running.

The refresh seemed to go fine, albeit slowly, yet my computer was back up and running as it always had been. However, when I then attempted to reinstall the windows updates and programs I had lost in the refresh, it would fail for all updates with error code 800F0922. Furthermore, several 3rd party programs would fail to install, citing a 'microsoft.vc80.crt' error.

I was unable, therefore, to update to Windows 8.1 through the Windows Store (as this requires a readiness-for-8.1 update for Windows 8) which required me to update through a disc copy burnt from an .iso downloaded with my key. I had hoped the installation of Windows 8.1 would fix my problem, however it did not - I am experiencing exactly the same errors with all Windows updates and certain programs.

I have determined from a large trawl of the internet and Microsoft forums that my problem is related to a problem in the installation of .Net Framework 3.5. I therefore followed all given instructions as to turn this feature on and fix it.

When attempting to install .Net Framework reliant products, I receive Error 1935.

Let me be clear in this situation: The following fixes I have tried have all taken place on my recently-refreshed machine both normal and clean-booted, from elevated-level command prompt where applicable and with no 3rd party anti-virus or firewall software enabled.

Here is a non-exhaustive list of what I have tried and the results (I have left out my first attempted fixes solely related to Windows update as it became clear my problem was not isolated to that particular area):

- Control panel -> Programs and Features -> Turn Windows Features On or Off -> .Net Framework 3.5 -> Installation (not download) fails with error 0x0800F0922

- From command line dism /online /enable-feature /featurename:NetFx3 /All /Source:E:\sources\sxs /LimitAccess (where E:\ is my Windows 8.1 disc) -> completion bar moves to 99.8% where it hangs for a few seconds, and fails with error 0x800F0922.

- Using sfc /scannow to repair windows files -> completes with no found corruptions.

- Using dism /online /cleanup-image /restorehealth -> moves to 20% where is hangs for ~10mins and then proceeds to complete at 100% saying it has repaired corruptions. Running it again provides the same result.

- Using chkdsk -> completes with no errors found.

Downloaded and attempted to install KB2884846 -> Fails with error

Deleted TxR folder contents (in use by SYSTEM, had to force delete on boot)

Used fsutil resource setautoreset true C:\ -> Operation completes

- Stopped the update service and deleted all files from C:\Windows\SoftwareDistribution\Download -> Attempted install of updates again -> Update fails with error 800F0922.

- Stopped winmgmt service and renamed folder C:\Windows\system32\wbem\Repository -> Restarted service and attempted to install .Net Framework 3.0 -> Fails with error 800F0922.

- Repair install Windows 8.1 -> The problem persists in all forms.

- Refresh Windows 8.1 -> the problem persists on the refreshed machine.

I provide my DISM and CBS log here:

To pre-empt questions regarding the upgrade status of my Windows installation - yes, I upgraded to Windows 8 from 7 using a disc and then WMC key. However, my installation of 8.1 was done through a different key (as I was unable to simply upgrade through the store for reasons mentioned above).

I am only very short of completely reinstalling my Windows installation, but would prefer this as a last resort. I am happy to provide any more information that I may have missed in order for you to diagnose my problem.

  • Edited by coldsky Wednesday, November 27, 2013 5:14 PM
November 14th, 2013 8:57pm

Do you have any additional MUI packs installed?
Free Windows Admin Tool Kit Click here and download it now
November 15th, 2013 5:22am

Hi Andre,

Thanks for replying.

By MUI I assume you are referring to Multilingual User Interface.

I have English (UK), English (US) and Espaol (Ecuador) keyboard layouts, but my language pack is English (US); I have no others installed.

Also, I forgot to include in my first post, I have attempted to refresh Windows which did not fix the problem.

November 15th, 2013 11:56am

upload the CBS folder from C:\Windows\logs\
Free Windows Admin Tool Kit Click here and download it now
November 15th, 2013 5:49pm

Have uploaded CBS folder to same Skydrive location as DISM log.
November 15th, 2013 6:35pm

You miss a MUI from the WindowsStore which is part of KB2884846 (

2013-11-15 12:47:16, Info                  CBS    Calling client to resolve source, cannot find file 'amd64_microsoft-windows-s..client-ui.resources_31bf3856ad364e35_6.3.9600.16415_en-gb_ccec51a7d6eea7ef\WinStoreUI.dll.mui'
2013-11-15 12:47:16, Info                  CBS    Exec: Not able to pre-stage package: Package_77_for_KB2884846~31bf3856ad364e35~amd64~~, file: WinStoreUI.dll.mui, source: \\?\C:\WINDOWS\SoftwareDistribution\Download\ec743a58646255f6daa46205f24da8c4\amd64_microsoft-windows-s..client-ui.resources_31bf3856ad364e35_6.3.9600.16415_en-gb_ccec51a7d6eea7ef\WinStoreUI.dll.mui

Next you get the error STATUS_RM_NOT_ACTIVE :

2013-11-15 12:47:11, Error                 CSI    000001ae (F) STATUS_RM_NOT_ACTIVE #1218358# from Windows::Rtl::SystemImplementation::CSystemIsolationLayer_IRtlSystemIsolationLayerTearoff::OpenFilesystemDirectory(flags = (SharingViolationIsOk|TransactionalConflictIsOk|DeletePendingIsOk), da = (FILE_GENERIC_READ), dn = [ml:192{96},l:78{39}]"\SystemRoot\WinSxS\Temp\PendingRenames\", sa = (FILE_SHARE_READ|FILE_SHARE_WRITE|FILE_SHARE_DELETE), oo = (FILE_DIRECTORY_FILE|FILE_SYNCHRONOUS_IO_NONALERT|FILE_OPEN_FOR_BACKUP_INTENT), dir = NULL, disp = Invalid)
2013-11-15 12:47:11, Info                  CSI    000001af Error STATUS_RM_NOT_ACTIVE while executing operation MoveFile on [l:300{150}]"\SystemRoot\WinSxS\Temp\PendingRenames\cbd9c0cc00e2ce014304000038159017._0000000000000000.cdf-ms, \SystemRoot\WinSxS\FileMaps\_0000000000000000.cdf-ms"
this can be solved by deleting all files from C:\Windows\System32\config\TxR, next run

fsutil resource setautoreset true C:\

and reboot.

Don't forget to set the folder options to show all system and hidden files otherwise the TxR directory will look empty.

Free Windows Admin Tool Kit Click here and download it now
November 16th, 2013 7:08am

Hi Andre,

I have already performed this step. I have previously deleted all files from TxR and run fsutil.

However, I decided to run this step again following your advice (I had to force the delete of TxR files from reboot as they were in use by SYSTEM), but to no avail.

I followed these steps:

- Downloaded and attempted to install KB2884846 -> Fails with error

- Deleted TxR folder contents (in use by SYSTEM, had to force delete on boot)

- Used fsutil resource setautoreset true C:\ -> Operation completes

The problem persists.

  • Edited by coldsky Saturday, November 16, 2013 11:05 AM
November 16th, 2013 10:59am

remove the Update KB2884846 from control panel if it is installed. If you can't install the update, stop the update service, delete all files from C:\Windows\softwaredistribution\download and try again to install the update.
Free Windows Admin Tool Kit Click here and download it now
November 16th, 2013 7:39pm

Thanks for taking the time to help me with this problem.

- Update KB2884826 was not installed already. 

- Stopped the update service and deleted all files from C:\Windows\SoftwareDistribution\Download -> Attempted install of update again -> Update fails with error 800F0922.

Naturally, the problem persists.

November 16th, 2013 9:23pm

upload the new logs.
Free Windows Admin Tool Kit Click here and download it now
November 17th, 2013 6:28am

New CBS log uploaded to same Skydrive location as CBS (1).
November 17th, 2013 10:40am

the log is too small. Windows stores older logs into CAB files. Upload the cabs, too.
Free Windows Admin Tool Kit Click here and download it now
November 17th, 2013 6:38pm

There are no CAB files within the CBS logs directory. I have uploaded the 3 CBSPersist logs to the Skydrive location, however.
November 18th, 2013 12:05pm

 you get again the  ERROR_RM_NOT_ACTIVE issues which should be fixed by deleting the files in the TxR folder.

Repair Windows:

This should also work for Win8.

Free Windows Admin Tool Kit Click here and download it now
November 18th, 2013 7:03pm

Unfortunately this has not solved the problem.

- Repair install Windows 8.1 -> The problem persists in all forms.

Notably, I receive Error 1935 when trying to install .Net Framework products.
  • Edited by coldsky Tuesday, November 19, 2013 12:50 PM
November 19th, 2013 12:45pm

The problem is still not fixed.

Any more ideas would be appreciated.

Free Windows Admin Tool Kit Click here and download it now
November 26th, 2013 9:40pm

I have no other idea. Backup all data and install Windows again. After you did this create a complete backup image that you can restore if yo run into trouble again.
November 27th, 2013 5:29am


This article might be helpful to you:

Windows 8: Enable .NET Framework 3.5 (includes .NET 2.0 and 3.0) i.e. (NetFx3) feature in Online & Offline mode!

A user named "G1ZJK" encounter the same error 800F0922. And he resolved by the following steps:

1. net stop winmgmt

2. CD C:\windows\system32\wbem

3. rename repository repository.old

4. net start winmgmt

If it still doesn't resolve, you might need to reintsall Windows as Andre said.

Free Windows Admin Tool Kit Click here and download it now
November 27th, 2013 9:57am

Hi Karen,

Thanks for the aforementioned method and link.

Unfortunately I've already tried everything from the link and the steps provided did not fix the problem.

Needless to say I'm a little more than disappointed Microsoft hasn't taken more notice of this problem, seeing as how every page I visit for someone with a similar issue, there is yet to be a foolproof fix.

From my internet trawls I have gathered the following steps are a common theme in this 'unfixable' problem:

1. Upgraded (not clean install) to Windows 8 from 7 (or Vista).

2. Refreshed or repair installed Windows for some reason.

I am holding out hope for an answer.. But it appears the time to reinstall Windows may be drawing near. Obviously I and any others with the same issue won't be very happy if this is the only fix available.

My CBS and DISM logs are still available for analysis on Skydrive for anyone else who wants a crack at this issue.

November 27th, 2013 5:12pm

Well the problem no longer exists, but neither does my old OS installation.

Just a few things to note:

- A reinstall/reset of the Windows OS did not fix the problem.

- In order to fix I had to format my hard drive and perform a clean, brand-new install.

- This is not an answer to my question, as the fix required me to start anew, and will not be marked as such.

I hope others who have experienced this problem, and continue to, can find a real fix.

  • Edited by coldsky Sunday, December 15, 2013 9:16 PM
Free Windows Admin Tool Kit Click here and download it now
December 15th, 2013 9:15pm

Ok, I don't know if this will help, but my cousin's laptop is doing the same thing and it's very frustrating.  What I ended up doing was, I went to the control panel, and did the manual "windows update".  He had 12 updates to do.  I installed the file with the biggest memory, and manually installed it, then on reboot, (although I selected ONLY one of the 12 updates listed), the screen said "installing 1 of 6 updates"  what!?   I only selected one...I'm guessing that the one I installed contained some of the others.  When I checked win updates again there was only 6 left.  Presently we're trying to install the last four (one at a time).  Selecting the bigger leftover file didn't work, so we're trying to do it by selecting the smallest file.  I will post later, if I find any other answers.  I hope this helps some people.  I guess some is better than none (I suppose some would argue that...LOL).  Personally to me I say "Long live Windows 7".  Good luck.
January 23rd, 2014 10:57pm

I'm suffering on the same issue. Just wanted to thank you OP for the very comprehensive description of the issue. I've tried more or less the same steps as you have. Sadly no true fix visible to me at the moment either.

These two articles were interesting:

No luck with those however as the update referred to doesn't seem to exist.

One extra symptom I've had has been disappearance of my SSD C: drive from BIOS after couple of failed manual update tries. Unplugging power has made the drive visible again. Haven't seen that for the last couple of days though. I suspect something to do with mobo or ssd (UEFI, AHCI drivers, etc.) but I'm at completely lost on figuring out any ways to understand or troubleshoot.

Good luck to all others wandering this far...

Free Windows Admin Tool Kit Click here and download it now
May 13th, 2014 6:10pm

I had problems upgrading from 8.1 to 10 and hit this same issue with my PC updating the original 8.0 installation.  This is what I did to get past it:

Clean out Windows\temp and user's temp folders

Clean out C:\Windows\SoftwareDistribution\Download

Changed my Windows Updates so that it just prompts me and lets me decide what to install

Turned off option to check for other updates

Ran a check for updates (had 25)

Starting from the BOTTOM of the list (oldest), I was able to install them one at a time.  Takes forever, but it worked

If during this process, I hit a failure with any update, I would clean out the temp folders and try again

I made it all the way to KB2756872 before it failed again.

At this point, all I had left were the .Net 3.5 and 4.5 updates

I ran those updates successfully

I then turned off the Windows features for .Net (any version that shows up in the list)

Went back to install KB2756872 and it worked.

Now back to upgrading to 10.0!

September 9th, 2015 1:05pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics