Dual Band WIFI nic not seeing 5ghz band networks

I have windows 8 64bit release. I upgraded from windows 7 where I was connected via my wusb600N dual band network adapter using the 5ghz N network.

After the upgrade windows 8 only sees the 2.4ghz band networks.

The drivers installed are newer than anything on the Cisco site, and I did a search of the forum here and it appears that this was a known pre-release issue in the release candidate but worked prior to that. Any plans to fix this issue as it doesn't appear to only affect the Cisco wusb600n wifi adapter based on the discussions I've seen.

netr28ux.sys RALINK Technology Corp.

vwifibus.sys Microsoft Corporation 6.2.9200.16384 (win8_rtm.120725-1247)

Updating the driver just tells me I'm already updated to the best driver for my device:

Linksys WUSB600N Wireless-N USB Network Adapter with Dual-Band ver. 2

October 27th, 2012 8:08pm

Re-install the Windows 7 drivers.  The ones that likely were installed by MS may be the issue.  We had a user install win8 yesterday and when he did, he lost all networks.  Manual install of the original driver allowed connectivity again.
Free Windows Admin Tool Kit Click here and download it now
October 27th, 2012 8:11pm

RALINK provides the drivers for the wusb600n/rt2870 here: http://www.ralinktech.com/en/04_support/license.php?sn=5007

Just install the driver the utility that comes with it doesn't seem to work under windows 8.

October 28th, 2012 12:16am


This may be the compatibility issue. You may contact the manufacture and ask for the driver which is compatibility with Windows 8.

Free Windows Admin Tool Kit Click here and download it now
November 1st, 2012 9:34am

Posting my solutions in case anyone else runs into these issues on Windows 8.  I have yet to see both of these issues solved elsewhere.  I will go into detail for the less experienced.

1. The prepackaged driver that Windows 8 installs for the WUSB600N can only discover 2.4GHz networks.  Driver must be installed manually.
2. When disconnecting/reconnecting the adapter, Windows re-installs its broken version of the driver, making it necessary to manually install a driver each time the device is unplugged.  Since this is a USB adapter and as such is designed to be hot pluggable, this is absurd.  Let's fix.

The Windows 7 driver available at Linksys.com enables discovery of 5GHz networks.  For WUSB600Nv1, the correct driver as of this writing is v3.0.10.0.  It must be installed manually via the device's property box; there is no exe.  Download it to a folder you'll remember and extract the files from the zip file.

In desktop mode, open device manager.  Mouse to the bottom left corner of your screen; a menu appears. Select device manager.  Expand the network adapters category. Find the "Linksys Dual Band Wireless-N Adapter" (or similar) entry. 

Right-click and select "Update driver software..." from the context menu.  Now select "Browse my computer for driver software".  In the next window, select "Let me pick from a list of device drivers on my computer".

In the next window you will see the Linksys adapter driver already filled in.  This is the bad pre-installed driver; ignore it. Click "Have Disk...".   A file box will appear; use it to browse to the folder with the files you downloaded from Linksys.com and select the folder containing "netr28ux.inf".  Hit OK.

Back on the Update Driver Software screen it appears nothing has changed; don't worry.  Click next and Windows should start "Installing driver software...".  If a progress bar starts moving we're on the right track.  When done, the new driver is installed and you will be able to discover and connect to 5GHz networks. 

Now, to prevent Windows from undoing all that hard work each time the device is unplugged, we must implement another fix.  You need elevated administrator rights for this.  There are several ways to do what we are about to do next.  If you prefer another method, have at it.

Open an elevated command window: In desktop mode, hold down the Windows Key and hit R.  A run box appears.  Type "cmd" (minus the quotes) and press Ctrl+Shift+Enter.  If successful you now have an elevated command window.  The title bar should say "C:\Windows\system32\cmd.exe".  If not try again.  You must hold Ctrl, then Shift, then Enter.

Now we will set the driver file to read-only.  This prevents Windows from overwriting it.  In the elevated prompt type the following, minus the quotes: "attrib +R c:\windows\system32\drivers\netr28ux.sys"  If successful there will be no message.  No news is good news on this one :)

Close the command window and try unplugging/replugging the device.  The driver should stay put and you should be able to connect to 5GHz each time with no issue.  All fixed.


  • Proposed as answer by pingman12 Wednesday, July 31, 2013 1:40 AM
April 23rd, 2013 11:00am

This is the only solution that actually worked from more than a half dozen sites I checked
Free Windows Admin Tool Kit Click here and download it now
March 17th, 2015 11:01pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics