DistributedCOM issue for imebroker.exe



I got a dcom error event from system, about the "C:\Windows\System32\IME\SHARED\imebroker.exe"

when i want to modified the Local Activation permission, but the check box unable to select even though i am admin.

so how to fix the error issue?




Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Date:          2012/11/17 10:05:48
Event ID:      10016
Task Category: None
Level:         Error
Keywords:      Classic
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
 and APPID
 to the user LAPTOP\ABC SID (S-1-5-21-1169550721-3515471555-2295220807-1000) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    <EventID Qualifiers="0">10016</EventID>
    <TimeCreated SystemTime="2012-11-17T02:05:48.322249700Z" />
    <Correlation />
    <Execution ProcessID="924" ThreadID="932" />
    <Security UserID="S-1-5-21-1169550721-3515471555-2295220807-1000" />
    <Data Name="param1">application-specific</Data>
    <Data Name="param2">Local</Data>
    <Data Name="param3">Activation</Data>
    <Data Name="param4">{DE50C7BB-FAA7-4A7F-BA47-BF0EFCFE433D}</Data>
    <Data Name="param5">{B0316D0C-DA2F-40E0-9F91-F600CAF042DC}</Data>
    <Data Name="param6">LAPTOP</Data>
    <Data Name="param7">ABC</Data>
    <Data Name="param8">S-1-5-21-1169550721-3515471555-2295220807-1000</Data>
    <Data Name="param9">LocalHost (Using LRPC)</Data>
    <Data Name="param10">Unavailable</Data>
    <Data Name="param11">Unavailable</Data>

November 19th, 2012 8:58am


Try to grant the user permissions to start the COM component

Grant the user permissions to start the COM component. To do this, follow these steps:

1 Click Start, click Run, type regedit in the Open box, and then click OK.

2 Locate and then click the following registry subkey:


    Note In this subkey, "CLSID value" is a placeholder for the CLSID information that appears in the message.

3 In the right pane, double-click AppID.
   The Edit String dialog box appears. Leave this dialog box open and continue to the next step.

4 Click Start, click Run, type dcomcnfg in the Open box, and then click OK.
    If a Windows Security Alert message prompts you to keep blocking the Microsoft Management Console program, click to unblock the program.

5  In Component Services, double-click Component Services, double-click Computers, double-click My Computer, and then click DCOM Config.

6  In the details pane, locate the program by using the friendly name.
    If the AppGUID identifier is listed instead of the friendly name, locate the program by using this identifier.

7  Right-click the program, and then click Properties.

8  Click the Security tab.

9  In the Launch and Activation Permissions area, click Customize, and then click Edit.

10  Click Add, type the user's account name, and then click OK.

11  While the user is selected, click to select the Allow check boxes for the following items:

       Local Launch

       Remote Launch

       Local Activation

       Remote Activation

12  Click OK two times.

13  Quit Registry Editor.

Free Windows Admin Tool Kit Click here and download it now
November 20th, 2012 6:58am


like i said,  the check box unable to select, so i unable to change any setting.


November 20th, 2012 6:23pm


Open component services as an administrator.  The under computers -> my computer.  Right click on my computer and select properties. Then select the Com Security tab and there you have it.  Set Access and Activation permissions. 

You can also refer these links:



Hope that helps

Free Windows Admin Tool Kit Click here and download it now
November 21st, 2012 5:47am

Hello, I found the cause and solution for this problem.


Windows 8 + Asian input language + Firefox + Flash player protected mode =


EventID 10016

DCOM permission error for APPID {b0316d0c-da2f-40e0-9f91-f600caf042dc}


Add ProtectedMode=0 to mms.cfg (modify from notepad in 'run as administrator' mode)

x86 file location: C:\Windows\System32\Macromed\Flash

x64 file location: C:\Windows\SysWOW64\Macromed\Flash

I found this information on a Japanese forum : http://www.d-toybox.com/studio/weblog/show.php?mode=single;id=2012102201 (with screenshots of the steps)


February 9th, 2015 4:02pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics