Strict Standards: Non-static method Settings::setHostName() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 20

Strict Standards: Non-static method Settings::addHostAlias() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 22

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 28

Strict Standards: Non-static method Settings::setDsn() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 16

Strict Standards: Non-static method Settings::setTitle() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 19

Strict Standards: Non-static method Settings::setDescription() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 20

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 24

Strict Standards: Non-static method Settings::setShowDeleted() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 31

Strict Standards: Non-static method Settings::setRecentTopicsDuration() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 36

Strict Standards: Non-static method Settings::test() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 28

Strict Standards: Non-static method Skin::test() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 29

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 102

Strict Standards: Non-static method Settings::getSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 32

Strict Standards: Non-static method Settings::getDsn() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 35

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 39

Strict Standards: Non-static method Form::fieldExists() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\User.php on line 92

Strict Standards: Non-static method Form::fieldExists() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 15

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 17

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\Topic.php on line 138

Strict Standards: Non-static method Entity_Post::queryPosts() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 21

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Entity\Post.php on line 111

Strict Standards: Non-static method Skin::showHeader() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 23

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 46

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 91
Desperate! Tried Everything. Local Network Connection not binding to IP stack. Connects o.k. on Linux, not Win7 (Network Steve Forum)
Desperate! Tried Everything. Local Network Connection not binding to IP stack. Connects o.k. on Linux, not Win7
My machine is dual boot <acronym title="Windows">Win</acronym> 7 x32 and Linux. I'm using a wired Broadcom 400x integrated NIC with a Motorla cable modem. I've been using this setup of about 5 months with <acronym title="Windows 7">Win7</acronym>. There is only one computer connected and I have no wireless/router. In the middle of surfing on the <acronym title="Windows">Win</acronym> OS, my connection dropped and the computer froze up, forcing me to do a cold boot. When rebooting to windows, I got a red X in the sys tray. No Local area connection, no network connectivity. I booted again, into Linux this time, and it all works fine, leading me to believe this is a software issue for sure. I also downloaded and ran the broadcom diagnostic utility for my NIC and all the tests passed. The "Network and Sharing" screen shows no connection, (just diagram of computer<=>X<=>Globe) but the properties screen in the device manager shows it's connected with no problem, other than 0 packets transferred. It also reports no problem with the , but I re-installed it anyway, using the latest available. Most mysterious of all is that running ipconfig/all doesn't show the card at all. It's completely missing. (see below) The only thing it returns is the Teredo Tunneling Pseudo Interface and a 6to4 adapter. Both are reported "Media Disconnected" and neither has a DNS suffix, IP address or Default Gateway listed. Nor do either of these show up in the Device manager under network adapters. The property screen that comes up when you right-click the Local Area Connection on the "Network and Sharing" screen and double click the IPV4 line returns the message "Windows couldn't automatically bind the IP protocol stack to the network adapter". IPV4 and IPV6 show no connectivity. Looking through the event log at the time of the confirms the problem (see below). That's the best and only hint I've gotten so far as to what is going wrong, but I can't find a clue of how to correct it. The network troubleshooter acts like it is resolving the problem but is useless in the end and just reports that my network card is "experiencing problems"....Duh! This is what I've done so far, (not necessarily in this order): Ran Farbar (shows no connection to net, but localhost, Yahoo and Google accessible, see log below) Installed newest driver I could find. Power off/on the modem and rebooted (warm and cold) multiple times. Ran a sfc /scannow Did full virus and malware scans Reset winsock Reset IPV4 and IPV6 TCP/IP stacks to installation defaults Cleared and registered DNS cache Release and renew current IP address Checked Hosts file for any strange entries. Checked all services and process lists for any remnants of any possibly interfering process. Repeatedly boot into safe mode with network connectivity. Uninstalled network card in device manager and reboot, cold and warm. Unchecked IPV6 and both topographical protocols, one at a time, and rebooted after each change. Uninstalled AVG, Comodo Firewall, Open VPN and Wireshark, all of which were present for a week or more when everything was running just fine. Spit, cursed, rendered my clothes and tore at my hair. Spent 17 hours on google trying to figure this out. (Running Linux) PLEASE!!! If anyone has any idea what's going on here, please chime in. I have wore out my google finger and have not found anything like what I'm experiencing here. At least most people get something reported in their ipconfig window. I can't use a system restore because, evidently, the VSS shadow service has been turned off lately. In the event log, there are references to the "RootCauseGUID. I Found 3 instances of them under the same sub-key in the . PC-Tools reports them as having/being invalid D-Values of 2 bytes. The "RepairGUID"s don't exist at all in the registry. Is there any significance to this, or to the mention of "70 seconds Required"? If I didn't know better, I'd think this could be fixed in 70 seconds by editing these 2 invalid "RootCauseGUID"s. Anyway, here are the results of some of the logs, etc. that I have generated. I desperately need to get this fixed. I can't do a restore because my VSS was disabled. I can't even do a re-install because the Mickey Mouse outfit I bought this machine from never gave me a disc or any way to reinstall it. All I have is a 6 month old img. file if worse comes to worse. BTW, I had been running AVG AV and Comodo FW for a month before this happened. I uninstalled them and scoured the computer for any remaning remnants. I still suspect they may have changed something in the registry that "stuck" when it crashed. But that's 100% speculation. ********************************** Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved. C:\Users\User>ipconfig /all (Yeah, that's ALL!!) Windows IP Configuration Host Name . . . . . . . . . . . . : User-PC Primary Dns Suffix . . . . . . . : Node Type . . . . . . . . . . . . : Hybrid IP Routing Enabled. . . . . . . . : No WINS Proxy Enabled. . . . . . . . : No Tunnel adapter Teredo Tunneling Pseudo-Interface: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes Tunnel adapter 6TO4 Adapter: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Microsoft 6to4 Adapter Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes ******************************************************** Farbar Service Scanner Version: 01-03-2012 Ran by User (administrator) on 12-04-2012 at 10:03:37 Running from "C:\Users\User\Desktop" Microsoft Windows 7 Professional Service Pack 1 (X86) Boot Mode: Normal **************************************************************** Internet Services: ============ Connection Status: ============== Localhost is accessible. There is no connection to network. Google IP is accessible. Yahoo IP is accessible. Windows Update: ============ File Check: ======== C:\Windows\system32\nsisvc.dll => MD5 is legit C:\Windows\system32\Drivers\nsiproxy.sys => MD5 is legit C:\Windows\system32\dhcpcore.dll => MD5 is legit C:\Windows\system32\Drivers\afd.sys => MD5 is legit C:\Windows\system32\Drivers\tdx.sys => MD5 is legit C:\Windows\system32\Drivers\tcpip.sys => MD5 is legit C:\Windows\system32\dnsrslvr.dll => MD5 is legit C:\Windows\system32\wuaueng.dll => MD5 is legit C:\Windows\system32\qmgr.dll => MD5 is legit C:\Windows\system32\es.dll => MD5 is legit C:\Windows\system32\cryptsvc.dll => MD5 is legit C:\Windows\system32\svchost.exe => MD5 is legit C:\Windows\system32\rpcss.dll => MD5 is legit **** End of log **** =================================================== Last, but not least, the Event ID 4000 from the event viewer [ Name] Microsoft-Windows-Diagnostics-Networking [ Guid] {36C23E18-0E66-11D9-BBEB-505054503030} EventID 4000 Version 1 Level 4 Task 4 Opcode 0 Keywords 0x4000400000000001 - TimeCreated [ SystemTime] 2012-04-12T01:52:23.662353000Z EventRecordID 3923908 - Correlation [ ActivityID] {2FD171E5-DC3B-47BE-8465-CF94C0BE1DC9} - Execution [ ProcessID] 1692 [ ThreadID] 1716 Channel System Computer User-PC - Security [ UserID] S-1-5-19 - EventData RootCause There might be a problem with the driver for the Local Area Connection adapter Windows couldn't automatically bind the IP protocol stack to the network adapter. RootCauseGUID {46EC1E49-CA70-4561-9AB7-009F6B1B3709} RepairOption Set up the 'Local Area Connection' adapter Set up the network adapter to communicate with this network. This ensures that both Internet Protocol Version 4 (TCP/IPv4) and Internet Protocol Version 6 (TCP/IPv6) can be used on the network adapter. RepairGUID {4406F2CC-9CBD-4098-A03A-E5C9810E4895} SecondsRequired 70 SIDTypeRequired 37 HelperClassName NdisHC InterfaceDesc Local Area Connection InterfaceGUID {E87B74C6-1D82-41F3-A792-3CA9360CB0A6}
April 14th, 2012 10:15am

1. IMHO EventID 4000 is response to recovery attempt. Are there any other events? 2. How is the NIC "rendered" in Device Manager (healthy or not)? 3. It would be intersting to see the boot log (via F8). 4. Before full install I would do install -> upgrade (which takes IE9, but repair some components). 5. When nothing helps, the last option is vanilla plain install. That is the life. Regards Milos
Free Windows Admin Tool Kit Click here and download it now
April 14th, 2012 1:48pm

After you establish that the NIC card is detected by the system and the card is enabled you can try resetting tcp/ip stack http://www.geeksinphoenix.com/blog/post/2010/12/03/Resetting-your-network-adapter-in-Windows-7.aspx Resets TCP/IP and related components to a clean state. netsh int ip reset c:\resetlog.txt Resets IPv6 configuration state. netsh int ipv6 reset
April 14th, 2012 2:38pm

Reset(s) is(are) on the list. A lot of tests and configuration has been done. It is not easy to suggest something new in this troubleshooting case. Regards Milos
Free Windows Admin Tool Kit Click here and download it now
April 14th, 2012 3:24pm

1. I'm sure there are. There is a long list of events. I'm not sure how to look for the pertinent ones though. 2. According to the Device manager, the NIC is healthy, enabled and running. I ran a separate diagnostic test from the mfg. (Broadcom). It checked out o.k. as well. 3.. How do I generate a boot log? 4. Problem is that I don't have an installation disk. This machine was bought from a local shop and they never gave me a disk or proper backup files. I can't even do a complete install without buying an entirely new OS.
April 14th, 2012 10:31pm

This may not be relavent to your problem, but still worth checking out. http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/realtek-rtl8187-wireless-network-adapter-on-asus/e9d017f8-5a91-499c-a557-1a00e3948ad0 http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/windows-couldnt-automatically-bind-the-ip-protocol/a2f074cf-be62-435e-b951-42dfbb9351c2
Free Windows Admin Tool Kit Click here and download it now
April 16th, 2012 8:22am

Hi, Please upload the report of Windows Network and Network Adapter Troubleshooter to Skydrive and post a link here. Also, try to uninstall all the Network adapter drivers and Network filter drivers in Device Manager(Show hidden devices) , then reboot to let Windows install them automatically. If you have some security application installed, please uninstall them and uninstall the protocol driver in local connection properties. Juke Chou TechNet Community Support
April 17th, 2012 3:19am


Strict Standards: Non-static method Settings::getRecentTopicsLimit() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\Topic.php on line 120

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics

Strict Standards: Non-static method Skin::showFooter() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 119

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 56

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 91