Cannot print after update to 8.1 : Printers gone : Print spooler keeps stopping : Cannot add printers
Hello, Microsoft? Any updates or real answers to this issue. My spooler won't stay running, I can't add printers. Tell me something I haven't already tried! Tried right click the one printer that appears and click troubleshoot. It finds nothing. Tried printer diagnostics, it tells me the spooler isn't running (duh) and starts it and thinks that it has solved the problem, it didn't. Set spooler to restart on all failures, which it does but that doesn't help. With spooler running I get RPC Call failure message when I try to add a printer. With spooler not running/failed I get Endpoint Mapper error (duh).

I don't know about you but It's kind of important that I can print things.

Since we can't roll-back or do a restore (thanks a bunch) and I don't want to have to refresh and re-install the 142 Programs (not store apps) that I have, I need a resolution NOW!

Dell Latitude E6520 was running Win 7, did update to Win 8 last year, then 8.1 a few days ago.

On a Domain. Was working fine until update to 8.1. No errors while installing update.

"Mahesh Kumar A replied on October 24, 2013
Microsoft Support Engineer
Hi Charles,
This issue would be better suited in the TechNet community.
Please visit the link below and post the query for better assistance:


October 24th, 2013 4:58pm

I'm seeing the same issue with a customer of mine. They upgraded two Win8 boxes and both now find their print spooler service terminating unexpectedly.

Log Name:      System
Source:        Service Control Manager
Date:          10/24/2013 4:49:29 PM
Event ID:      7031
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      win81.domain.local
The Print Spooler service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 5000 milliseconds: Restart the service.


Also from the App log:

Log Name:      Application
Source:        Application Error
Date:          10/24/2013 4:53:19 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      win81.domain.local
Faulting application name: spoolsv.exe, version: 6.3.9600.16384, time stamp: 0x5215d570
Faulting module name: csintprt.dll, version: 2012.0.3.0, time stamp: 0x51c087d0
Exception code: 0xc0000005
Fault offset: 0x000000000000a93c
Faulting process id: 0xb24
Faulting application start time: 0x01ced1032bcac7ac
Faulting application path: C:\WINDOWS\System32\spoolsv.exe
Faulting module path: C:\WINDOWS\system32\spool\PRTPROCS\x64\csintprt.dll
Report Id: b10d15bc-3cf6-11e3-beab-90b11c9169b1
Faulting package full name: 
Faulting package-relative application ID: 


Update after more research:

Our issue seems to be related to Thomson Reuters Accounting software (Creative Solutions Professional) which runs several print services and which seem to have compatibility issues (perhaps) with the 8.1 upgrade. Just FYI in case it affects you.

  • Edited by Chris Gurley Thursday, October 24, 2013 10:21 PM
Free Windows Admin Tool Kit Click here and download it now
October 24th, 2013 9:58pm

Well, I'm not a computer genius, but I did find the Microsoft Compatibility pages. Guess what. Windows 8.1 is not completely compatible or is incompatible with most mid-priced jet all-in-one printers and many other printers by Microsoft's admission. Perhaps this has to do with 3D printing? Whatever the reason, this will send home PC users screaming to Apple in greater numbers. My advice to Microsoft: Patches Now!
November 2nd, 2013 3:29pm

Both my HP printers will not work now on the 8.1 update tried new drivers taken printers out put them back, still no print, both are wireless

this is message I get

This error can appear if a default printer has not been designated or if the
application is unable to locate an existing default printer. To correct this
problem, try one of the following in Microsoft Windows:

  • If a printer or printer settings is not available after you click the File tab, and then click Print, add a
  • If the application cannot find an existing printer that is already
    installed, set the printer as the default printer.
  • If a default printer is installed but the application is unable to use it,
    uninstall the printer driver, and then install the latest version of the printer
  • If the printer is on a print server, make sure the printer is available, the
    network is functioning, the server is not stalled, the printer is not out of
    paper, or the printer is not suspended by the administrator. Printing issues
    associated with a network printer are best handled by your local network

For more information about setting up and troubleshooting

  • Edited by lozs64 Saturday, November 02, 2013 4:55 PM
Free Windows Admin Tool Kit Click here and download it now
November 2nd, 2013 4:46pm

Here is what worked for me:

1. Open Regedit as Administrator 
2. Find the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\ key. 
3. If you are on a 64-Bit machine, browse to the "Windows x64" sub-key (else "Windows NT x86") 
4. Under the "Print Processors" sub-key DELETE ALL THE SUB-KEYS EXCEPT "winprint" key 
5. Start the Print Spooler service. 
6. Test to see if you can Add a printer. 

PLEASE NOTE: I just figured this out and haven't done much testing, so DO AT YOUR OWN RISK. 

I should also note that I experienced this on machines with the Thompson Reuters CS Print drivers installed. Uninstalling the CS drivers unfortunately did not resolve the issue, but I am guessing that they are the most likely culprit. Perhaps their uninstall utility does not delete the offending registry keys as I would have expected. 

We may be able to pear this down to deleting just the "Print processors" sub-keys that start with "cs" but I don't have any more machines to test this on, so someone else will need to test this and let us know how it goes. 

You will need to reinstall the CS print drivers after deleting these registry keys and repair Adobe as well (if you delete them all as originally suggested). It doesn't appear that reinstalling the Creative Suite print drivers brings the problem back but not enough testing has been done yet to be sure.


I ran into an issue reinstalling the CS print drivers on a subsequent PC. 

It appears the install/uninstaller does not actually remove the drivers during uninstall and this creates a problem when reinstalling. 

The easiest way to fix is to run the CS Print driver installer. At the end of the installation it will error out and tell you it could not remove the driver and give you the path. Just navigate to the path provided, delete any file starting with "cs" and once that is done, rerun the install and it should work. 

Please also note that all of the registry keys except winprt DO NOT need to be deleted. Only the "CS" registry keys need to be deleted.

  • Proposed as answer by JSB43211 Monday, November 18, 2013 10:12 PM
  • Edited by JSB43211 Tuesday, January 28, 2014 2:15 PM
November 18th, 2013 7:47pm


I solve that problem this way.

First i create bat file looks like;


echo "Islemler yapiliyor. Bekleyin..."

Its work successful manually.

f I start on windows start up as a service its become a perfect solution :))

simple but it's worked ;)

  • Edited by 5734L7H Friday, November 29, 2013 2:21 PM
Free Windows Admin Tool Kit Click here and download it now
November 29th, 2013 2:16pm

thank you very much. I was about to downgrade to windows 7 from windows 8.1. Your post helped me fix my samsung laser printing issue, i guess this could solve all other printing problems as well(faced in windows 8.1). Best.
December 17th, 2013 2:06am

Hi had a major panic in experiencing same issue with printer canon 4500 and was ready to uninstall kaspersky but decided might be worth trying the standard troubleshooter and it worked!!!! Went to settings-control panel- printer troubleshoot and spool all sorted. Hope this helps, rare occasion troubleshoot worked but maybe windows have added a patch to sort since original issues? 
Free Windows Admin Tool Kit Click here and download it now
April 18th, 2014 10:04am

>JSB43211 said: Under the "Print Processors" sub-key DELETE ALL THE SUB-KEYS EXCEPT "winprint" key<

You nailed it!  Thanks TONS!!!
  • Edited by IT Architect Tuesday, December 30, 2014 10:11 PM
December 30th, 2014 10:06pm


I have the same problem and cant find any fix.

I don't even have the environments folder. What does that means?




  • Edited by Bodo Wiegand Wednesday, January 07, 2015 6:22 PM
Free Windows Admin Tool Kit Click here and download it now
January 7th, 2015 6:19pm

Found in windows 8.1:  Control panel \ All Control Panel Items \ Devices and Printers

Right clicked on Epson printer. 

Clicked trouble shoot and follow prompts until finished.

Open printing software like.."Word"  

Open printer dialogue box and see list of printers.

select your printer and then print.


I have found that most printer problems start with the windows interface.  If a printer is not recognized by windows then programs like paint and word can't access the printer. This works with networked and non-networked printers.  So first enable the printer in windows and then in the program you are trying to print from.

Thank you,


March 29th, 2015 8:05pm

That worked and it was relatively easy!
Free Windows Admin Tool Kit Click here and download it now
April 26th, 2015 9:55pm

If right-clicking the printer and using the troubleshooter worked, then you weren't having the same issue we've been discussing.  I've been working on this for days after setting up a new router and previously spent several days working on it after my network crashed and had to be re-set.  The only thing that worked for me was going through the registry and deleting references to all the printers from the environment and ...CurrentControlSet/Print folders.  This is way too dangerous for me to be comfortable doing - but I got desperate when the tech guys' "guaranteed solution"s didn't work.

Symptoms of the problem in this thread include a response from printing software (like "Word") stating that there are "no printers installed", even though the devices and printers folder shows printers there and available.

So - thank you jsb43211 - 

May 2nd, 2015 5:09pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics