Strict Standards: Non-static method Settings::setHostName() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 20

Strict Standards: Non-static method Settings::addHostAlias() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 22

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_lib\AutoConfig.php on line 28

Strict Standards: Non-static method Settings::setDsn() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 16

Strict Standards: Non-static method Settings::setTitle() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 19

Strict Standards: Non-static method Settings::setDescription() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 20

Strict Standards: Non-static method Settings::setSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 24

Strict Standards: Non-static method Settings::setShowDeleted() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 31

Strict Standards: Non-static method Settings::setRecentTopicsDuration() should not be called statically in C:\website\www.networksteve.com\windows\_site\Config.php on line 36

Strict Standards: Non-static method Settings::test() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 28

Strict Standards: Non-static method Skin::test() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 29

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 102

Strict Standards: Non-static method Settings::getSiteRoot() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 32

Strict Standards: Non-static method Settings::getDsn() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 35

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Init.php on line 39

Strict Standards: Non-static method Form::fieldExists() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\User.php on line 92

Strict Standards: Non-static method Form::fieldExists() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 15

Strict Standards: Non-static method Form::field() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 17

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\Topic.php on line 138

Strict Standards: Non-static method Entity_Post::queryPosts() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 21

Strict Standards: Non-static method Settings::getShowDeleted() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Entity\Post.php on line 111

Strict Standards: Non-static method Skin::showHeader() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 23

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 46

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 91
Cannot create new folder in Windows 7 (Network Steve Forum)
Cannot create new folder in Windows 7
I am unable to create a new folder by any means in Windows 7. From within Windows Explorer if I select the "New Folder" option, nothing happens. Also, from the Desktop, the "Folder" option does not show when right-clicking and selecting "New". I have done a system restore back beyond where I knew it was working and am still not able to create a new folder. Any guidance would be greatly appreciated. Thank you, Mike
May 23rd, 2010 5:53pm

Hi Mike, First, please use System File Checker tool to troubleshoot this issue. If the issue persists, import the following registry key and see if the issue can be resolved. First, please refer to this knowledge base (KB) article to back up the registry key. After backing up the registry, please follow the steps below to import the registry: 1. Click Start, type Notepad in the Search bar and pres ENTER. 2. Copy the following commands and then paste them into the open Notepad window. Windows Registry Editor Version 5.00 [HKEY_CLASSES_ROOT\CLSID\{11dbb47c-a525-400b-9e80-a54615a090c0}] @="CLSID_ExecuteFolder" [HKEY_CLASSES_ROOT\CLSID\{11dbb47c-a525-400b-9e80-a54615a090c0}\InProcServer32] @="ExplorerFrame.dll" "ThreadingModel"="Apartment" [HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New] @="{D969A300-E7FF-11d0-A93B-00A0C90F2719}" [HKEY_CLASSES_ROOT\Folder] @="Folder" "EditFlags"=hex:d2,03,00,00 "FullDetails"="prop:System.PropGroup.Description;System.ItemNameDisplay;System.ItemType;System.Size" "ThumbnailCutoff"=dword:00000000 "TileInfo"="prop:System.Title;System.PropGroup.Description;System.ItemType" [HKEY_CLASSES_ROOT\Folder\DefaultIcon] @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\ 00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,00,68,00,\ 65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,33,00,00,00 [HKEY_CLASSES_ROOT\Folder\shell] [HKEY_CLASSES_ROOT\Folder\shell\explore] "MultiSelectModel"="Document" "BrowserFlags"=dword:00000022 "ExplorerFlags"=dword:00000021 [HKEY_CLASSES_ROOT\Folder\shell\explore\command] @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\ 00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\ 65,00,20,00,2f,00,73,00,65,00,70,00,61,00,72,00,61,00,74,00,65,00,2c,00,2f,\ 00,65,00,2c,00,2f,00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,00,25,00,49,00,\ 2c,00,25,00,4c,00,00,00 "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}" [HKEY_CLASSES_ROOT\Folder\shell\open] "MultiSelectModel"="Document" "BrowserFlags"=dword:00000010 "ExplorerFlags"=dword:00000012 [HKEY_CLASSES_ROOT\Folder\shell\open\command] @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\ 00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\ 65,00,20,00,2f,00,73,00,65,00,70,00,61,00,72,00,61,00,74,00,65,00,2c,00,2f,\ 00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,00,25,00,49,00,2c,00,25,00,4c,00,\ 00,00 "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}" [HKEY_CLASSES_ROOT\Folder\shellex] [HKEY_CLASSES_ROOT\Folder\shellex\ColumnHandlers] [HKEY_CLASSES_ROOT\Folder\shellex\ColumnHandlers\{F9DB5320-233E-11D1-9F84-707F02C10627}] @="PDF Column Info" [HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers] [HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\BriefcaseMenu] @="{85BBD920-42A0-1069-A2E4-08002B30309D}" [HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\Offline Files] @="{474C98EE-CF3D-41f5-80E3-4AAB0AB04301}" [HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\{a2a9545d-a0c2-42b4-9708-a0b2badd77c8}] [HKEY_CLASSES_ROOT\Folder\shellex\DragDropHandlers] [HKEY_CLASSES_ROOT\Folder\shellex\DragDropHandlers\{BD472F60-27FA-11cf-B8B4-444553540000}] @="" [HKEY_CLASSES_ROOT\Folder\shellex\PropertySheetHandlers] [HKEY_CLASSES_ROOT\Folder\shellex\PropertySheetHandlers\BriefcasePage] @="{85BBD920-42A0-1069-A2E4-08002B30309D}" [HKEY_CLASSES_ROOT\Folder\shellex\PropertySheetHandlers\Offline Files] @="{7EFA68C6-086B-43e1-A2D2-55A113531240}" [HKEY_CLASSES_ROOT\Folder\ShellNew] "Directory"="" "IconPath"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\ 74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,73,\ 00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,33,00,\ 00,00 "ItemName"="@shell32.dll,-30396" "MenuText"="@shell32.dll,-30317" "NonLFNFileSpec"="@shell32.dll,-30319" [HKEY_CLASSES_ROOT\Folder\ShellNew\Config] "AllDrives"="" "IsFolder"="" "NoExtension"="" 3. After pasting the above commands, please click File on the menu and click Save. 4. Type in NewFolder.reg as the file name, select to save the file on the Desktop. Click Save. 5. Go to the Desktop, and double click NewFolder.reg. A dialog box will pop-up saying "Are you sure you want to add the information in fix.reg to the registry?". Click Yes to confirm. Note: Administrative privileges are required to perform the above steps. Please click "Continue" when the User Account Control dialog-box appears. Hope this helps. Regards, Linda
Free Windows Admin Tool Kit Click here and download it now
May 24th, 2010 8:38am

Thank you Technocrate and Linda, your rapid and detailed responses helped tremendously. Mike
June 1st, 2010 3:00pm

Glad to hear it helped. :-)
Free Windows Admin Tool Kit Click here and download it now
June 3rd, 2010 8:40am

When trying to import the registry key, I get an error saying that the key cannot be written because affected processes are being used. Anyway around this? Tried killing explorer.exe and then import and that didn't help.
July 20th, 2010 6:58pm

linda, I'm having the same issue as mike, but when i go to follow your steps i can't save to the file to desktop to open it, I just installed windows 7 onto my computer and i didn't set up an administrator when i installed it, i'm the only user on the computer what should i do? i can't over ride this administrator stuff... to fix the problem
Free Windows Admin Tool Kit Click here and download it now
August 29th, 2011 12:08am

Having same problem. Ran the file checker. No problems reported. Copied the registry commands you listed to NewFolder.reg and double-clicked. After answering yes to the dialog box I also got the "key cannot be written because affected processes are being used" message. Since it has been over a year since a moderator has responded here to the many similar reports I guess it's just a stab in the dark posting this. Perhaps someone else who has found a solution will reply.
September 16th, 2011 7:17am

Well, now I'm embarrassed. After my last post I tried again to create a New Folder and then check the logs when I noticed it actually did create a folder. So Linda Yan's fix works...... just ignore the "key cannot be written" error when running the NewFolder.reg file.
Free Windows Admin Tool Kit Click here and download it now
September 16th, 2011 7:34am

Hi, sorry this is like a year later but i really need ur help... i have the same problem but when i double click on my saved file on the desktop and then it asks if u wanna add this to regedit i click yes then it says error : cannot import , u can only import binarry things.... i also have been looking for a soloution to fix my taskbar and startmenu issue i cant pin anything onto their as well i have windows 7 and on the first day i got the laptop nothing was working when i tryed to pin/ drag to task bar and start menu... plz help ive been trying to find a soloution for 5 months!
September 23rd, 2011 7:54am

Hi Thanks for this, it helped me. Any idea what could cause this? EyeOfThePirate: When you create the .reg file you must include also include the header "Windows Registry Editor Version 5.00" Also, when you save your file make sure you select "All file types" and not "Text files". Hope you succeed.
Free Windows Admin Tool Kit Click here and download it now
September 23rd, 2011 9:35pm

This was great. worked for me. Thanks. I knew it was a registry key, but no clue as to how to fix. Windows 7 Home Premium 64-bit, w/Svc pck 1
October 16th, 2011 2:24pm

Many thanks - this fixed the problem!
Free Windows Admin Tool Kit Click here and download it now
May 8th, 2012 2:08am


Strict Standards: Non-static method Settings::getRecentTopicsLimit() should not be called statically, assuming $this from incompatible context in C:\website\www.networksteve.com\windows\_lib\Entity\Topic.php on line 120

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics

Strict Standards: Non-static method Skin::showFooter() should not be called statically in C:\website\www.networksteve.com\windows\topic.php on line 119

Strict Standards: Non-static method Skin::includeFile() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 56

Strict Standards: Non-static method Settings::getSkin() should not be called statically in C:\website\www.networksteve.com\windows\_lib\Skin.php on line 91