Can't connect machine to domain
I can't get my machine to connect to the domain. I've tried flushing the dns and turning off my firewalls, all to no avail. I have set my dns to the Domain Controllers ip address. When I attempt to connect my machine, I get the following error: The following error occurred when DNS was queried for the service location (SRV) resource record used to locate an Active Directory Domain Controller (AD DC) for domain "mydomain": The error was: "DNS name does not exist." (error code 0x0000232B RCODE_NAME_ERROR) The query was for the SRV record for _ldap._tcp.dc._msdcs.mydomain Common causes of this error include the following: - The DNS SRV records required to locate a AD DC for the domain are not registered in DNS. These records are registered with a DNS server automatically when a AD DC is added to a domain. They are updated by the AD DC at set intervals. This computer is configured to use DNS servers with the following IP addresses: - One or more of the following zones do not include delegation to its child zone: mydomain com The netlogon service is not running on the client machine, which may be a problem. Whenever I try to start it, it says it started and then stopped. It won't stay started. Thanks in advance!
August 4th, 2011 11:23am

The strange part is that while my physical machine cannot ping the dc (says it can't find the host. Works when IP is used), a VM running on the same machine can.
Free Windows Admin Tool Kit Click here and download it now
August 4th, 2011 12:51pm

Hi, According to your description, the issue should related with your DNS server. Please run ipconfig /registerdns on all DNS servers to see the result. Also you can run the same command on Windows 7. If the issue persists, I suggest to contact Windows Server Forum for further help: The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding. Regards, Leo HuangPlease remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
August 8th, 2011 1:48am

I had the same problem and I had to change my DNS to be the local DNS server FIRST and then the other DNS records, so after that, it worked. The Breakdown! Go to Control Panel\Network Connections Go to your NIC (Network Interface Card) or your "Local Area Connection" whatever it is called. Right click and go to Properties. Click on Internet Protocol Version 4 (TCP/IPv4) and click Properties. In the "bottom" you may have obtain DNS Server address automatically, which if you do, you want to manually set it to point to your domain controller or the DNS server, (Domain Naming Service) for the device going to give you your "name" and then you can "talk!" But if you have "Use the following DNS server addresses:" click on the bottom right Advanced... button. Click on the DNS tab. Click on the Add... button if you do NOT have your DNS address in there already. I had to add mine. I tried it again and it did NOT work. I had to "Push" it to the top, by clicking it and clicking on the UP arrow to the right. I Put it FIRST. I have 2 of my other DNS addresses given to me by my ISP (Internet Service Providers). "THEY" were "seeing" my information and probably QUICKLY saying "oh no, we don't want to be a party to your activities!" Once I changed and put MY DNS location "192.168.1.x" (x is a variable, you will have a # here). and then I hit OK and it was "good!" I was then able to get my other server added to the domain! Click OK and Apply to everything to get back to the main screen and then go to Control Panel / System and then Change Settings for Computer name, domain, and workgroup settings and add yourself to your NEW domain, it SHOULD work! You will have to restart your server though to be fully added.
Free Windows Admin Tool Kit Click here and download it now
November 2nd, 2012 7:27am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics