Can't change my desktop (Windows 8)
Just upgraded from Windows 7 to Windows 8. I right click on my desktop and click personalize. Everything appears like Windows 7 did, including my themes. But every time I switch themes, everything but the default background changes. I've tried clicking "Desktop Background" and changing it from there, but nothing works. Anyone else having this problem, or hopefully a fix?
October 29th, 2012 6:51am

Hi Leo,

My Windows 8 is already activated with a key... I can change colors and backgrounds on the Start screen, also the lock screen, but I cannot select an specific theme for my desktop yet. I can see that some change happens, because the window bars change colors, but the background doesn't. I do even hear an alert sound whenever I click on a theme, like it happened in Windows 7, but the background remains the same.



  • Edited by MauAntunez Wednesday, October 31, 2012 2:28 PM
Free Windows Admin Tool Kit Click here and download it now
October 31st, 2012 2:28pm

Try going to C:\Users\YOUR USERNAME HERE\AppData\Roaming\Microsoft\Windows\Themes\CachedFiles and copy the name of that pic. Then save the pic you want to your computer and rename it to the Catched image file. Then drag and drop your picture into CachedFiles. Press replace file when it asks. Finally it wont immediately change by itself, but if you hold down right click on the desktop and drag a box around the new pic will update. Yeah, it's weird... but works!
December 6th, 2012 11:54pm


I am not sure if this will help, but it solved the problem that I had, which I think it was similar to yours.

Go to Start screen and type "Ease of Access Center". Then (from the three sections that appear below the search box that you've just filled) choose settings. On your left you will then have the "Ease of Access Center" "shortcut". Choose it.

Then, at that window choose the link "Make the computer easier to use".

Then uncheck the "Remove background images (where available)" (if it is checked, of course!) and scroll to the bottom of the page, hit the "Apply" button and finally, the "Ok" button.

Check if that solved the problem.

If the "Remove background images (where available)" setting wasn't checked in the first place, then my problem was different from yours and I apologise for giving inaccurate info..

Best regards

  • Proposed as answer by wmriester Tuesday, April 30, 2013 11:35 PM
Free Windows Admin Tool Kit Click here and download it now
January 20th, 2013 11:28pm

OK I have had this problem and did what is sensible and contacted Microsoft by phone directly and got great support and the problem was solved for me.


go to settings and  touch or click 'search'

now touch or click 'settings'

then in the input box

type 'ease' without the quotes

this will bring up search options for you.

from the list select EASE OF ACCESS CENTER

this will open a dialogue on the desktop

in this dialogue select MAKE THE COMPUTER EASIER TO SEE


then click or touch OK.

This should fix the problem.

The fix was supplied to me by Microsoft who are ready to help

my advice after having this problem for a few weeks and trying to get a solution here,  is.....

Call Microsoft first.

by the way... I am a Mac user so have no axe to grind here just trying to help others with a problem.

  • Proposed as answer by skypilot1947 Tuesday, December 30, 2014 2:33 PM
September 18th, 2013 7:52am

Tried using the "Ease of Access Center"-trick and my %appdata%\Microsoft\Windows\Themes doesn't have a cachedfiles folder. I still can't set my desktop background :-/

I've tried switching to two other accounts - a different domain account (yes, my machine is domain joined, but desktop background is not set through GPO), and another microsoft-account. Neither works.

Also tried using a synced theme, hoping that setting the desktop background on a different win8.1 machine would trigger the background when syncing, but no such luck.

Any ideas?
Free Windows Admin Tool Kit Click here and download it now
November 8th, 2013 7:53am

It worked on Win 8.1


November 18th, 2013 11:46pm

Thank god for this guy! lol I've been searching the web for hours trying to figure out why my Desktop background WOULDN'T change! -_-
Then finally i saw this...and read it...and WHATYA KNOW! It works now :)

Thank you soooooo much i though i had a virus or something and it was pissin me off lol
Do what this guy says ^ (if you have windows 8) and you'll be able to have a new background hahaha

I cant get over how stupid that was.... i didn't even know there was a check-mark that was for disabling the background...idk why i checked it in the first place and idk why they'd even have that ok done ranting ty.

Free Windows Admin Tool Kit Click here and download it now
December 31st, 2013 6:45pm

ya it works but when i restart my computer it automatically changes to its default image. 
January 5th, 2014 1:21pm

worked well. It deleted the existing images in the cached files except for the one I highlighted. Odd way of doing it really.
Free Windows Admin Tool Kit Click here and download it now
January 19th, 2014 12:58am

 hey i faced the same problem but i resolved the problem with the help of this link

April 16th, 2014 10:07pm

This works!!!!  Hard to believe and how the settings got the way did is beyond me, but this worked for me.... solution by gpjma

Free Windows Admin Tool Kit Click here and download it now
December 30th, 2014 2:33pm

I fixed mine! Try going to - Ease of Access Center - Make the Computer Easier to See - uncheck the box that says Remove Background Images (where available)... hope that should work! I had restored my computer to fix the bugs and all the sudden I couldn't get the slideshow to play from Personalization-Desktop Background, it just showed a black desktop!
June 19th, 2015 7:12pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics