Atbroker.exe "application failed to initialize properly" on remote desktop to vista?
I get this error message when trying to connect to my remote vista x64 RTM (Ultimate) machine.. It happens at random.. the only fix is to remotely reboot the machine via a "shutdown" command.It says to click ok to terminate the application, that only results in a blank screen.Anyone found a solution as of yet?
February 5th, 2007 11:20pm

What gives?? Same error. Differences... XPMCE trying toRDP to Vista Ultimate x86 up to date with latest patches. Atbroker.exe crashes and you can click ok sometimes. But everytime the black screen of death is present. No fixes Microsoft?? Vista has been very mature until this. ########### BSOD LIVES!! Stay tuned for White too!
Free Windows Admin Tool Kit Click here and download it now
February 10th, 2007 11:59am

Just ran into this myself... vpn'd to the office and wanted to connect to my Vista Ultimate machine to check on a few FTP uploads that were running on the desktop... (using smartftp) weird stuff.. hopefully there is a fix.. first real 'problem' that i have experienced...
February 17th, 2007 8:02am

I get this aswell. Even when i press ctrl + Alt + end and press task manager "Taskmgr fails to inititialize properly" error appears. Getting to be a pain.
Free Windows Admin Tool Kit Click here and download it now
February 26th, 2007 11:47pm

I do not beleive we will see a fix soon from Microsoft Vista dev team. I beleive this is because even though I have only 2 or 3 bugs, there are probably many people who have many more complaints. I think Bill said some 5 million people downloaded the software. Depending on the build, this bug was found in build 6000 Vista Ultimate. Vista Service Pack 1 will be much appreciated anyway when its released. I only got this error once. Though I try not to remote into that machine much because its my work-station. That means I should be doing work while logging into it.
February 27th, 2007 9:16am

Hello,I got the same bug on my computer running Vista Business Edition.Only black screen, after reconnection I'm able to type my password but then the same error message again.
Free Windows Admin Tool Kit Click here and download it now
February 28th, 2007 4:36pm

I don't mind waiting for a fix but it would be lovely if Microsoft could at least confirm the problem and give us some sort of headsup. I find it a little rediculous that a search for AtBroker on Microsoft's supportsite turns up nothing. If anyone can shed some light, please do.In themeantime I guess this XPS M1210 will make a nice paper wieght.
March 25th, 2007 6:49am

There is a workaround on Spat's Weblog: To resume it: CTRL-ALT-END and choose Logoff It worked for me... hope it will work for you also. Cheers
Free Windows Admin Tool Kit Click here and download it now
April 24th, 2007 11:08am

CTRL-ALT-END doesn't always work for me. I am connected into 10+ servers at once and sometimes I connect into multiple machines and then into multiple more machines from those I'm already on. It's not confusing, it's massivemultitasking. But I don't know if RDP is completely functional at that level. Some features do seem to dissapear. And the way you interact with multiple server windows which you are connected to is rediculous. I think I have mastered the thumbtac though. I haven't seen this atbroker.exe problem in a long time. I hope to not jinx myself, but perhaps they fixed the problem without saying anything. I do that sometimes because it doesn't affect enough people in a large enough way to draw a lot of attention. We notice they don't mention it on their site. We are not the same person but I don't hear of many others having the same issue with atbroker. Personally after Halo 2 drops I'm going to try that and then uninstall Vista. The kernel is pretty solid. The GUI is my favorite.I got 4GB of PC3200 DDR with an Intel P4 HT 3.0GHz. It runs as quick as XP does for most multitasking, but the networking is faster than XP. OpenGl support is terrible on my 9800 Pro ATI GPU with 7.3 CCC. Since Vista Ultimate was supposed to be the Ultimate gaming OS I will come back later when its had time to fill those shoes. But right now XP MCE will stay my game machine.
May 9th, 2007 9:09am

How do you do to remotely shutdown the computer when you cannot access it through RDP?
Free Windows Admin Tool Kit Click here and download it now
May 10th, 2007 7:02am

Hi All, My Vista Ultimate machine developed the same issue recently. The Ctrl-Alt-End workaround was no help i my case I'm afraid. However, as the issue has only started happening in the last 7-10 days I decided to uninstall all updates recently installed... Presto, problem solved !!! The updates in question are KB933566, KB929123, KB931213, KB905866, KB929762 & KB936825. Hope this helps.
June 25th, 2007 1:07am

this still looks to be going on.. (Vista SP1 Business x64) I attempted to RDP from a WinXPSP2client and got the 'black screen' locally. Fixed it by connecting from another WinXP(this one SP3) client and was able to bring back the locked screen locally and also see the screen over RDP.
Free Windows Admin Tool Kit Click here and download it now
June 21st, 2008 7:56am

Yep, just happened to me for the first time. The workaround worked. Ctrl - Alt - End.
September 16th, 2008 8:57pm

If you don't want to log out, ctrl+alt+end and then press Task Manager instead of Log Out
Free Windows Admin Tool Kit Click here and download it now
September 30th, 2008 8:08pm

It's got to be related to the Desktop Window Manager or something to do with the composition through RDP. If you try to connect using RDP with full features turned on you are likely to eventually see the error. However if you turn down the DWM options and turn off desktop compositions and basically make your desktop look like windows 98, you will not see the error. There is no fix as MS does not want to admit a problem YET. It's also hit and miss on when the error comes up so it's harder to troubleshoot and fix.
October 20th, 2008 7:30pm

You pick up the phone and dial the phone number to where your machine is at and you have someone physically turn it off and back on. That is why people still get paid to work in a datacenter/NOC. If your machine is at home and nobody is there but your cat/dog, train them to do this. Monkies can do it. I've seen "techs" with the same IQ and attention span as a cat perform reboots. It's not that hard.
Free Windows Admin Tool Kit Click here and download it now
October 20th, 2008 7:32pm

Okay, I had this again and I found a workaround. Since I was connecting through one RDP (2003 Server) to another (Vista x64), where I had this error with Vista -- I rebooted the 2003 for the updates. After that, I was able to reconnect via RDP to the 2003 server and then RDP to the Vista x64! I had an interesting error (WER) on the x64, stating 'Transitions Accessible technologies between desktops has stopped working'.
November 13th, 2008 6:09am

In my case I was RDP'ing from Windows XP to Windows Vista machine. CTRL+ALT+END, then select "TASK MANAGER" works greatly for me. You don't need to logoff. When I do that I do see 'Transitions Accessible technologies between desktops has stopped working' error like 10 times. After that I don't see that error. Once I do this, and I close the RDP and reconnect,I don't see the AtBroker.exe error again. This might be a timing issue in Vista. It doesn't seem to have a solution at the moment. See this article:
Free Windows Admin Tool Kit Click here and download it now
November 26th, 2008 2:28am

How do u unisntall the updates?
January 2nd, 2009 8:52pm

Vista Enterprise SP1 to Vista Enterprise SP1 all updates applied.This happens to me 99% of the time when I do a remote desktop over a VPNconnection.The key combination reported above of : <CTRL><ALT><END> seemed to work just fine. However,I just select<CANCEL> and the desktop returns to normal!
Free Windows Admin Tool Kit Click here and download it now
March 6th, 2009 8:53am

I'm having this issue with XP to Win7. Nothing listed above seems to work. I was able to connect from the network, but not from home, VPNed in.
December 30th, 2009 5:44am

I am getting the same error when connecting to a Windows 7 Pro x64 system from a Win 7 ultimate x64 system via Remote Web Workplace in SBS2003. This is the first time it happened though, it's worked fine in the past.
Free Windows Admin Tool Kit Click here and download it now
January 12th, 2010 5:39pm

I'm having the same issue with Win7 on a new stand alone computer 6 weeks old. Now I can't use the computer at all. I notice some of the users (above) had issues with 'remote access'. Don't even use this! Any advice on how I can fix the "AtBroker" problem would be greatly appreciated
January 31st, 2010 3:06am

I just had this same problem over the weekend. It was caused by the CA Antivirus quarantining the windows system shell 32.dll. You have to go into CA and click the modify area and exclude C:\windows\system\shell32.dll (check if I did the last part correctly). You can do this if you boot in the safe mode. restart the computer and the problem is resolved.
Free Windows Admin Tool Kit Click here and download it now
February 2nd, 2010 3:21am

I tried to connect from an XP Pro 32-bit workstation to my home computer running Win7 Ultimate x64. The Media Center interface was open on full-screen, which normally isn't a problem. I would normally get a message that Media Center was closed because it was using a mode (GPU rendered interface) that was not supported by remote desktop...which is expected. This time, I got the AtBroker.exe error + black screen error. I tried Ctrl+Shift+Esc and an error dialog would appear on the black screen, saying that task manager couldn't execute. Google led me here. For me, the Ctrl+Alt+Shift > Task Manager trick worked beautifully. Thanks!
March 15th, 2010 5:08pm

My solution is Ctrl+Alt+End - it makes Ctrl+Alt+Del on RDP So I clicked OK, then pressed ctrl alt end and runed Task Manager and win logged me in :) I have Win 7 pro x64 on both machines, hope it would help U :)
Free Windows Admin Tool Kit Click here and download it now
April 21st, 2010 12:14pm

CTRL-ALT-END works for me. Also I choose Task Manager instread of Logoff. Thank You.
April 30th, 2010 7:19pm

CTRL-ALT-END worked for me too. I accidentally clicked lock, so I had to log back in and I was able to get past the error message and get to my desktop, I then clicked ok on the error message.Regards, Mike DePouw
Free Windows Admin Tool Kit Click here and download it now
October 14th, 2010 3:50am

Can't believe this bug is still around over 3 years! I got this on my Windows 7 Pro 64bit (is it more likely on 64bit?) and ctrl-alt-end also worked for me. I don't have CA so I don't believe it is related to quarantining system files.
October 20th, 2010 10:14am

Thanks it is working for me .
Free Windows Admin Tool Kit Click here and download it now
October 28th, 2010 12:56am

It worked for me too, Thanks.
January 25th, 2011 8:00pm

happens on a Win 2008 server as well thx for the solution...two thumbs up
Free Windows Admin Tool Kit Click here and download it now
January 27th, 2011 3:48am

Thx ...problem solved
March 7th, 2011 4:40am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics