Acces denied when trying to read/copy a specific file
I just reinstalled my system to Win7x64. Now I have a file that I cannot read whatsoever. I am trying to move all files to a new harddrive. I've tried everything. The permissions are now correct. E.g. I've followed the instructions from this thread. But with no success. The file is not open by any process, I've searched using process explorer. I've tried both CMD.EXE Run as admin and normal operations in explorer. The Advanced > Effective Permissions shows that my user has full control (inherited from parent). I've tried re-propagate permissions but to no success. Access denied access denied... Strangely enought, I am able to rename the file. Ive read http://support.microsoft.com/kb/320081 with great interest, but the subinacl /onlyfile "\\?\D:\path_to_file" /setowner=hal07 /grant=hal07=F does not help. There are no errors on my hard drives in event logs. I'm running chkdsk /R/F now on this volume and hope this might reveal something but I fear it's impossible to retrieve the old file.
April 27th, 2011 1:14pm

Hi, Which files do you want to read? According to your description, this should be related to the specific file, please capture a screenshot for further analyzing: How to capture a screenshot ========================= 1) Press the Print Screen key (PrtScn) on your keyboard. 2) Click the "Start" menu, type "mspaint" in the Search Bar and Press Enter. 3) In the Paint program, click the "Edit" menu, click "Paste", click the "File" menu, and click "Save". 4) The "Save As" dialogue box will appear. Type a file name in the "File name:" box, for example: "screenshot". 5) Make sure "JPEG (*.JPG;*.JPEG;*.JPE;*.JFIF)" is selected in the "Save as type" box, click “Desktop” on the left pane and then click "Save". 6) Then Upload to SkyDrive. Hope it helps. Alex ZhaoPlease remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
Free Windows Admin Tool Kit Click here and download it now
April 29th, 2011 2:38am

what? you want a screenshot of a file? why?
April 29th, 2011 5:03am

Try this, right click the file/folder and select "take ownership" I had to do that after a reinstall of win7 to manage some files even though I'm the administrator and owner of the system and the files.
Free Windows Admin Tool Kit Click here and download it now
April 29th, 2011 6:37am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics