Windows 2012 R2 printers showing twice (and unable to set default printer)
Hello,

I have a problem that will not just go away. I have two Windows 2012 R2 servers: one with RDS installed for 30 users with an appointment application and one "back-end" server were print queues and database are running.

So basically, users can connect to network printers by clicking on a link that points to the "back-end" server. In Windows 2008 R2, this is so simple but in Windows 2012 R2, I am experiencing tons of issues (with both V3 and V4 drivers). By the way, printer redirection in RDS (remote desktop) is disabled and forbidden by GPOs. I am listing the issues here to see if someone experienced them before:

1. After a disconnection between the printer and the RDP session (the servers are in a remote site as the printers are local and printing through a site-to-site VPN tunnel as they are all IP printers). Example: a power failure will set a particular printer at "offline", which is normal and eventually, it comes back online. But then, the problem starts: the printer "loses" it "default printer" status and none of the printers for a specific user are showing as default printer in his printer list. If I try to set again the desired printer to default, it is already "set as default" but the green "tick" is not showing on the printer icon and printing fails.

2.  When the above happens, I usually try to delete the printer from the user session and reconnect to it. But then, it is even worse: the specified printer is now showing "twice" in the list of "device and printers" for a specific user while working OK for another (when you right click the printer, you see two instances of it). This is interfering with our main application and a specific user session is non functional. A printer will also show in the "unspecified section"

3. Even a bigger problem: if I delete a particular printer from a specific RDS user session, the same printer disappears for all other users using that printer. So each time I try to fix a printer in one user session, I can expect a myriad of issues with the other users.

4. The only way I found to fix this issue (so far) is by rebooting both servers at the end of the day and after power recycling the printer exhibiting the issue. The only other thing I could try (never tried it yet) would be to delete the affected user profile and recreate it on the RDS server. But I do not know yet the consequences of that action (will everyone else lose the defective printer mapping as well???).

5. This issue doesn't seem to be driver or brand related as I had the issue with many printers of different brand. Both servers are virtual under Hyper-v (physical hosts are also Windows 2012 R2) and are running the latest integration version.

If anyone has experienced this issue, please let me know what you have to have done to resolve it. My next step is escalating this to Microsoft.

Thanks.
July 24th, 2014 6:53pm

Hi Benji,

Whats your printer model? Please see that you have updated driver installed.

Whether it happened with any particular user account? I suggest you to check by creating new user account and check if you can set default printer for user.
How do you set default printer for your user, by login script?

You can check the registry setting whether default profile on printer is not corrupted. You can check on following reg keys.
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows

To resolve this issue:
1. Log the user off the terminal server.
2. Copy the %SYSTEMDRIVE%\Documents and Settings\Default User folder from a working Windows Server computer running the same Service Pack to %SYSTEMDRIVE%\Documents and Settings\Default User on the terminal server, overwriting all files.
3. Delete the problem user profile on the terminal server.

After this try to allow the user to logon.

Hope it helps!

Thanks.
Free Windows Admin Tool Kit Click here and download it now
July 27th, 2014 11:35am

Printers affected are all brands of printers.

If I delete the printer from one user session, the printer is also deleted for all other users using this printer in their session. To fix the issue, if a printer is deleted, they have to reconnect to the printer (by using \\servername and double clicking on the printer).

Also, if a VPN tunnel gets disconnected, this is where the other starts: the default printer gets unselected for one user (never the same it seems) and I can't select it back again. If I try to delete the printer, it gets deleted for everyone and when I try to reconnect it (\\servername), then it appears in double and I am still unable to set the printer to default.

Finally, after I deleted the printer from a malfunctioning session, reconnected everyone else and still having this problem with one user, a simple server reboot will fix the issue. This is why I have never attempted to delete a user profile yet and recreate it (and especially that the problem seems to be happening at random independently of the user session).

Benji.

July 30th, 2014 4:37pm

This issue is still there and someone else on Expert Exchange confirmed the same issue. Are we the only two IT persons operating a RDS environment on Windows 2012? P.S.: this is not a printer redirection issue but a print server issue (print server and RDS server both on Windows 2012 R2).
Free Windows Admin Tool Kit Click here and download it now
September 15th, 2014 12:56am

Hi,

Please install the hotfix below on your RDSH servers and see if it resolves some of the issues you are seeing:

A network printer is deleted unexpectedly in Windows

http://support.microsoft.com/kb/2967077

Thanks.

-TP

September 15th, 2014 1:43am

Wow! Definitely part of my problem. Definitely worth to try it. Hope it will fix the rest as well (unable to set default printer, etc.).
Free Windows Admin Tool Kit Click here and download it now
September 15th, 2014 1:50am

Wow! Definitely part of my problem. Definitely worth to try it. Hope it will fix the rest as well (unable to set default print
October 29th, 2014 7:32pm

So far so good. I haven't had a complain since I installed the update last month. And one of my sites was down for three hours this morning and printing resumed correctly when the Internet came back (usually after such long time, printing would have crashed).

I cannot say if it is fixed forever but this update had no negative effect on our environment. I guess you could try it without risks.

Free Windows Admin Tool Kit Click here and download it now
October 29th, 2014 7:59pm

Problem not completely fixed. Seems like within the older sessions that had the bug, it is still partly present.
November 4th, 2014 7:54pm

Same problem here. Some times the default printers "tick" disappear. Removing and re-adding helps, but only for some days...
Free Windows Admin Tool Kit Click here and download it now
November 6th, 2014 10:18am

I have the same issue.  Hotfix as mentioned above was part of a rollup already applied.  Issue will not go away. 8 user system with 3 printers manually have to reinstall printers during the day.  Client mentions how great windows 2003 was in comparison.  Now written off 22 hours ($2500 in billing) on the issue.  Would recommend everyone stay clear of RDS on Windows 2012 R2.  All of 11/11/14 updates applied

Best work around for me (other than use Windows 2003): 

Generic or universal drivers used

Easy print disabled

Lots of 513 errors in logs yet I can browse to print spooler.  Firewall off. Sharing and network discovery on.

Not AV related as there is not AV software as we removed it. Fiji, Brother, HP printers all effected.

The solution of rebuild server as mentioned by MS in another thread is unacceptable.

November 12th, 2014 11:03pm

Very sad reading... I have same issue here.

14 users RDSH 3 different printer brands, all new installation, new print server, dc and rds server

Printers showing twice and printjobs dissapears, often I can solve by deleting the printer for the user calling

Server is all updated before launch late december 2014.

please any help!! users are killing me

Lars

Free Windows Admin Tool Kit Click here and download it now
January 6th, 2015 2:51am

We currently have 3 2012R2 RDSH servers running a pilot system all patched and up to date.

Some users can't select a default printer, some have printers appearing twice, only way to fix is to reboot the servers or delete user profiles, neither of which are viable workarounds long term.

Same printers on 2008R2 RDSH production system work absolutely fine (and have done for the past 3 years).

Need some help with this ASAP to get the system out of pilot - Microsoft, are you looking into this??

Thanks


January 28th, 2015 9:14am

We also have been experiencing a similar problem. One thing worth trying is to check these two keys in the registry 

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers

and see if your backend server is showing up multiple times with different names, for example: printsrv, PRINTsrv, printsrv.company.local, 192.168.1.1... you get the idea

Keep only one server entry and delete the rest then restart the spooler. Then try to be consistent when adding new printers, always using the very same server name. Also be careful of capital letters.

You will probably also need to remove and remap all the printers defined with the "wrong" server names for each user. If not I presume the deleted server names would eventually reappear.

As always, proceed with caution deleting stuff in the registry in production environments...

Hope this helps

Luca

Free Windows Admin Tool Kit Click here and download it now
February 11th, 2015 10:37pm

Hi Luca,

thanks for the suggestion, it's taken me a while to get round to testing it again properly but unfortunately has not worked for us (we didn't have multiple variations of the same server name in the reg keys you mentioned).


March 18th, 2015 10:21am

Same problem here. 300 users on 20 RDS servers. The hotfix did not solve this problem.

Anyone suggestions?

Free Windows Admin Tool Kit Click here and download it now
May 28th, 2015 7:00am

EDIT - Disabling the firewall did not fix it. Still the same problem.

May 28th, 2015 7:10am

Hello, Is this problem solved already ? Dit you escalated to Microsoft ? We are having the exact same problem at one of our custommers . Please let me know. Kind regards Jeffrey
Free Windows Admin Tool Kit Click here and download it now
June 18th, 2015 9:19pm

We are still experiencing this problem, I've reinstalled all RDS servers and the problem went away for about a month, this week it came back with a vengeance, so I'm back to square one on this one.

The weird part is that this is just happening to this particular customer. Also, installing the hotfix did not fix this.


July 10th, 2015 2:54am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics