Windows 2008 R2 - Slow Network Share Access
Hi All, I have recently moved one of our applications from a Windows 2003 Sevrer to a Windows 2008 R2 64Bit Server. The application runs on a desktop by running an exe file from a shared folder. When the program was ran from the Windows 2003 Server the program would run instantly, but now when it run from the Windows 2008 server it takes about 90 seconds to load up. It seems very slow when running it from the Windows 2008 Share. Is there anything different within Windows 2008 than 2003 regarding shares. Are there any settings that I need to make that could make shared folder access quciker on 2008. Both Sevrers are running Teamed 1GB NICS are are plugged into the same switch. I have done some searching and someone mentions they ran this but I dont want to run it as I dont understand what it does just yet. netsh interface tcp set global autotuninglevel=disabled Has anyone come across slow share access before? The desktops are a mix of Windows XP SP3 and Windows 7 Thanks
January 5th, 2012 4:50am

I havent come across this issue. I dont like to disable the autotuning level myself. Have you updated the network card drivers and firmware? Make sure you have Windows 2008 R2 SP1 on the server. Disable any A/V & firewall software on the server if any, might as well boot the server in minimal boot mode if possible and test.
Free Windows Admin Tool Kit Click here and download it now
January 5th, 2012 7:01am

Hi, The network drivers are all up to date and the firmware is too. The server is already running SP1. I've disabled the Anti Virus and it hasn;t made any difference. Could it be that Windows 2008 uses SMB version 2??
January 5th, 2012 8:30am

check your nic advanced settings like disable the ipv4 checksum settings and all other settings and try ithttp://www.virmansec.com/blogs/skhairuddin
Free Windows Admin Tool Kit Click here and download it now
January 5th, 2012 8:38am

Yes 2008 R2 uses SMB 2.1 You can use "process monitor" to see whats taking so long for the exe to open. Take a look at this; http://blogs.technet.com/b/markrussinovich/archive/2010/12/07/3373406.aspx
January 5th, 2012 8:41am

It is a HP Team of 2 network cards. I do have an option of disabling the TCP CheckSum Offload (IPV4) which is currently set to RX/TX Enable Is this was I should set to disable? Thanks Chris
Free Windows Admin Tool Kit Click here and download it now
January 5th, 2012 8:41am

What I dont understand is that from a Windows 7 Client the application and file access is absolutly fine and is the same as it was when the files were on the Windows 2003 Server. It only seems to be slow on the Windows XP clients.... This would sort of suggest that it isn;t anything to do with the NICS, AV, drivers etc although I'm open to suggestions.
January 5th, 2012 11:37am

One more suggestion, on one of the xp machines, try to disable the tcp checksum offloads (send and receive), reboot and then test.
Free Windows Admin Tool Kit Click here and download it now
January 5th, 2012 12:13pm

Thanks, Tried setting the tcp checksum to none on a Windows XP workstation and there was no change. This is what I have found so far when running the executable on the new Windows 2008 R2 Share Windows 2008 to the Windows 2008 R2 Server Share - Fast about 10 seconds Windows 7 to the Windows 2008 R2 Server - Fast about 10 seconds Windows XP SP3 to the Windows 2008 R2 Server - Slow about 60 seconds They are all plugged into the same network switch although most of the xp clients would be running at 100mb rather than 1gb Looking at the above it certainly points towards something being different on the new Windows 2008 R2 Server. Could it be something to do with this SMB2, I know it is meant to be backward compatable??
January 6th, 2012 1:32am

yes might be see this article and give a try and do let us know the effect http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htmhttp://www.virmansec.com/blogs/skhairuddin
Free Windows Admin Tool Kit Click here and download it now
January 6th, 2012 1:36am

yes might be see this article and give a try and do let us know the effect http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htmhttp://www.virmansec.com/blogs/skhairuddin
January 6th, 2012 9:30am

Hi Chris, Have you tried the suggestion provided by Syed to disable SMB on Windows Server 2008? What’s the result? Please check this similar thread. Browsing shared folders slow from XP http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/7817f338-50ec-4de6-b059-4370588f4e30/ If it does not help, you may collect a network monitor trace on the Windows XP machines when reproducing the issue by establishing the SMB connection to server. Download: Microsoft Network Monitor 3.3 http://www.microsoft.com/downloads/details.aspx?FamilyID=983b941d-06cb-4658-b7f6-3088333d062f&displaylang=en How to use Network Monitor to capture network traffic http://support.microsoft.com/kb/812953 Thanks ZHANG
Free Windows Admin Tool Kit Click here and download it now
January 10th, 2012 12:28am

Hi Chris, Have you tried the suggestion provided by Syed to disable SMB on Windows Server 2008? What’s the result? Please check this similar thread. Browsing shared folders slow from XP http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/7817f338-50ec-4de6-b059-4370588f4e30/ If it does not help, you may collect a network monitor trace on the Windows XP machines when reproducing the issue by establishing the SMB connection to server. Download: Microsoft Network Monitor 3.3 http://www.microsoft.com/downloads/details.aspx?FamilyID=983b941d-06cb-4658-b7f6-3088333d062f&displaylang=en How to use Network Monitor to capture network traffic http://support.microsoft.com/kb/812953 Thanks ZHANG
January 10th, 2012 8:24am

Hi Guys, Thanks for everyones unput and sorry for the delay coming back. It turned out to be a Network switch problem that strangely only affected Windows 2008 Servers. I did some testing and found that if I plugged a workstation directly into the switch that the Sevrers were patched into then it was again fast. If I ran it from the access layer switches it was very slow but only to Windows 2008 servers, Windows 2003 servers were fine. I swapped out the Switch and its instant again. So nothing to do with Windows 2008 directly. Thanks for everyones input.
Free Windows Admin Tool Kit Click here and download it now
January 12th, 2012 8:48am

I had the same problem when accessing an app's .exe which is shared on WinServer2008R2 from XP client. I changed speed&duplex from auto to "100Mb half" by right clicking network adaptor-->configure button-->advanced tab and it is now working great for me. Hope this helps.
May 28th, 2012 1:46pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics