Slow File Sharing
I just installed the latest build of WS2008 Enterprise. Everything is presently set at default, with no additional roles or features installed, other than DNS server. I am experiencing serious issues with File Sharing from other PCs on the network to the WS2008 machine. I have tried from various WinXP machines as well as Vista machines with virtually the same results. If I am accessing a folder with few files/folders, everything is fine. When I try to access a shared folder (or admin share) that has multiple files/folders or subfolders, I get wait times of several minutes while the folder populates, often times explorer stops responding. If I tried to actually copy files from the WS2008 server, it will begin copying, slowing down immediately, and then stop with an error indicating the network path was no longer available. I also have WS2003 installed on a virtual machine inside the WS2008 server. I can access files on the WS2003 machine without any problems or delays. I can also share files back and forth between the WS2008 and WS2003 machines without issue. The problem only arises when trying to access shared files/folders on the WS2008 machine from an XP/Vista machine on a wired or wireless connection (same results in either case). From everything I have read about file sharing on WS2008, what I am experiencing does not exist and I shouldn't be seeing it. But as it stands, I cannot effectively access any shares on WS2008. I had this same problem during Beta 3, but was hoping it would be resolved by RC0. Any suggestions? I've tried various TCP and DNS configurations. I've tried with NetBIOS and without. I've tried using IPv6 on all machines as well as IPv4. I've tried with the Firewall enabled and disabled. Right now the only use I have for WS2008 is a glorified host for virtual servers, for which it does a beautiful job.
March 7th, 2008 1:52am

Looks like I may have found the root of my problem. It seems that having Virtual Machine Network Services bound to the NIC is causing the connectivity issues I am seeing. If I disable VM Network Services, the problems go away. Of course this means I am unable to run a Virtual Machine on WS2008 at this time.
Free Windows Admin Tool Kit Click here and download it now
March 8th, 2008 8:24am

That sounds like a problem with the NIC driver in the host. Some of them don't work well with VMNS. There has been a fair bit of discussion about this in the virtual server newsgroups and also in the Server 2008 virtualzation forum. One thing you could try is to disable TCP offload in the NIC properties on the host machine.
March 9th, 2008 3:29am

By the way, running a Server 2008 install purely as a host for virtual machines is the Microsoft recommended confguration. They also recommend running it as a server core version .If you have the Hyper-V role enabled, it is recommended that you do not enable any other roles on the parent partition. Run them in one of the vms in a child partition. Hyper-V is not simply an extra application like Virtual Server. It fundamentally changes the way the parent OS works.
Free Windows Admin Tool Kit Click here and download it now
March 9th, 2008 5:39am

I am seeing a very similar problem when trying to access a 100 GB partition on a second HDD local to the 2008x64 EE RTM server (running Hyper- V-RC0) Explorer basically times out (becomes non responsive) the problem on the other hand does not exist on a second ~ 60 GB partition also located on the second physical HDD. Both partitions can be accessed fine from a Vista SP1 client with unnoticable access speed problems. Forr test purposes I tried turning the volume indexing feature off - no improvement. Both partitons on the 2nd HDD only hold media files not related to any of the Hyper V child systems. CPU is at ~2% and free memory at ~ 900MB when the problem occurs.
May 14th, 2008 10:10am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics