SCVMM 2012 SP1 Virtual Switch on Cluster Node Disappears

I have been running into an interesting but an alarming issue with virtual switches. I have recently built a 4 node Server 2012 Hyper-V failover cluster. I have built numerous 2008R2 and 2012 Hyper-V clusters before, so I am pretty familiar with the process. I have rebuilt my VMM due to software problems, and on this new cluster, I have configured the virtual switches with nic teaming on 2 of the virtual switches.

I have 4 clusters being managed by this VMM.. and this newly built cluster keeps losing all of the VMM virtual switch configurations, meaning if I go to properties on the problem host and click on virtual switches, its blank. Refresh host cluster flags all virtual machines in this cluster as "Unsupported Configuration," making the vm unmanageable via VMM. 

Information (26844)
Virtual switch (Virtual Switch Name) is not highly available because the switch is not available in host (One of the Hyper-V Hosts).

Recommended Action

All virtual servers on that host still has connectivity, as all virtual switch configs are normal when looking at it with Hyper-V Manager or Failover Cluster Manager..

The workaround is to evacuate the host using Failover Cluster Manager and reboot the host. Then refresh the host. Then refresh the VM's. I cannot consider this a 'workaround' as I cannot be rebooting my hyper-V hosts every week.. and migrating virtual servers constantly just for this reason. (DPM backups have a FIT with csv's if it tries to backup a vm on a same csv as another vm thats being migrated.)

I have been wrestling with this problem for a few weeks now. The cluster has been slicked and completely rebuilt.. Still same problems. Has ANYONE else out there seen this issue? Does ANYONE out there suggest a way to go about further troubleshooting this issue? 

  • Edited by cheesewhip Tuesday, August 26, 2014 2:16 PM correction
August 26th, 2014 2:09pm

Well those are the obvious candidates.  It would be interesting to see the output of Get-SCVirtualNetwork.  Something like:
Get-SCVirtualNetwork -VMHostCluster %ClusterName% | ft Name,VMHost,LogicalNetworks,LogicalSwitchComplianceStatus

Free Windows Admin Tool Kit Click here and download it now
August 27th, 2014 6:25pm

Hi Folks 

Have you found any fix ? I'm in same situation . VMM seems to loose all the switch info. However Cluster is fine . VMs are up and running . Im on SCVMM 2012 SP1 with rollup7 . 

Guys Please let me know if you find solution . So far Im only rebooting the hosts to fix these issues . after sort of 15 - 20 day this will happen again . It has bee 3 months now Im getting same issue . Not sure how to proceed . My company is not ready for 2012 R2 yet 



  • Edited by mumtazkhan Monday, December 15, 2014 1:36 PM removed private info
October 1st, 2014 5:25pm

Has anyone found a fix for this, this has been happening to my system for months, I have both a SCVMM 2012 SP1 and R2 VMM lab and it happens on both versions.
  • Edited by Drakie Thursday, October 09, 2014 2:53 AM
Free Windows Admin Tool Kit Click here and download it now
October 9th, 2014 2:53am

Hey Folks 

Any positive response from Microsoft yet?. One more thing I have noticed is when I am refreshing the cluster I have getting below error in event log of the hosts. 

The server {73E709EA-5D93-4B2E-BBB0-99B7938DA9E4} did not register with DCOM within the required timeout. 

Number of entries are equal to number of Virtual Networks in my Hosts. 

There are some fixes revloving around permissions in registry . I have tried to give everyone permissions on this registry but does not help . 



  • Edited by mumtazkhan Wednesday, October 29, 2014 4:56 PM Additions
October 28th, 2014 12:51pm

Hi gents,

I did some testing and found following workaround without any downtime: restart "Windows Management Instrumentation".

This is an issue with VMM talking to Hyper-V, and not with Hyper-V itsself. In my opinion, one of the current "imperfections" of VMM/Hyper-V is the overall WMI communication between VMM and VMHost. In reference of the performance counters-issue after a reboot of a VMHost (, restarting the SCVMMAgent-service isn't enough. Just restart the whole "Windows Management Instrumentation"-service. After this VMM is able again to see the Logical Switch again.

Check the dependencies first offcourse, but SCVMMAgent and VMMS can be restarted without any impact on your running VMs.

My environment is SCVMM2012R2, managing multiple Hyper-V clusters (2012 & 2012R2).

Offcourse, this is a workaround, and I'm looking forward to a stable solution for this(, and all other small 'growing pains' of VMM), so please let us know...

Free Windows Admin Tool Kit Click here and download it now
October 31st, 2014 9:01am

Just for everyones info, after 16 days of the upgrade to SCVMM 2012 R2 UR4, I have the same issue as before, this is not fixed.
  • Edited by Drakie Thursday, November 27, 2014 3:43 AM
November 27th, 2014 3:42am

I wasn't saying that dpm was THE cause of the problem. Possibly just coincidental. And I have backups going every night- and I do not have this problem of the virtual switches disappearing every morning when I come in. 

I would, however, like to give a warning about DPM... 2012. R2. well.. upgrading to R2 from SP1

We were having issues with dpm leaving failed backup vss images on our csv's... (cluster shared volume) I am having to resort to using software vss because for some reason I cannot get our hardware vss provider to work nice with dpm. One extended weekend, when things were not being monitored closely... the csv space crept up to over 95%.. which resulted in the cluster losing the csv.... and 77 of our production servers unexpectedly rebooted. Long story short, we needed some sort of "professional" troubleshooting and analysis from Microsoft. We opened a case... and one of the troubleshooting they suggested was to upgrade to dpm2012 r2 as we were running dpm2012 sp1. 

I upgraded the agents on a 4 node cluster. Cluster nodes needed rebooting. So I vacated a node, rebooted it, was getting ready to do the second one... and the rebooted node stopped responding. I rebooted it again, it was fine for about 5 minutes.. So in that 5 minutes I vacated and rebooted the second node. I was left with 2 non functional hyper-v nodes. No computer management. Unable to do log onto the servers even on the console. I spent the next few hours rebuilding ALL the cluster nodes from scratch. 

I did notice right before the dpm upgrade that VMM was saying that 2 of the nodes in the cluster had no virtual switch... and all the vm were marked with 'unsupported configuration.' Microsoft DPM team blames the WMI breakage between VMM and the hosts as the cause of this disaster. 

So... I would urge everyone to fix their virtual switch problem on the hosts (well, in vmm..) if you plan on doing any kind of system center.. DPM or whatever.. or actually doing any kind of upgrade prior to the process by rebooting the hosts or restarting the wmi service.

Oh yes, as a footnote warning- restarting the wmi service DID fail us once or twice so far... so now we are opting to vacate and reboot whatever host is faced with this issue. its kind of annoying. i run a lot of virtual servers...

  • Edited by cheesewhip Thursday, March 12, 2015 7:55 PM left out word
Free Windows Admin Tool Kit Click here and download it now
March 12th, 2015 7:54pm

We are still getting this issue, I am starting to wonder if its hardware/drivers cauing it, is there a common factor here?

We are using HP Gen8 Blades (bl460c) and DL380's, the blades use the Eumlex flex fabric, is anyone else using the same hardware?

  • Edited by RichS82 Saturday, March 14, 2015 11:40 PM
March 14th, 2015 11:40pm

As mentioned I am on SCVMM 2012 R2, 27 days ago Prem support told me to install UR6, one of the bug fixes in UR6 is this exact issue.

So far after 27 days I have not seen this issue appear again, it used to come back after approx. 14 days.

Now I am not sure if they have released the same fix for SCVMM 2012 that they did for R2.

Free Windows Admin Tool Kit Click here and download it now
May 27th, 2015 2:06am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics