SCVMM 2012SP1 setting bandwidth

Hello everyone,
I have a problem in creating VMs from SCVMM because when I try to create a VM are generates the following errors:

Error 25262: CAN NOT SET bandwidth setting on virtual network adapter for SRIOV switch (Public Network)

Recommended Action: Check the native virtual port profile and correct the issue.

What could be the problem?

Thanks in advance for your help,

Luca

April 29th, 2013 9:15am

Seems like you are using converged fabric and logical switches here in VMM.

Make sure that the virtual network adapter profile and the port classification on your logical switch are correct, and match the criteria.

Also note that Update Rollup 2 is available for VMM 2012 SP1, which contains a bunch of fixes related to networking in VMM.

Can you deploy update rollup 2 and try the operation again?

Also, it would be nice with some background information about your configuration here, to be able to help you.

-kn

Free Windows Admin Tool Kit Click here and download it now
April 29th, 2013 6:18pm

Hi Kristian,

thanks for the answer. 

I installed the rollup 2 but unfortunately the problem still occurs.

What type of information do you need?

Regards,

Luca

May 1st, 2013 3:26pm

HI Freedom80,

I need to have additional information like:

  • - What kind of network adapter are you using into your node and it it SRIO-V capable?
  • - Do you already have enabled SRIO-V at the network card?
  • - Do you enabled SRIO-V into your BIOS? 
  • - Have you installed the latest (SRIO-V) compatible drivers?

* Maybe you can try deploy a windows server 2012 VM directly at the node with the same virtual switch and see if the SRIO-V status after installing the OS is enabled/ok. If the status is good we have to focus at the configuration settings into VMM. 

Thanks in advanced for the additional information.

Regards,

Tristan

Free Windows Admin Tool Kit Click here and download it now
May 1st, 2013 7:37pm

Hello Tristan,
I try to answer your questions:

1) The network cards are intel I350 that support SR-IOV;
2) SR-IOV is enabled both within the network adapters in the BIOS;
3) The network card drivers are up to date;

Through powershell, however, I was able to verify that the parameter bandwidth reservation mode is set to "none" and I think that my problem is this.

How can I set it to one of the parameters absolute or weight, or make sure that VMM ignores the setting of minimum bandwidth?

Thank you,

Luca


  • Edited by FREEDOM80 Monday, May 06, 2013 10:50 AM
May 6th, 2013 10:22am

Hello Tristan,
I try to answer your questions:

1) The network cards are intel I350 that support SR-IOV;
2) SR-IOV is enabled both within the network adapters in the BIOS;
3) The network card drivers are up to date;

Through powershell, however, I was able to verify that the parameter bandwidth reservation mode is set to "none" and I think that my problem is this.

How can I set it to one of the parameters absolute or weight, or make sure that VMM ignores the setting of minimum bandwidth?

Thank you,

Luca


  • Edited by FREEDOM80 Monday, May 06, 2013 10:50 AM
Free Windows Admin Tool Kit Click here and download it now
May 6th, 2013 10:22am

Hi Luca,

What was the results when you create a virtual machine at the hyper-v Host, is the status SR-IOV ok? 

Can you also post the results of the commands below?:

To check if IovSupport is enabled, type:

get-vmhost | fl

To verify that SR-IOV is supported, and the number of VFs, type:

get-netadapterSRIOV | fl

To see why the SR-IOV status is degraded, type:

get-vmnetworkadapter | fl

More information about SR-IOV for Windows server 2012 can be found at my blog

http://hyperv2012.wordpress.com/2013/05/03/server-2012-sr-iov/

Regards,

Tristan

May 6th, 2013 11:57am

Hi Tristan,

I solved the issue with SR-IOV, but unfortunately the problem remains.

Running the command get-vmhost | fl I get this result:
IovSupport: True
IovSupportReasons: {OK}

Unfortunately, the problem remains, infact when I try to deploy a VM from VMM I always get this error:

"Error 25262: CAN NOT Set bandwidth setting on virtual network adapter for SRIOV switch (Public Network)
Recommended Action: Check the native virtual port profile and correct the issue."

I noticed, however, running the command: get-vmshitch | fl I get these results:

"BandwidthPercentage: 0
BandwidthReservationMode: None
DefaultFlowMinimumBandwidthAbsolute: 0
DefaultFlowMinimumBandwidthWeight: 0"

The problem I think is the BandwidthReservationMode parameter set to "none".

Is there a way to change this value?

Thank you again,

Luca


  • Edited by FREEDOM80 Tuesday, May 07, 2013 2:54 PM
Free Windows Admin Tool Kit Click here and download it now
May 7th, 2013 2:45pm

Hi Tristan,

I solved the issue with SR-IOV, but unfortunately the problem remains.

Running the command get-vmhost | fl I get this result:
IovSupport: True
IovSupportReasons: {OK}

Unfortunately, the problem remains, infact when I try to deploy a VM from VMM I always get this error:

"Error 25262: CAN NOT Set bandwidth setting on virtual network adapter for SRIOV switch (Public Network)
Recommended Action: Check the native virtual port profile and correct the issue."

I noticed, however, running the command: get-vmshitch | fl I get these results:

"BandwidthPercentage: 0
BandwidthReservationMode: None
DefaultFlowMinimumBandwidthAbsolute: 0
DefaultFlowMinimumBandwidthWeight: 0"

The problem I think is the BandwidthReservationMode parameter set to "none".

Is there a way to change this value?

Thank you again,

Luca


  • Edited by FREEDOM80 Tuesday, May 07, 2013 2:54 PM
May 7th, 2013 2:45pm

Try running the command below.

Set-VMSwitch "VMSW01" -DefaultFlowMinimumBandwidthWeight 20

This will configure the Virtual switch to use 20% of the total bandwidth of the physical NIC.

Free Windows Admin Tool Kit Click here and download it now
July 6th, 2015 5:51am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics