Repair Server 2008 R2 system files with DVD ?
Hi, Is it possible with a server 2008 R2 to repair the system with the dvd as it was for exemple with Windows XP ? Which would repair the file system, but without touching to the data files ? If yes, if the server is a domain controler, would it stay that way, or would it become a simple server in a workgroup ? Thanks a lot, alan
October 26th, 2010 5:13am

if you give more details whats broken, there might be better tips. does the server boot at all? when you speak about repairing the file system, what is broken? tried running chkdsk? if system files are corrputed, you can try a sfc /scannow (sfc /verifyonly if you prefer just to get info first if windows thinks files arent what they are supposed to be).
Free Windows Admin Tool Kit Click here and download it now
October 26th, 2010 3:59pm

The problem I have : . In another forum e propose me to repair the server with the dvd, but I'm asking if it's possible with a server 2008 R2. But I'm also asking generally about this tips whiwh was use for windows XP or server 2003, and wanted to know if it was still existing now.
October 26th, 2010 4:08pm

Hi, You can repair the Windows Server 2008 R2 system but there are some differences. In previous systems, you can boot from the disk and then repair the system. In Windows Server 2008 and Windows Server 2008 R2, you should run the disk from the current system to perform an In-place Upgrade. For example, if you are running Windows Server 2008 R2 Enterprise, you can insert the installation disk, double-click setup.exe and install Windows Server 2008 R2 Enterprise again over the current system. Normally your personal data will not be destroyed after that. But it is still recommended to back up your important files first. Tim Quan
Free Windows Admin Tool Kit Click here and download it now
October 26th, 2010 10:42pm

I've tried to install this upgrade, everything seems to be find, but at the last reboot, it writes me that the upgarde has failed, without explanation, and it backed up the system as it was. I don't know if it has an influence, but I had disconnected the network, to be sure that there would not be any problem in active directory on the network if the upgrade erased active directory. You see what I mean ? (sorry for my poor english, I'm french)
October 27th, 2010 3:16am

Hi, Why would you like to repair the system? What problem occurs on your system? Before repairing the system, I recommend running sfc /scannow first. Before in-place upgrading the system, please disable all third-party software and unplug all unnecessary devices such as sound card, network card and external hard drive. Tim Quan
Free Windows Admin Tool Kit Click here and download it now
October 27th, 2010 4:12am

The problem which occured in my system : I've found many problem having the same problem, but who didn't have so far any solution. That's why I wanted to try to repair the system. I will now try your command sfc /scannow. Before upgrading the system, i had unplugged all material I could.
October 27th, 2010 4:57am

Hi, Thank you for the reply. Please also run the System Update Readiness Tool and paste the result in %SYSTEMROOT%\Logs\CBS\CheckSUR.log The System Update Readiness Tool can be downloaded from the following site: Related article: Tim Quan
Free Windows Admin Tool Kit Click here and download it now
October 28th, 2010 2:32am

Thanks for your answer. But as I mentionned in the original thread : I've tried to install the The System Update Readiness Tool , but as every update, .msu, I can no longer install them...That's one of the original matter ! ;-)
October 29th, 2010 4:22am

For more information, I've tried the command "sfc /scannow" wednesday 27th at 11am. It tells it reparis some problems, but couldn't repair everything because of windows authorisation. I've retried then the system update readliness tool. As before, ti writes "looking for existing update", but then nothin happens. I don't have a checksur.log on the directory, just a cbs.log. Here it is with the log from the "sfc /scannow command" and the try of installation of SURT (if you understand it..?): Thanks again for your help, I really need it (and it seems I'm not the only one on the Internet...)
Free Windows Admin Tool Kit Click here and download it now
October 29th, 2010 4:49am

Hi, Now I suggest trying In-place Upgrade again. Tim Quan
November 1st, 2010 4:17am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics