NIC driver
Have installed Server 2008 in a VM but no driver found for my Realtek RTL8139 NIC. Have tried the latest Vista driver from Realteks website but NIC is still not recognised. I am surprised there is no driver built into the OS as this must be one of the oldest/commonest NIC there is.
March 21st, 2008 1:05am

I'm sorry to have to inform you Microsoft Windows Server 2008 only supports Gbit TX-basedNetwork Interface Cards (NICs) out of the box. Since your Realtek 8139 card is a 100Mbit TX-based NIC it is not supported out of the box, as are other popular 100Mbit TX-based NICs (3Com 905s for instance)
Free Windows Admin Tool Kit Click here and download it now
March 21st, 2008 11:17am

I wonder if I am slightly confused here: I previously had a beta version of Server 2008 running a domain with several clients allasseperate virtual machines(VMWare) on one host PC, and I had that all working ok. Now I have installed the latest version of Server 2008 again in a virtual machine, when I look in Device Manager I have no driver for a network controller. I have tried to install the latest Vista driver from but this wont work. Am I mistakingly assuming the controller is the actual host PC,s NIC (which is the 8139), or is it the virtual machines built in controller which requires a driver for Server 2008? I was able to activate/update my beta version ok over the internet by setting TCP/IP to DHCP temporarily (reset to static to run the domain). However I cannot activate my new version beause I cannot access the internet at all from within the Server VM.
March 21st, 2008 4:16pm

This was a VMWare issue. Have downloaded trial of VMWare Workstation 6 and loaded the Server 2008 VM and it installs its own VMNet driver. Have succesfully activated and updated the OS ok now.
Free Windows Admin Tool Kit Click here and download it now
March 23rd, 2008 12:55am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics