Missing VM's from Hyper-V Manager - visible via PowerShell

I installed Windows Server 10 TP on my servers yesterday, I setup a brand new environment of VM's with Generation 2 as a baseline across it, Windows Server 2012 R2(1 x DC, 1 x AD CS, 1 x Exchange, 1 x SCCM 2012 R2) and Windows Server 10 Technical Preview(1 x DC + 2 x Hyper-V nodes). These all appear fine.

I also setup some new Debian Wheezy (7.4 and 7.6 mix) VM's as Generation 1 to start playing with logstash/influxdb. These disappeared after they were setup from the Hyper-V Manager on the Hyper-V node. The Hyper-V node is not domain joined and as such there is only one user account at the moment on it, of which everything was installed as.

I noticed the used memory after reboot stayed high (40%+) even with all Windows VM's powered off. Using Get-VM, I can see all the Linux VM's I installed previously. The question is why are these not appearing in the Hyper-V manager, is this to force me to learn more powershell when I use *nix systems?

Using SSH to the IP's of each VM I am able to connect to all of them, so they are running as they should underneath the covers.

I have not seen this behavior on either Windows Server 2012 or Windows Server 2012 R2 where the VM's of any sort (supported), appear properly in the Hyper-V Manager.

Thoughts?

October 4th, 2014 10:23am

I'm seeing a similar issue.  I notice a VM "Win7" was missing.  It was indeed accessible via ping and RDP.  Create a second VM "Win7--" and reboot server...now it's gone?
Free Windows Admin Tool Kit Click here and download it now
October 4th, 2014 11:14am

So I think I see my issue...I renamed "Win7" to "_Win7" and now it appears.  I've done this with other VMs with WinXX as the name and they are appear now.

Strange.

October 4th, 2014 11:24am

More insight....

If I connect to the Hyper-V manager via a Win8 or downlevel client...all the VMs appear.

Free Windows Admin Tool Kit Click here and download it now
October 4th, 2014 11:42am

Hi!

Unfortunately, this is a known bug in the Technical Preview release.

The specific issue is that Hyper-V Manager gets confused if a virtual machine returns basic heartbeat information, and does not include application health state.  Luckily - there is a simple work around.  If you run the following PowerShell line:

get-vm | ?{$_.heartbeat -eq "OKApplicationsUnknown"} | Disable-VMIntegrationService "Heartbeat"

This will turn off the Heartbeat service for any virtual machine that is not returning application state.

Cheers,

October 4th, 2014 7:34pm

Thanks Ben, the powershell commandlet solved it!

Free Windows Admin Tool Kit Click here and download it now
October 7th, 2014 8:48pm

Yep ! Thanks Ben. Solved also
November 5th, 2014 8:50am

I had VM's missing from Hyper-V Manager in Windows Server 2012 R2. The missing ones that should be started actually were as I found out and all of them showed up using Get-VM in PowerShell. Even if it's slightly off-topic, I'll post my solution here for others to find.

Odd enough, about halfway through the list there was one VM reported OffCritical and those VM's still showing up in Hyper-V Manager had names alphabetically before that one. All those that were missing were after it (and exactly the one in OffCritical state, as might be expected). Since I didn't care having to recreate the one in OffCritical so much - as opposed to perhaps exporting and importing all the others - I just ran

Remove-VM -Name NameOfTheVMInOffCritical 
net stop vmms
net start vmms

to find all my VM's back in Hyper-V Manager.

Free Windows Admin Tool Kit Click here and download it now
May 3rd, 2015 7:58pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics