Error 2606 - Host Not Responding


I have three identical VS 2005 x64 R2 SP1 hosts added to my new SCVMM console but one is not responding.

I have performed all of the troubleshooting steps in the documentation and on this site but the problem persists.

Please note that the virtual machines have been added to the console np.

In the Error Log it lists the following issue:

Error (2606)

Unable to perform the job because one or more of the selected objects are locked by another job.

Recommended Action

To find out which job is locking the object, in the Jobs view, group by Status, and find the running or cancelling job for the object. When the job is complete, try again.

January 15th, 2008 11:57pm

I am having the same issue with 13 out of 33 Hosts. I see no jobs in the running or cancelled state as per the Error log. Some steps I have taken to rectify the issue:

1. I have tried to rebooting the machine with no success.

2. Restarting the WINRM service with no success.

3. I also tried the solution posted on this post with no luck.

I understand that SCVMM uses the WinRM ports to report the status of the Host as per my earlier question in

I do notice when I telnet from the SCVMM console to the VMHost on port 80 that it takes 10-15 seconds to connect (we have multiple FWs between the servers) and am wondering if a timeout condition is present that needs to be increased.

Any and all help will be appreciated.

Free Windows Admin Tool Kit Click here and download it now
January 17th, 2008 6:53pm

Thank you for your response.

I don't have any firewalls in between my hosts and scvmm and I still have the same issue.

I am also experiencing certain jobs failing intermittently (P2V, Library Store, SysPrep) but I'm not sure if it is related. However, scvmm does make a connection to the target hosts so I think there is some kind of connectivity issues causing these problems.

From all of the posts that I have read, maybe my problems are caused by running the SQL Express on the scvmm server. I'm going to try creating the db on a seperate sql server to see if that helps.

So far it seems the product has some great potential but of course nobody is using it so we are on our own!

January 17th, 2008 7:07pm

Make sure the SCVMM Console server is in the local admin group of the VM Host. This solved my problem with the regular client install. We had a GPO regulating the membership of the local admin group and the server was removed. We have added the server to be allowed in the Local Admin group via the GPO.

Check this article out... ""

I am still figuring out how to fix the VM Hosts that were done using the Perimeter install. When I figure it out I will post. Hope this helps.

Free Windows Admin Tool Kit Click here and download it now
January 18th, 2008 12:23am

Yesh, I went thru that troubleshooting document already and the console is in the local admin group.

Let me know what you find out.


January 18th, 2008 12:29am

As a suggestion, you could try uninstalling the SCVMM agent via Add/Remove programs on the VM Host, rerun the WinRM installation, and then reinstall the agent. As far as I know, the WinRM component is what tells the SCVMM Console the status of the Host.

My problems in both my environment had to do with the server missing from the local admin group because our GPOs restrict access to that group. Good luck.

Free Windows Admin Tool Kit Click here and download it now
January 18th, 2008 6:36pm

sigh - i guess i will have to give it another try...

i am thinking about rebuilding my entire virtual infra with 2008 anyway so maybe this effort is fruitless...

hurry up 2008!

January 22nd, 2008 10:38pm

If you go to the host properties for one of the hosts which is not responding, and view the status tab. What do the status there say? This should atleast narrow down where the problem is.

Free Windows Admin Tool Kit Click here and download it now
February 11th, 2008 8:02pm

Overall Host Status:

Overall host status: X Not Responding

Agent Status:

Connection: Responding

Version: 1.0.2626.0

Upgrade: Current

Virtualization software status:

Service: Unknown

Version: 1.1.603.0

Upgrade: Current

February 11th, 2008 9:24pm

Do you have Virtual Server installed on the machine? What is the output of running the following command on the host?

sc query Virtual Server

Free Windows Admin Tool Kit Click here and download it now
February 25th, 2008 11:26pm

SERVICE_NAME: Virtual Server




WIN32_EXIT_CODE : 0 (0x0)




February 25th, 2008 11:44pm

We've been struggling to solve the same problem all day, trying all the MS & Google suggestions without any luck. To cut a long story short, the following command, run on the host, fixed our "not responding" errors:

winmgmt /resyncperf

After a few seconds, the problem host changed to "Responding" in the VMM console.

Hope this helps!

Free Windows Admin Tool Kit Click here and download it now
March 17th, 2008 9:07pm

It didn't work for me...

I just get a bunch of errors in the eventvwr when I try that...

Thanks however...

March 17th, 2008 10:32pm

Scratch that - it did work afterall - i just had to reboot!


Free Windows Admin Tool Kit Click here and download it now
March 18th, 2008 5:58pm

Excellent! I'm glad your problem is sorted. Perhaps this solution should be included in the Technet Troubleshooting guide -
March 19th, 2008 1:23am


I have the same problem (error 2606).
I added an host with Virtual Server 2005 SP R2 to SCVMM successfully.
And finaly, it doesn't respond on SCVMM consol ... (global status is "not respond" but agent status and software status are "respond" and "running")

I try to apply the solution give by PABBY but it didn't change anything (I execute command and reboot the server).

note that SCVMM is running on Windows 2003 with a Virtual Server on the same server (which work correctly) and that Virtual Server which give me problem run on Windows Server 2008 (I don't know if it can work because of this )

Any suggestions ?

Free Windows Admin Tool Kit Click here and download it now
March 19th, 2008 3:08pm

I agree, that was a real head-scratcher...

March 19th, 2008 4:45pm

Did you also try that troubleshooting guide?

Free Windows Admin Tool Kit Click here and download it now
March 19th, 2008 4:47pm

I didn't try to follow step by step the guide, but on first read, I tried lot of thing that show in it ( I think I try all step by I'm not sure...)

I will try it tomorrow step by step if I have enough time.
March 19th, 2008 7:56pm


I follow all the step in the guide and finaly, it's still not reponsd....

Any suggestion ?
Free Windows Admin Tool Kit Click here and download it now
March 20th, 2008 2:38pm


Does "winmgmt /resyncperf" this work on windows core 2012 hyper-v also. I am facing the same issue(scvmm shows Not Responding" status for host). I have tow host and when I add them to scvmm the status will be host not responding and the job will get failed. But I can access them through RDP and also with Hyper-V manager console. I am also getting an error 408 with one host which says to uninstall the vmm agent.

Please help!!!  

October 24th, 2012 2:24pm

Old post by just over a year. the winmgmt /resyncperf for SCVMM and the host in question worked for me

Running SCVMM 2012 SP1 and Server 2012 - not R2

thought I would throw this out there for those who might not think it would apply being this old.  Guess it still does.

Free Windows Admin Tool Kit Click here and download it now
November 7th, 2013 12:34am

This worked for me as well had ran command - winmgmt /resyncperf

Did a reboot afterwards and now my hosts are showing as "OK"

Thanks for this.!

July 8th, 2015 7:16am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics