Dynamic query disappears from group

Hi All,

I've created a group within my SCOM deployment and wanted to add Windows servers to this group dynamically, using a Dynamic inclusion Rule.

However when I create the rule and click apply, it seems to save (it also says populating the group members).

But when I check the group via the "view group members" actions, it is empty..

The formula I've added is a very simple one: ( NetBIOS Domain Name Equals 'domainname' )

When I check back on the tab for Dynamic Members, then I don't see my rule anymore.

It seems as if it didn't get saved.

Can anyone help me on this?



May 2nd, 2013 2:15pm

Hi Filip,

Try to create a group in a fresh overrides MP or change the formula to another simple one to check.

Free Windows Admin Tool Kit Click here and download it now
May 3rd, 2013 3:49am

Hello Natalya,

I've tried what you suggested but this gives the same outcome.

When I click apply after creating the rule, it is shown in the pane.

But when I click OK and the group window has closed, then pane is empty again when I re-open it..


Does anyone have any other suggestions what could be causing this?


May 7th, 2013 11:34am

The UI for the groups wizard in the Operations console can be tricky, and there is no validation message indicating incorrect expressions. Sometimes it is easier to create a group in XML than in the console. Here are some examples of how to do this in VSAE: http://scomskills.com/blog/?p=383

If you can copy/paste your criteria in here from the Operations console, someone might be able to offer better advice.

Free Windows Admin Tool Kit Click here and download it now
May 18th, 2013 6:27am

Hi all,

Apologies for resurrecting an older post, but I still don't get it. I followed up on the link, but I haven't had the time to familiarize myself enough with SCOM to feel confident enough to create such a XML.

Basically, I want to add servers with a NETBIOS/DNS name starting with WEB... or SQL... etc.

I tried the GUI several times, only to find my queries were gone with no group members in the computer group. I build my queries based on:

Class: Windows Server
Or Group for Windows Server (all of these are true):

  • DNS Name Contains WEBNY
  • DNS Name Contains SQLNY
  • DNS Name Contains WEBAMS
  • DNS Name Contains SQLAMS

SCOM keeps removing my queries after hitting OK. My query could be more precise if I could use a "Starts with .. " option.

Thanks in advance!

January 28th, 2014 7:04am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics