DFS between 2 SQL Failover clusters a seperate sites

I have 2 clusters running without issues. 1 is located in a branch office and 1 is located in our datacenter.  These clusters are providing a HA SQL 2008 R2 services. At the branch site we have a nightly backup that dumps to a backup drive. That drive is a resource of the SQL Application. This works great as no matter what server is currently active it owns the shared backed drive.

I want to use DFS to move that backup to a datacenter now. Here's what I did

1) I added the Files servers (dfs, and replication) to both nodes at the remote site, and both nodes in the Datacenter

2) Added the file server resource to the SQL application group at the remote site and created a "replicate" share

3) added the files server resource to the SQL application group at the datacenter and added a "replicate" share

4) Now I try to create the replication group. I think I have to use the SQL client access point. When I do it seems to accept it but when I have to specify the "Add a folder to replicate", I get an error "myserver.mydomain.com: It is not possible to enumerate the physical disk drives in the cluster resource group. The cluster group could not be found". The folder I am trying to add is G:\replicate. I can map a drive remotely to \\branchserver\replicate without any problems. Failover works great but I can't add it as a replicate target.

Just a note, I tried the actual host name of the remote site server to no avail. I also tried the cluster name to no avail

The SQL Client Access point gets me the furthest but I still get the enumeration error.

Any help would be greatly appreciated. Thanks,

March 20th, 2014 7:57pm


The steps will be different on set DFSR on cluster. Please see if the steps in this article could help:

Deploying DFS Replication on a Windows Failover Cluster


Free Windows Admin Tool Kit Click here and download it now
March 23rd, 2014 2:02pm

I have followed the instructions, but I am still having issues. Also I am performing these tasks on Windows Server 2012 R2 Cluster. I have tried both using the GUI and Powershell commands.

No matter which method I use I get "Path is not valid. The cluster group could not be found".

When I add the cluster resource client access name, it does allow me to browse the to the target. However, when I click the OK button, it throws the error.

The target is a Dell EqualLogic iSCSI LUN. It is properly connected and I browse the target via Windows Explorer (N:)

October 19th, 2014 7:58pm


Did you solved it somehow?

I'm experiencing the same error. DFS replication from Cluster disks (hosted on 2 nodes) and single server. All 3 servers are HW with fresh 2012R2 with FO Cluster and DFS.

Free Windows Admin Tool Kit Click here and download it now
March 16th, 2015 7:23am

We do have same problem. Can you let us know how it got fixed?
August 20th, 2015 1:55am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics