Can't view or edit Application Insights webtests in the new Azure Portal

I'm in the process of setting up Application Insights for an Azure Cloud Services Web Role.  Things have been looking good so far - I've enabled App Insights telemetry to the VS2013 solution, configured correctly and am getting usage/monitoring data displayed in the NEW Azure Portal (portal.azure.com).

I set up my first "webtest" on Friday to monitor the site availability from three separate locations around the world and alert when down; however, logging in today shows my webtests graph as blank, i.e. contains no data. 

Usually, when this is the case, there's a link provided to create new webtests, but since I've already added a webtest, this is no longer the case.  So I can neither view or edit my existing webtest, nor create a new one.  I have tried clearing my browser private data and even use a different browser but the result is the same.  I have also tried deleting and recreating the Application Insights instance with the same name but the result is the same (although the data from the deleted instance remains...).  My only recourse is to create a new, differently named Application Insights instance and set it all up again, losing the telemetry collected so far.  This isn't such a big deal during the prototype stage, but when this goes into effect on the production site, deleting and starting from scratch whenever there's a webtests problem isn't going to be an option.

How do I view/edit/clear existing webtests?  Is it possible to do this through Azure PowerShell or the Azure SDK?

October 7th, 2014 7:45pm

Hi Chris Haigh,

We are working on this thread and will try to reply with the proper resolution as soon as possible.

Regards,
Azam khan

Free Windows Admin Tool Kit Click here and download it now
October 7th, 2014 9:14pm

It's been four months, any updates?
February 11th, 2015 2:44am

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics