tmp files Filling Up C:\windows\temp Folder
Since a reboot of our Exchange 2007 SP3 server on Monday the C:\windows\temp folder has been filling up with temp files called ifsXXX.tmp. There are tens of thousands of them and they are all open by store.exe. They can't even be deleted until the server is once more rebooted and store.exe lets go of them. Why are these files all suddenly being created and not deleted?Hibs Ya Bass!
May 25th, 2011 9:12pm

Hi Hibs, Do you have any other software installed, such as backup agents or Anti virus? Have you made any recent changes to the server. First point of call to find out what process has those .tmp files open would be one of the sysinternals tools, such asProcess Explorer . Meanwhile You can change TEMP to use another folder elsewhere. Just create a new folder, and then in the System Control Panel, click on Advanced, Environment Variables and change TEMP to point to the new location. Restart services. More info : http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1136375,00.html http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/c175e70d-e9bb-4b71-a65d-ead75f4e6e03/ Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2011, My Blog : http://messagingschool.wordpress.com
Free Windows Admin Tool Kit Click here and download it now
May 26th, 2011 12:18am

Hi Hibs, Do you have any other software installed, such as backup agents or Anti virus? Have you made any recent changes to the server. First point of call to find out what process has those .tmp files open would be one of the sysinternals tools, such asProcess Explorer . Meanwhile You can change TEMP to use another folder elsewhere. Just create a new folder, and then in the System Control Panel, click on Advanced, Environment Variables and change TEMP to point to the new location. Restart services. More info : http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1136375,00.html http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/c175e70d-e9bb-4b71-a65d-ead75f4e6e03/ Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2011, My Blog : http://messagingschool.wordpress.com There is AV on the server but it has always been there. The only new software would be windows updates. As I said in the OP store.exe has all of these files open (I used Process Explorer for this). Also, 90% of the files are 0KB but some of theem can be up to12 MB in size. Hibs Ya Bass!
May 26th, 2011 1:23pm

Hi Hibs, Do you have any other software installed, such as backup agents or Anti virus? Have you made any recent changes to the server. First point of call to find out what process has those .tmp files open would be one of the sysinternals tools, such asProcess Explorer . Meanwhile You can change TEMP to use another folder elsewhere. Just create a new folder, and then in the System Control Panel, click on Advanced, Environment Variables and change TEMP to point to the new location. Restart services. More info : http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1136375,00.html http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/c175e70d-e9bb-4b71-a65d-ead75f4e6e03/ Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2011, My Blog : http://messagingschool.wordpress.com There is AV on the server but it has always been there. The only new software would be windows updates. As I said in the OP store.exe has all of these files open (I used Process Explorer for this).Hibs Ya Bass!
Free Windows Admin Tool Kit Click here and download it now
May 26th, 2011 1:24pm

Hi Hibs, Do you have any other software installed, such as backup agents or Anti virus? Have you made any recent changes to the server. First point of call to find out what process has those .tmp files open would be one of the sysinternals tools, such asProcess Explorer . Meanwhile You can change TEMP to use another folder elsewhere. Just create a new folder, and then in the System Control Panel, click on Advanced, Environment Variables and change TEMP to point to the new location. Restart services. More info : http://searchexchange.techtarget.com/tip/0,289483,sid43_gci1136375,00.html http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/c175e70d-e9bb-4b71-a65d-ead75f4e6e03/ Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2011, My Blog : http://messagingschool.wordpress.com This morning i disabled AV but that didn't help. However when I stopped the Information Store service all of the latest temp files disappeared (this didn't happen yesterday with all the temp files dating back to Monday). I then started the Information store service and within 3 mins all the temp files started accumulating again.Hibs Ya Bass!
May 26th, 2011 1:57pm

Do you have any Macentourage users connecting to your system? This was a known issue in that circumstance: http://social.technet.microsoft.com/Forums/en-IE/exchangesvrgeneral/thread/005edc90-2e98-44b4-b5c9-2719873ffc15TBrennan
Free Windows Admin Tool Kit Click here and download it now
May 26th, 2011 2:05pm

Do you have any Macentourage users connecting to your system? This was a known issue in that circumstance: http://social.technet.microsoft.com/Forums/en-IE/exchangesvrgeneral/thread/005edc90-2e98-44b4-b5c9-2719873ffc15 TBrennan That is EXACTLY what is happening here but we don't have any Mac User using exchange. We're also running Exchange 2007 (SP3) so I'm not sure if the reference to .stm file relevant or not?Hibs Ya Bass!
May 26th, 2011 5:13pm

Hi Do your user send email through abnormal email software ? Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
Free Windows Admin Tool Kit Click here and download it now
May 26th, 2011 7:40pm

Hi Do your user send email through abnormal email software ? Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Not that I'm aware. Everyone uses either Outlook 2003/2007 or OWA. Definitely no Mac users.Hibs Ya Bass!
May 26th, 2011 7:55pm

Hi Are you convenient to run exbpa to test your configuration? I just talk about your thread with my colleagues. It is heard that some special email software or some special format html email will cause this issue. Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
Free Windows Admin Tool Kit Click here and download it now
May 27th, 2011 1:11am

Hi Are you convenient to run exbpa to test your configuration? I just talk about your thread with my colleagues. It is heard that some special email software or some special format html email will cause this issue. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Actually, now I come to think of it we have a few users using an application on their mobile phones called Nokia for Exchange. Maybe this could be the culprit?Hibs Ya Bass!
May 29th, 2011 1:06pm

Hi 3 rd software may cause this kind of problem. It is proper reason. In fact, we always run EXBPA to check exchange. If the issue doesn’t affect exchange performance, we always ignore it.Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
Free Windows Admin Tool Kit Click here and download it now
May 29th, 2011 6:22pm

Hi Maybe I don’t explain it clearly. My suggestion is to check healthy. If the result is “pass”, I can know that not misconfiguration causes the tmp issue. No special tool or program can check tmp issue. Please remember to click Mark as Answer on the post that helps you, and to click Unmark as Answer if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
May 29th, 2011 9:47pm

Hi Maybe I don’t explain it clearly. My suggestion is to check healthy. If the result is “pass”, I can know that not misconfiguration causes the tmp issue. No special tool or program can check tmp issue. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Health Check was fine.Hibs Ya Bass!
Free Windows Admin Tool Kit Click here and download it now
May 29th, 2011 9:49pm

Hi 3 rd software may cause this kind of problem. It is proper reason. In fact, we always run EXBPA to check exchange. If the issue doesn’t affect exchange performance, we always ignore it. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Which EXBPA report are you talking about. The Health Check?Hibs Ya Bass!
May 29th, 2011 10:53pm

yeah Best Practices Analyzer Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
Free Windows Admin Tool Kit Click here and download it now
May 29th, 2011 10:55pm

yeah Best Practices Analyzer Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Yeah, but which scan in EXBPA would help me with this problem, Health Check, Permission Check, Connectivity test or Baseline? I've already run Health Check but there is no mention of the issue with the tmp files.Hibs Ya Bass!
May 29th, 2011 11:11pm

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics